VirtualBox

Ticket #11143 (reopened defect)

Opened 7 years ago

Last modified 8 months ago

vboxmanage startvm fails with E_ACCESSDENIED

Reported by: brian.king Owned by:
Component: other Version: VirtualBox 4.2.4
Keywords: Cc:
Guest type: other Host type: other

Description

I upgraded from VirtualBox 4.1.x to 4.2.4 and now I am unable to start VMs from batch files using the command line.

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe startvm b7a6f624-1fe0-43e7-b0ce-75f2de26a80e VBoxManage.exe: error: The object functionality is limited VBoxManage.exe: error: Details: code E_ACCESSDENIED (0x80070005), component Machine, interface IMachine, callee IUnknown VBoxManage.exe: error: Context: "LaunchVMProcess(a->session, sessionType.raw(),env.raw(), progress.asOutParam())" at line 580 of file VBoxManageMisc.cpp

I am running the command as the administrator (as I always have). I am running on a Windows 7 host.

I can start my VMs fine from the GUI, and I can list the VMs and their properties fine from the command line.

Attachments

VBoxSVC.log Download (685 bytes) - added by kpiq 6 years ago.
VBox.log Download (157.9 KB) - added by kpiq 6 years ago.

Change History

comment:1 Changed 7 years ago by brian.king

The issue is still present in 4.2.6. The command line doesn't work to start VMs, unless the GUI is running.

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe list vms
"WinXP-GNB" {b7a6f624-1fe0-43e7-b0ce-75f2de26a80e}
"WinXP-GNB-2" {fe4142d7-ed4f-4eaf-adcc-1b49f6dfc71b}
"WinXP-AndroidDev" {8eca831f-49f1-40de-a207-391cf422748d}
"WinXP-GNB-20121029b" {130ac48b-c10e-4d17-8d02-d16c4a947b0b}

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe startvm "WinXP-GNB"
VBoxManage.exe: error: Could not find a registered machine named 'WinXP-GNB'
VBoxManage.exe: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee IUnknown
VBoxManage.exe: error: Context: "FindMachine(Bstr(pszVM).raw(), machine.asOutParam())" at line 563 of file VBoxManageMisc.cpp

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe startvm b7a6f624-1fe0-43e7-b0ce-75f2de26a80e
VBoxManage.exe: error: The object functionality is limited
VBoxManage.exe: error: Details: code E_ACCESSDENIED (0x80070005), component Machine, interface IMachine, callee IUnknown
VBoxManage.exe: error: Context: "LaunchVMProcess(a->session, sessionType.raw(),env.raw(), progress.asOutParam())" at line 580 of file VBoxManageMisc.cpp

Start the VBox GUI Launcher as Administrator -- Then the same commands work fine

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe startvm b7a6f624-1fe0-43e7-b0ce-75f2de26a80e
Waiting for VM "b7a6f624-1fe0-43e7-b0ce-75f2de26a80e" to power on...
VM "b7a6f624-1fe0-43e7-b0ce-75f2de26a80e" has been successfully started.
Last edited 7 years ago by frank (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 7 years ago by frank

Looks indeed like some permission problem. Where is the directory located which contains the VM settings? And does the non-admin user has write access to every file inside that directory?

comment:3 in reply to: ↑ 2 Changed 7 years ago by brian.king

Replying to frank:

Looks indeed like some permission problem. Where is the directory located which contains the VM settings? And does the non-admin user has write access to every file inside that directory?

The settings are in the normal user directory (C:\users\$username\.VirtualBox), but I am running all commands as Administrator when I am getting these access denied errors.

I think this might be related to VBoxSVC.exe. I noticed that there used to be a process "VBoxSVC.exe" running whenever I started my VMs from a batch file. Now that process is gone. Looking in the logs directory (\Users\xxxx\.VirtualBox), I can see that for every attempt I made to start a VM without the GUI running, I have a VBoxSVC.log with similar errors to what I see when starting the VM Fails.

I also see a VBoxSVC.log that is being actively written to, when I start the virtual box GUI, and it has similar messages but ends up being successful. Has the VBoxSVC function been moved into the GUI, and the old VBoxSVC broken?

Successful startup, vboxsvc.log from virtual box GUI

00:00:01.264000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB\WinXP-GNB.xml" with version "1.9-windows"
00:00:01.310000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={Could not find an open hard disk with UUID {1e353aae-dbf3-4d7b-b630-8a9bc1c9ba7c}}, preserve=false
00:00:01.326000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB-2\WinXP-GNB-2.xml" with version "1.9-windows"
00:00:01.373000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={Could not find an open hard disk with UUID {a4c517be-e248-4991-aa57-63963ababfdb}}, preserve=false
00:00:01.388000          Loading settings file "C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-AndroidDev\WinXP-AndroidDev.vbox" with version "1.12-windows"
00:00:01.466000          Loading settings file "C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-GNB-20121029b\WinXP-GNB-20121029b.vbox" with version "1.12-windows"
00:00:03.853000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB\WinXP-GNB.xml" with version "1.9-windows"
00:00:03.978000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB-2\WinXP-GNB-2.xml" with version "1.9-windows"
00:07:20.172000          ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={SessionMachine} aText={Saved screenshot data is not available (VERR_NOT_SUPPORTED)}, preserve=false
00:07:21.561000 Medium::Task ERROR [COM]: aRC=VBOX_E_INVALID_OBJECT_STATE (0x80bb0007) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB-2\Snapshots\{a4c517be-e248-4991-aa57-63963ababfdb}.vdi' is not locked for writing}, preserve=false
00:12:11.317000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-AndroidDev\WinXP-AndroidDev-disk1.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-GNB-20121029b\Snapshots/{f8d55deb-06cb-4cbf-b487-9a9612975211}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:12:11.333000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Cannot close medium 'C:\UnsecureData\VirtualBoxImages\WinXP-GNB-20121029-disk1.vdi' because it has 1 child media}, preserve=false
00:12:11.364000 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

Failed startup vboxsvc.log without the GUI

00:00:22.449000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB\WinXP-GNB.xml" with version "1.9-windows"
00:00:22.449000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={Could not find an open hard disk with UUID {1e353aae-dbf3-4d7b-b630-8a9bc1c9ba7c}}, preserve=false
00:00:22.449000          Loading settings file "C:\Users\br06298\.VirtualBox\Machines\WinXP-GNB-2\WinXP-GNB-2.xml" with version "1.9-windows"
00:00:22.449000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={Could not find an open hard disk with UUID {a4c517be-e248-4991-aa57-63963ababfdb}}, preserve=false
00:00:22.449000          Loading settings file "C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-AndroidDev\WinXP-AndroidDev.vbox" with version "1.12-windows"
00:00:22.449000          Loading settings file "C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-GNB-20121029b\WinXP-GNB-20121029b.vbox" with version "1.12-windows"
00:00:22.464000          ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object functionality is limited}, preserve=false
00:00:22.464000          ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object functionality is limited}, preserve=false
00:00:22.464000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={Could not find a registered machine named 'WinXP-GNB-2'}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-AndroidDev\WinXP-AndroidDev-disk1.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium 'C:\Documents and Settings\br06298\VirtualBox VMs\WinXP-GNB-20121029b\Snapshots/{f8d55deb-06cb-4cbf-b487-9a9612975211}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={22781af3-1c96-4126-9edf-67a020e0e858} aComponent={Machine} aText={The object is not ready}, preserve=false
00:00:27.472000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Cannot close medium 'C:\UnsecureData\VirtualBoxImages\WinXP-GNB-20121029-disk1.vdi' because it has 1 child media}, preserve=false
00:00:27.472000 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

comment:4 Changed 6 years ago by kpiq

Similar issue. Vboxsvc.exe service fails to start and "headless" VMs refuse to start. VMs do start while Virtualbox console is open but they crash when Virtualbox console is closed (the whole story is, if you close the console while a VM is running, vboxsvc service stops and the VM crashes).

Result Code: E_ACCESSDENIED (0x80070005) Component: Machine Interface: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

Changed 6 years ago by kpiq

Changed 6 years ago by kpiq

comment:5 Changed 6 years ago by kpiq

uninstalled and reinstalled. Vboxsvc didnt get added as a service

comment:6 Changed 6 years ago by Lucas Malor

I have the same problem in Linux, and it's because when I start the VM as root, the owner of its .vbox file changes to root. My workaround is to do after running VM as root:

sudo chown -R USERNAME:USERNAME "/home/USERNAME/VirtualBox VMs/"

Probably you have to regrant permissions to the unprivileged user in Windows as well.

This is an annoying bug, since I have to start VM as root when I want to use USB devices, since Virtualbox doesn't recognize USB devices without root privileges.

Last edited 6 years ago by Lucas Malor (previous) (diff)

comment:7 Changed 6 years ago by lkj

Guests start from the GUi for me but I have instances of this error in the VBoxSVC.logs for multiple machines.

ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Medium '/Applications/VMs/openSUSE 132/openSUSE 1032.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false

OSX 10.9.2 VB 4.3.10

comment:8 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:9 Changed 20 months ago by AshokMazumder

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I am having the same issue with VirtualBox release 5.2.8. Invested 2hr time to setup the box, applied windows license also. After rebooting the pc when I am trying to start the virtual box it throws error.

9d4.9d8: Log file opened: 5.2.8r121009 g_hStartupLog=0000000000000068 g_uNtVerCombined=0xa03ad700
9d4.9d8: \SystemRoot\System32\ntdll.dll:
9d4.9d8:     CreationTime:    2017-03-18T20:57:39.201977500Z
9d4.9d8:     LastWriteTime:   2017-03-18T20:57:39.201977500Z
9d4.9d8:     ChangeTime:      2018-04-04T04:47:42.181105700Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x1d7450
9d4.9d8:     NT Headers:      0xe0
9d4.9d8:     Timestamp:       0xb79b6ddb
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0xb79b6ddb
9d4.9d8:     Image Version:   10.0
9d4.9d8:     SizeOfImage:     0x1db000 (1945600)
9d4.9d8:     Resource Dir:    0x170000 LB 0x69398
9d4.9d8:     [Version info resource found at 0xd8! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x1700f0 LB 0x380, codepage 0x0 (reserved 0x0)]
9d4.9d8:     ProductName:     Microsoft® Windows® Operating System
9d4.9d8:     ProductVersion:  10.0.15063.0
9d4.9d8:     FileVersion:     10.0.15063.0 (WinBuild.160101.0800)
9d4.9d8:     FileDescription: NT Layer DLL
9d4.9d8: \SystemRoot\System32\kernel32.dll:
9d4.9d8:     CreationTime:    2017-03-18T20:57:15.887502700Z
9d4.9d8:     LastWriteTime:   2017-03-18T20:57:15.887502700Z
9d4.9d8:     ChangeTime:      2018-04-04T04:47:39.931076300Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0xad068
9d4.9d8:     NT Headers:      0xf8
9d4.9d8:     Timestamp:       0x17a3637d
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x17a3637d
9d4.9d8:     Image Version:   10.0
9d4.9d8:     SizeOfImage:     0xae000 (712704)
9d4.9d8:     Resource Dir:    0xac000 LB 0x520
9d4.9d8:     [Version info resource found at 0x90! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0xac0b0 LB 0x3a4, codepage 0x0 (reserved 0x0)]
9d4.9d8:     ProductName:     Microsoft® Windows® Operating System
9d4.9d8:     ProductVersion:  10.0.15063.0
9d4.9d8:     FileVersion:     10.0.15063.0 (WinBuild.160101.0800)
9d4.9d8:     FileDescription: Windows NT BASE API Client DLL
9d4.9d8: \SystemRoot\System32\KernelBase.dll:
9d4.9d8:     CreationTime:    2017-03-18T20:57:35.951701900Z
9d4.9d8:     LastWriteTime:   2017-03-18T20:57:35.951701900Z
9d4.9d8:     ChangeTime:      2018-04-04T04:47:39.993574700Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x249bf0
9d4.9d8:     NT Headers:      0x100
9d4.9d8:     Timestamp:       0x461a0ff5
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x461a0ff5
9d4.9d8:     Image Version:   10.0
9d4.9d8:     SizeOfImage:     0x249000 (2396160)
9d4.9d8:     Resource Dir:    0x22a000 LB 0x548
9d4.9d8:     [Version info resource found at 0x90! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x22a0b0 LB 0x3bc, codepage 0x0 (reserved 0x0)]
9d4.9d8:     ProductName:     Microsoft® Windows® Operating System
9d4.9d8:     ProductVersion:  10.0.15063.0
9d4.9d8:     FileVersion:     10.0.15063.0 (WinBuild.160101.0800)
9d4.9d8:     FileDescription: Windows NT BASE API Client DLL
9d4.9d8: \SystemRoot\System32\apisetschema.dll:
9d4.9d8:     CreationTime:    2017-03-18T20:57:35.373527900Z
9d4.9d8:     LastWriteTime:   2017-03-18T20:57:35.373527900Z
9d4.9d8:     ChangeTime:      2018-04-04T04:47:21.446473600Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x1ada0
9d4.9d8:     NT Headers:      0xc0
9d4.9d8:     Timestamp:       0x76544b2
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x76544b2
9d4.9d8:     Image Version:   10.0
9d4.9d8:     SizeOfImage:     0x1b000 (110592)
9d4.9d8:     Resource Dir:    0x1a000 LB 0x408
9d4.9d8:     [Version info resource found at 0x48! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x1a060 LB 0x3a8, codepage 0x0 (reserved 0x0)]
9d4.9d8:     ProductName:     Microsoft® Windows® Operating System
9d4.9d8:     ProductVersion:  10.0.15063.0
9d4.9d8:     FileVersion:     10.0.15063.0 (WinBuild.160101.0800)
9d4.9d8:     FileDescription: ApiSet Schema DLL
9d4.9d8: NtOpenDirectoryObject failed on \Driver: 0xc0000022
9d4.9d8: supR3HardenedWinFindAdversaries: 0x3
9d4.9d8: \SystemRoot\System32\drivers\SysPlant.sys:
9d4.9d8:     CreationTime:    2017-11-29T08:50:43.541005400Z
9d4.9d8:     LastWriteTime:   2018-03-15T12:16:02.622294500Z
9d4.9d8:     ChangeTime:      2018-04-03T15:55:01.504909500Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x30548
9d4.9d8:     NT Headers:      0xf0
9d4.9d8:     Timestamp:       0x5a1adc8a
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x5a1adc8a
9d4.9d8:     Image Version:   5.0
9d4.9d8:     SizeOfImage:     0x31000 (200704)
9d4.9d8:     Resource Dir:    0x2f000 LB 0x49c
9d4.9d8:     [Version info resource found at 0x90! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x2f0b8 LB 0x3e4, codepage 0x4e4 (reserved 0x0)]
9d4.9d8:     ProductName:     Symantec CMC Firewall
9d4.9d8:     ProductVersion:  14.0.3856.1100
9d4.9d8:     FileVersion:     14.0.3856.1100
9d4.9d8:     FileDescription: Symantec CMC Firewall SysPlant
9d4.9d8: \SystemRoot\System32\sysfer.dll:
9d4.9d8:     CreationTime:    2017-11-29T08:50:43.395898800Z
9d4.9d8:     LastWriteTime:   2018-03-15T12:16:02.606653000Z
9d4.9d8:     ChangeTime:      2018-04-03T16:21:27.407406100Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x7cee8
9d4.9d8:     NT Headers:      0xf8
9d4.9d8:     Timestamp:       0x5a1adc96
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x5a1adc96
9d4.9d8:     Image Version:   0.0
9d4.9d8:     SizeOfImage:     0x95000 (610304)
9d4.9d8:     Resource Dir:    0x91000 LB 0x490
9d4.9d8:     [Version info resource found at 0x90! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x910b8 LB 0x3d8, codepage 0x4e4 (reserved 0x0)]
9d4.9d8:     ProductName:     Symantec CMC Firewall
9d4.9d8:     ProductVersion:  14.0.3856.1100
9d4.9d8:     FileVersion:     14.0.3856.1100
9d4.9d8:     FileDescription: Symantec CMC Firewall sysfer
9d4.9d8: \SystemRoot\System32\drivers\symevent64x86.sys:
9d4.9d8:     CreationTime:    2017-11-29T08:53:05.303638500Z
9d4.9d8:     LastWriteTime:   2017-11-29T08:53:04.933809100Z
9d4.9d8:     ChangeTime:      2018-04-03T15:55:01.504909500Z
9d4.9d8:     FileAttributes:  0x20
9d4.9d8:     Size:            0x190d0
9d4.9d8:     NT Headers:      0xe0
9d4.9d8:     Timestamp:       0x584f629e
9d4.9d8:     Machine:         0x8664 - amd64
9d4.9d8:     Timestamp:       0x584f629e
9d4.9d8:     Image Version:   6.2
9d4.9d8:     SizeOfImage:     0x23000 (143360)
9d4.9d8:     Resource Dir:    0x21000 LB 0x3c8
9d4.9d8:     [Version info resource found at 0x90! (ID/Name: 0x1; SubID/SubName: 0x409)]
9d4.9d8:     [Raw version resource data: 0x210b8 LB 0x310, codepage 0x4e4 (reserved 0x0)]
9d4.9d8:     ProductName:     SYMEVENT
9d4.9d8:     ProductVersion:  14.0.4.16
9d4.9d8:     FileVersion:     14.0.4.16
9d4.9d8:     FileDescription: Symantec Event Library
9d4.9d8: supR3HardenedWinInitAppBin(0x0): '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox'
9d4.9d8: Calling main()
9d4.9d8: SUPR3HardenedMain: pszProgName=VirtualBox fFlags=0x2
9d4.9d8: supR3HardenedWinInitAppBin(0x2): '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox'
9d4.9d8: SUPR3HardenedMain: Respawn #1
9d4.9d8: System32:  \Device\HarddiskVolume1\Windows\System32
9d4.9d8: WinSxS:    \Device\HarddiskVolume1\Windows\WinSxS
9d4.9d8: KnownDllPath: C:\WINDOWS\System32
9d4.9d8: '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe' has no imports
9d4.9d8: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe)
9d4.9d8: supR3HardNtEnableThreadCreation:
9d4.9d8: supR3HardNtDisableThreadCreation: pvLdrInitThunk=00007ff9068d9ad0 pvNtTerminateThread=00007ff906905e00
9d4.9d8: supR3HardenedWinDoReSpawn(1): New child 293c.2ac4 [kernel32].
9d4.9d8: supR3HardNtChildGatherData: PebBaseAddress=000000000086c000 cbPeb=0x388
9d4.9d8: supR3HardNtPuChFindNtdll: uNtDllParentAddr=00007ff906860000 uNtDllChildAddr=00007ff906860000
9d4.9d8: supR3HardenedWinSetupChildInit: uLdrInitThunk=00007ff9068d9ad0
9d4.9d8: supR3HardenedWinSetupChildInit: Start child.
9d4.9d8: supR3HardNtChildWaitFor: Found expected request 0 (PurifyChildAndCloseHandles) after 0 ms.
9d4.9d8: supR3HardNtChildPurify: Startup delay kludge #1/0: 515 ms, 33 sleeps
9d4.9d8: supHardNtVpScanVirtualMemory: enmKind=CHILD_PURIFICATION
9d4.9d8:  *0000000000000000-000000000076ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *0000000000770000-000000000078ffff 0x0004/0x0004 0x0020000
9d4.9d8:  *0000000000790000-00000000007a7fff 0x0002/0x0002 0x0040000
9d4.9d8:   00000000007a8000-00000000007affff 0x0001/0x0000 0x0000000
9d4.9d8:  *00000000007b0000-00000000007b3fff 0x0002/0x0002 0x0040000
9d4.9d8:   00000000007b4000-00000000007bffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00000000007c0000-00000000007c0fff 0x0004/0x0004 0x0020000
9d4.9d8:   00000000007c1000-00000000007fffff 0x0001/0x0000 0x0000000
9d4.9d8:  *0000000000800000-000000000086bfff 0x0000/0x0004 0x0020000
9d4.9d8:   000000000086c000-000000000086efff 0x0004/0x0004 0x0020000
9d4.9d8:   000000000086f000-00000000009fffff 0x0000/0x0004 0x0020000
9d4.9d8:  *0000000000a00000-0000000000afafff 0x0000/0x0004 0x0020000
9d4.9d8:   0000000000afb000-0000000000afdfff 0x0104/0x0004 0x0020000
9d4.9d8:   0000000000afe000-0000000000afffff 0x0004/0x0004 0x0020000
9d4.9d8:   0000000000b00000-000000007ffdffff 0x0001/0x0000 0x0000000
9d4.9d8:  *000000007ffe0000-000000007ffe0fff 0x0002/0x0002 0x0020000
9d4.9d8:  *000000007ffe1000-000000007ffeffff 0x0000/0x0002 0x0020000
9d4.9d8:   000000007fff0000-00007ff7bbf3ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bbf40000-00007ff7bbf62fff 0x0002/0x0002 0x0040000
9d4.9d8:   00007ff7bbf63000-00007ff7bc9effff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bc9f0000-00007ff7bc9f0fff 0x0040/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bc9f1000-00007ff7bca61fff 0x0020/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bca62000-00007ff7bca62fff 0x0080/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bca63000-00007ff7bcaa8fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcaa9000-00007ff7bcaa9fff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcaaa000-00007ff7bcaaafff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcaab000-00007ff7bcaaffff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcab0000-00007ff7bcab0fff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcab1000-00007ff7bcab1fff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcab2000-00007ff7bcab5fff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcab6000-00007ff7bcafdfff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcafe000-00007ff7bcafffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bcb00000-00007ff7bcb00fff 0x0004/0x0004 0x0020000
9d4.9d8:   00007ff7bcb01000-00007ff90685ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff906860000-00007ff906860fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906861000-00007ff90696ffff 0x0020/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906970000-00007ff9069b4fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069b5000-00007ff9069bcfff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069bd000-00007ff9069cafff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cb000-00007ff9069cbfff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cc000-00007ff9069cefff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cf000-00007ff906a3afff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906a3b000-00007ffffffdffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ffffffe0000-00007ffffffeffff 0x0001/0x0002 0x0020000
9d4.9d8: VirtualBox.exe: timestamp 0x5a942b95 (rc=VINF_SUCCESS)
9d4.9d8: '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe' has no imports
9d4.9d8: VirtualBox.exe: Differences in section #0 (headers) between file and memory:
9d4.9d8:   00007ff7bc9f0162 / 0x0000162: 00 != 11
9d4.9d8:   00007ff7bc9f0164 / 0x0000164: 00 != 14
9d4.9d8:   Restored 0x400 bytes of original file content at 00007ff7bc9f0000
9d4.9d8: '\Device\HarddiskVolume1\Windows\System32\ntdll.dll' has no imports
9d4.9d8: supR3HardNtChildPurify: cFixes=1 g_fSupAdversaries=0x3
9d4.9d8: supR3HardNtChildPurify: Startup delay kludge #1/1: 515 ms, 32 sleeps
9d4.9d8: supHardNtVpScanVirtualMemory: enmKind=CHILD_PURIFICATION
9d4.9d8:  *0000000000000000-000000000076ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *0000000000770000-000000000078ffff 0x0004/0x0004 0x0020000
9d4.9d8:  *0000000000790000-00000000007a7fff 0x0002/0x0002 0x0040000
9d4.9d8:   00000000007a8000-00000000007affff 0x0001/0x0000 0x0000000
9d4.9d8:  *00000000007b0000-00000000007b3fff 0x0002/0x0002 0x0040000
9d4.9d8:   00000000007b4000-00000000007bffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00000000007c0000-00000000007c0fff 0x0004/0x0004 0x0020000
9d4.9d8:   00000000007c1000-00000000007fffff 0x0001/0x0000 0x0000000
9d4.9d8:  *0000000000800000-000000000086bfff 0x0000/0x0004 0x0020000
9d4.9d8:   000000000086c000-000000000086efff 0x0004/0x0004 0x0020000
9d4.9d8:   000000000086f000-00000000009fffff 0x0000/0x0004 0x0020000
9d4.9d8:  *0000000000a00000-0000000000afafff 0x0000/0x0004 0x0020000
9d4.9d8:   0000000000afb000-0000000000afdfff 0x0104/0x0004 0x0020000
9d4.9d8:   0000000000afe000-0000000000afffff 0x0004/0x0004 0x0020000
9d4.9d8:   0000000000b00000-000000007ffdffff 0x0001/0x0000 0x0000000
9d4.9d8:  *000000007ffe0000-000000007ffe0fff 0x0002/0x0002 0x0020000
9d4.9d8:  *000000007ffe1000-000000007ffeffff 0x0000/0x0002 0x0020000
9d4.9d8:   000000007fff0000-00007ff7bbf3ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bbf40000-00007ff7bbf62fff 0x0002/0x0002 0x0040000
9d4.9d8:   00007ff7bbf63000-00007ff7bc9effff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bc9f0000-00007ff7bc9f0fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bc9f1000-00007ff7bca61fff 0x0020/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bca62000-00007ff7bca62fff 0x0040/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bca63000-00007ff7bcaa8fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcaa9000-00007ff7bcab5fff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcab6000-00007ff7bcafdfff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Program Files\Oracle\VirtualBox\VirtualBox.exe
9d4.9d8:   00007ff7bcafe000-00007ff7bcafffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff7bcb00000-00007ff7bcb00fff 0x0004/0x0004 0x0020000
9d4.9d8:   00007ff7bcb01000-00007ff90685ffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ff906860000-00007ff906860fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906861000-00007ff90696ffff 0x0020/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906970000-00007ff9069b4fff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069b5000-00007ff9069b8fff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069b9000-00007ff9069bcfff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069bd000-00007ff9069cafff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cb000-00007ff9069cbfff 0x0004/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cc000-00007ff9069cefff 0x0008/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff9069cf000-00007ff906a3afff 0x0002/0x0080 0x1000000  \Device\HarddiskVolume1\Windows\System32\ntdll.dll
9d4.9d8:   00007ff906a3b000-00007ffffffdffff 0x0001/0x0000 0x0000000
9d4.9d8:  *00007ffffffe0000-00007ffffffeffff 0x0001/0x0002 0x0020000
9d4.9d8: supR3HardNtChildPurify: Done after 1093 ms and 1 fixes (loop #1).
9d4.9d8: supR3HardNtEnableThreadCreation:
293c.2ac4: Log file opened: 5.2.8r121009 g_hStartupLog=0000000000000004 g_uNtVerCombined=0xa03ad700
293c.2ac4: supR3HardenedVmProcessInit: uNtDllAddr=00007ff906860000 g_uNtVerCombined=0xa03ad700
293c.2ac4: ntdll.dll: timestamp 0xb79b6ddb (rc=VINF_SUCCESS)
293c.2ac4: New simple heap: #1 0000000000c00000 LB 0x400000 (for 1945600 allocation)
293c.2ac4: supR3HardenedWinInitAppBin(0x0): '\Device\HarddiskVolume1\Program Files\Oracle\VirtualBox'
293c.2ac4: System32:  \Device\HarddiskVolume1\Windows\System32
293c.2ac4: WinSxS:    \Device\HarddiskVolume1\Windows\WinSxS
293c.2ac4: KnownDllPath: C:\WINDOWS\System32
293c.2ac4: supR3HardenedVmProcessInit: Opening vboxdrv stub...
293c.2ac4: Error opening VBoxDrvStub:  STATUS_OBJECT_NAME_NOT_FOUND
293c.2ac4: supR3HardenedWinReadErrorInfoDevice: NtCreateFile -> 0xc0000034
293c.2ac4: Error -101 in supR3HardenedWinReSpawn! (enmWhat=3)
293c.2ac4: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help.
9d4.9d8: supR3HardenedWinCheckChild: enmRequest=2 rc=-101 enmWhat=3 supR3HardenedWinReSpawn: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help.
9d4.9d8: Error -101 in supR3HardenedWinReSpawn! (enmWhat=3)
9d4.9d8: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help.

comment:10 follow-up: ↓ 11 Changed 19 months ago by socratis

@AshokMazumder
This is not even the same bug!!! You re-opened a ticket that has absolutely nothing to do with your problem. Please read carefully next time what each ticket is about.

You are having a hardening error, most probably due to Symantec. Uninstall it completely. If that doesn't work, open a new thread in the  VirtualBox on Windows Hosts section of the forums.

It's usually better and faster, if issues get first addressed in the  VirtualBox forums. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

comment:11 in reply to: ↑ 10 Changed 8 months ago by Levine

Replying to socratis: So, the final solution is to reinstall other versions of the software? I didn't find anything related to it in the forum.

@AshokMazumder
This is not even the same bug!!! You re-opened a ticket that has absolutely nothing to do with your problem. Please read carefully next time what each ticket is about.

You are having a hardening error, most probably due to Symantec. Uninstall it completely. If that doesn't work, open a new thread in the  VirtualBox on Windows Hosts section of the forums.

It's usually better and faster, if issues get first addressed in the  VirtualBox forums. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

comment:12 Changed 8 months ago by socratis

Levine, why reply so early? In 3 weeks we would have had the 1-year anniversary! :)

No, the answer is not to re-install older versions of the software, on the contrary. The answer is to install a version of the software that 1) is properly signed and 2) it has properly updated the Windows Certificate Database. For more information, read really carefully the following FAQ:  Diagnosing VirtualBox Hardening Issues for some generic guidelines/ideas.

PS. You didn't need to quote my whole message for a 1-line reply, it adds unnecessarily to the size of the ticket. ;)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use