VirtualBox

Ticket #11116 (new defect)

Opened 18 months ago

Last modified 4 weeks ago

drag and drop non function win7 64

Reported by: biggbitt Owned by:
Priority: minor Component: host support
Version: VirtualBox 4.2.2 Keywords: drag and drop
Cc: Guest type: Windows
Host type: Windows

Description

drag and drop does not work between win7 ultimate 64, and xp sp3 x86 guest.

host to guest results in the (X). guest to host result is the mouse will exit the guest, but the file icon will remain within the guest.

tried all all drag and drop options, none work. i have not yet tried removing the MS intellimouse driver from my host yet.

Change History

comment:1 Changed 18 months ago by aleksejs.ozolins

Same here. It wasn't working in 4.2 version and 4.2.2 neither.

comment:2 Changed 18 months ago by frank

As written in the changelog, drag and drop is currently only implemented for Linux guests. We will add support for more guests with future releases.

comment:3 Changed 17 months ago by Olaf

Here drag and drop does not work at all in a XP SP3 x86 guest (NOT from host to guest): one cannot drag files in windows explorer, emails in ms outlook and so on. It was ok in 4.1.22.

comment:4 follow-up: ↓ 5 Changed 17 months ago by frank

Olaf, did you enable drag'n'drop for that VM? If so, does the behavior change if you disable it?

comment:5 in reply to: ↑ 4 Changed 17 months ago by Olaf

Replying to frank:

Olaf, did you enable drag'n'drop for that VM? If so, does the behavior change if you disable it?

Frank, I just tried all 4 setting - none of them changed the behavior. On an other guest with the 4.1.22 guest additions still installed drag'n'drop works like a charm.

comment:6 Changed 14 months ago by geebee75

Drag'n'Drop also doesn't work between OSX Host and Win7 Pro guest, including on the Feb 2013 release. (4.2.8)

comment:7 Changed 14 months ago by frank

Yes, and the changelog items which mentions drag and drop also mentions that this is only supported for X11 guests right now.

comment:8 Changed 4 weeks ago by Jonathanwint

Yep I have the same Error I using fully installed 4.3.8 r92456 with extensions on a Fresh installed windows 7 host and using a XP pro updated install. "drag and drop" doesn't work in anyway disabled all my security.. I used VirtaulBox for many years and this first time had this issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use