VirtualBox

Ticket #11106 (closed defect: obsolete)

Opened 7 years ago

Last modified 3 years ago

Oracle Linux 6.3 x64 Guest freezes on shutdown & reboot

Reported by: gtin Owned by:
Component: other Version: VirtualBox 4.2.2
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Oracle Linux 6.3 x64 Guest Kernel 2.6.39.200 with guest additions running hangs on reboot and shutdown. The host system is windows 7 x64.

Attachments

VBox.log Download (74.9 KB) - added by gtin 7 years ago.

Change History

Changed 7 years ago by gtin

comment:1 Changed 7 years ago by frank

Does the same happen if you don't connect your OL6 guest to the host network interface (no networking or NAT)?

comment:2 Changed 7 years ago by gtin

If I disable network adapter in the vm settings and try to shutdown it still freezes

comment:3 Changed 7 years ago by frank

Does the guest hang or does the VM hang? In the latter case you cannot power-off the VM, you had to kill the process. In the former case this could be also a bug of your Linux guest.

comment:4 Changed 7 years ago by gtin

The VM freezes on halting system message from linux guest. I can not even move the vm window. I can try uninstalling guest editions and see if that fixes anything.

comment:5 Changed 7 years ago by gtin

As I suspected, uninstalling the guest additions for virtual box fixes the freezing issue.

comment:6 Changed 7 years ago by gtin

forgot to mention that I am using oraclelinux UEK version

comment:7 Changed 7 years ago by frank

Hmm, if you even cannot move the VM window with the mouse then does actually your host freeze? Also, do you experience these freezes with the Guest Additions installed but with only one guest core? Unfortunately we cannot reproduce these freezes.

comment:8 Changed 7 years ago by gtin

The host does not freeze. I have to kill the guest windows using windows task manager. This only happens with the guest addition installed. It is interesting notice that with oracle linux latest uek kernel 2.6.39.200 you do not get the header files that matches the same source code. The header version did not match the devel version. kernel-uek-headers = 2.6.32-300.38.1.el6uek.x86_64 kernel-uek-devel = 2.6.39-200.34.1.el6uek.x86_64

Also when installing guest additions it mentions that it could not find the headers probably because of the version mismatch in oracle repositories. Even though it can not find the headers it compiles all the modules without errors but the only integration that works is mouse integration

comment:9 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use