VirtualBox

Ticket #11044 (closed defect: fixed)

Opened 19 months ago

Last modified 5 months ago

REGRESSION: Guest session count doesn't decrement => Fixed in SVN

Reported by: Blrfl Owned by:
Priority: critical Component: guest control
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

On a RHEL 5.8 host and a guest running the same with Guest Additions 4.2.0, I am unable to execute programs on the guest more than 32 times:

VBoxManage guestcontrol foo execute /bin/true --username bar --password baz --wait-exit

On any run after 32, I get the following error:

VBoxManage: error: Maximum number of guest sessions (32) reached.

...and the following error in the guest's log:

00:01:16.254389 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={19c32350-0618-4ede-b0c3-2b4311bf0d9b} aComponent={Guest} aText={Maximum number of guest sessions (32) reached}, preserve=false

Observations:

  • The guest process runs to completion and VBoxManage exits on its own.
  • There is no trace of the process on the guest after it exits (as expected).
  • Whether or not the guest execution service is ready doesn't appear to make a difference. I can run it 32 times when the guest is first starting up (and get the expected "not ready" error), after it's up and running or any combination of both.
  • Shutting the guest down and restarting it resets the counter.

This worked fine in 4.1.4.

If you need additional information, please append it to this ticket and I'll provide it.

Thanks.

Change History

comment:1 Changed 17 months ago by frank

Still relevant with VBox 4.2.4 including the 4.2.4 Guest Additions?

comment:2 Changed 16 months ago by Blrfl

I'll have to whip up a system to test it out and will add a definitive thumbs-up/down.

Since nothing related to that has appeared in the changelogs for any release since, I would assume this is still a bug.

comment:3 Changed 9 months ago by Aiko Mastboom

Just experienced the same error,

Ubuntu Lucid host, VirtualBox 4.2.16

Windows Vista client

after reverting back to 4.1.26, all OK.

comment:4 Changed 9 months ago by dmco

We are experiencing the same issue with VirtualBox 4.2.16.

comment:5 Changed 5 months ago by frank

  • Summary changed from REGRESSION: Guest session count doesn't decrement to REGRESSION: Guest session count doesn't decrement => Fixed in SVN

This problem will be fixed in the next 4.3.x maintenance release.

comment:6 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use