VirtualBox

Ticket #1104 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

invalid symlink prevents directory from being listed

Reported by: ugemkow Owned by:
Priority: minor Component: shared folders
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

We are using Linux host and Windows XP guest with newest guest additions installed. We are using shared folder and have seen the following problem:

When in a subdirectory of a shared folder root a symlink is created which points to a file in the same directory which does not exist, an error happens when this directory is explored in the guest.

The following sequence shows this bug:

  • Create a subdirectory in a shared folder
    mkdir test
    cd test
  • create a file in this subdirectory and a symlink to this file
    touch test.txt
    ln -s test.txt test.txt.lnk
  • Explore this folder in the guest, all works and is displayed as expected
  • now rename the file the link points to
    mv test.txt test.txt.save
  • Now explore this folder again, this gives the error "Directory not accessible" in the guest

Change History

comment:1 Changed 6 years ago by frank

We still were not able to reproduce this problem. You might want to try VBox 1.5.6 to check if something changed.

comment:2 Changed 6 years ago by frank

  • Component changed from other to shared folders

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use