VirtualBox

Opened 11 years ago

Closed 10 years ago

#11038 closed defect (fixed)

OSX USB wont connect; log file in /Applications => fixed in SVN

Reported by: Charles B. Mc Kennie Owned by:
Component: USB Version: VirtualBox 4.2.0
Keywords: Cc:
Guest type: Windows Host type: Mac OS X

Description


Attachments (22)

vbox_usb_doc01.zip (496.6 KB ) - added by Charles B. Mc Kennie 11 years ago.
Zipped folder:subfolders before started, after,
vbox_usb_doc02.zip (409.7 KB ) - added by Charles B. Mc Kennie 11 years ago.
zipped folder: logs. etc.
vbox_usb_doc03.zip (449.7 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-11-14 at 1.44.09 PM.png.zip (171.9 KB ) - added by Charles B. Mc Kennie 11 years ago.
VB_Filter - Blowout.png (61.7 KB ) - added by Charles B. Mc Kennie 11 years ago.
Filter causing VBoxSVC to disappear
VB_Filter - No Blowout.png (58.4 KB ) - added by Charles B. Mc Kennie 11 years ago.
Filter that not causes VBoxSVC to disappear
Logs.zip (37.0 KB ) - added by Charles B. Mc Kennie 11 years ago.
Folder Logs
VirtualBox.zip (3.1 KB ) - added by Charles B. Mc Kennie 11 years ago.
From folder VirtualBox
2012-12-21-05-23-44.021-VBoxSVC-1627.log (142 bytes ) - added by Charles B. Mc Kennie 11 years ago.
file that appeared in folder /Applications
fromSystemLog.txt (1.8 KB ) - added by Charles B. Mc Kennie 11 years ago.
system log for time frame
Screen Shot 2012-12-21 at 12.19.07 AM.png (206.5 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.20.01 AM.png (141.1 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.20.54 AM.png (129.5 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.22.02 AM.png (216.9 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.22.21 AM.png (167.2 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.22.37 AM.png (129.0 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.23.29 AM.png (139.2 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.24.03 AM.png (196.3 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.25.17 AM.png (156.7 KB ) - added by Charles B. Mc Kennie 11 years ago.
Screen Shot 2012-12-21 at 12.26.01 AM.png (210.7 KB ) - added by Charles B. Mc Kennie 11 years ago.
VBoxSVC_present.png (42.9 KB ) - added by Charles B. Mc Kennie 11 years ago.
from activity monitor
VBoxSVC_not_present.png (42.4 KB ) - added by Charles B. Mc Kennie 11 years ago.
from activity monitor

Change History (52)

by Charles B. Mc Kennie, 11 years ago

Attachment: vbox_usb_doc01.zip added

Zipped folder:subfolders before started, after,

by Charles B. Mc Kennie, 11 years ago

Attachment: vbox_usb_doc02.zip added

zipped folder: logs. etc.

comment:1 by Charles B. Mc Kennie, 11 years ago

zipper folder vbox_usb_doc01: output before. started and after of following commands ls -l /Applications; system_profiler SPUSBDataType; VBoxManage list hostinfo; VBoxManage list usbhost; VBoxManage showvminfo "Win XP WDC Test 22280" and various screenshots showing Devices --> USB Devices

zipped folder vbox_usb_doc02: ~/library/VirtualBox contents (logs of VBoxSVC), contents of the virtual machine folder (with logs), file /Applications/2012-10-06-17-01-51.095-VBoxSVC-4341.log

by Charles B. Mc Kennie, 11 years ago

Attachment: vbox_usb_doc03.zip added

comment:2 by Charles B. Mc Kennie, 11 years ago

additional zipped folder vbox_usb_doc03 with screenshots of VirtualBox Manager showing effects of the overlay/overwrite of vb. VB is rendered useless until restarted, frequently a system restart/reboot is needed

Last edited 11 years ago by Charles B. Mc Kennie (previous) (diff)

comment:3 by Charles B. Mc Kennie, 11 years ago

Installed 4.2.4 and this still fails. Would a forced crash of VBoxSVC be worthwhile?

comment:4 by Charles B. Mc Kennie, 11 years ago

When I attempt to force VBoxSVC to give a crash report, I find that it has been terminated without any messages and without a crash report.

I am adding screenshot of Oracle VM Virtual Manager pane showing the loss of VBoxSVC.

Some suggestions . . .

Last edited 11 years ago by Charles B. Mc Kennie (previous) (diff)

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

Attachment: VB_Filter - Blowout.png added

Filter causing VBoxSVC to disappear

by Charles B. Mc Kennie, 11 years ago

Attachment: VB_Filter - No Blowout.png added

Filter that not causes VBoxSVC to disappear

comment:5 by Charles B. Mc Kennie, 11 years ago

Attach to screen images: USB Filters

  1. Settings that cause VBoxSVC to disappear
  2. Settings that do not cause VBoxSVC to disappear

by Charles B. Mc Kennie, 11 years ago

Attachment: Logs.zip added

Folder Logs

by Charles B. Mc Kennie, 11 years ago

Attachment: VirtualBox.zip added

From folder VirtualBox

by Charles B. Mc Kennie, 11 years ago

file that appeared in folder /Applications

by Charles B. Mc Kennie, 11 years ago

Attachment: fromSystemLog.txt added

system log for time frame

comment:6 by Charles B. Mc Kennie, 11 years ago

Additional filles from v4.2.6

Version 0, edited 11 years ago by Charles B. Mc Kennie (next)

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

by Charles B. Mc Kennie, 11 years ago

Attachment: VBoxSVC_present.png added

from activity monitor

by Charles B. Mc Kennie, 11 years ago

Attachment: VBoxSVC_not_present.png added

from activity monitor

comment:7 by Charles B. Mc Kennie, 11 years ago

OS X Mountain Lion 10.8.2 is being used

comment:8 by Charles B. Mc Kennie, 11 years ago

no change/improvement with v4.2.8 and as always, CPU = 1

comment:9 by Charles B. Mc Kennie, 11 years ago

no change/improvement with v4.2.10

no change/improvement with v4.2.12 - process VBoxSVC quits: no message, no log; as always, CPU = 1

Last edited 11 years ago by Charles B. Mc Kennie (previous) (diff)

comment:10 by Charles B. Mc Kennie, 11 years ago

no change/improvement with v4.2.14 - process VBoxSVC quits: no message, no log; as always, CPU = 1

Host is now 10.8.4 Mountain Lion

Last edited 11 years ago by Charles B. Mc Kennie (previous) (diff)

comment:11 by Charles B. Mc Kennie, 11 years ago

now using v4.2.16 on OSX 10.8.4 and no change

now using v4.2.18 on OSX 10.8.4 and no change

now using v4.3.0 on OSX 10.8.5 and no change

now using v4.3.2 on OS X 10.9.0 and no change

Last edited 10 years ago by Charles B. Mc Kennie (previous) (diff)

comment:12 by Charles B. Mc Kennie, 10 years ago

now using v4.3.4 on OS X 10.9.0 and no change. Blowout!

now using v4.3.6 on OS X 10.9.1 and no change - big overlay/blowout still

Last edited 10 years ago by Charles B. Mc Kennie (previous) (diff)

comment:13 by Charles B. Mc Kennie, 10 years ago

now using VB v4.3.8 on OS X 10.0.2 and still VBoxSVC quits.

comment:14 by galitsyn, 10 years ago

Can't reproduce the issue here. Could you please specify the exact steps to reproduce?

comment:15 by Charles B. Mc Kennie, 10 years ago

using external USB hard drive (not flash/stick drive)

Fill in Filter as shown in https://www.virtualbox.org/attachment/ticket/11038/VB_Filter%20-%20Blowout.png

After saving (OKing) the filter, unplug the external hard drive

Start up the Virtual Machine, Windows XP in my case

After Windows has settled, plug in the USB external hard drive

and the fun begins as you attempt to attach the device

Do notice https://www.virtualbox.org/attachment/ticket/11038/VB_Filter%20-%20No%20Blowout.png because VBocxSVC does not quit if the filter is as shown

comment:16 by galitsyn, 10 years ago

Thank you for the steps. Was able to reproduce the issue. Will look how it can be fixed.

comment:17 by Charles B. Mc Kennie, 10 years ago

now using VB v4.3.10 on OS X 10.9.2 and still VBoxSVC quits V4.3.10 to be replaced

now using VB v4.3.10 r93012 on OS X 10.9.2 and still VBoxSVC quits

Last edited 10 years ago by Charles B. Mc Kennie (previous) (diff)

comment:18 by galitsyn, 10 years ago

Could you please try this test build and confirm the issue has been resolved for you? https://www.virtualbox.org/download/testcase/VirtualBox-4.3.11-93500-OSX.dmg

NOTE: you need to re-create USB Device filter!

Last edited 10 years ago by galitsyn (previous) (diff)

in reply to:  18 comment:19 by Charles B. Mc Kennie, 10 years ago

Replying to galitsyn:

Could you please try this test build and confirm the issue has been resolved for you? https://www.virtualbox.org/download/testcase/VirtualBox-4.3.11-93500-OSX.dmg

NOTE: you need to re-create USB Device filter!

VBoxSVC does not blow out - an improvement.

BUT

No USB device is presented to the Guest; No stick, no external hard drive

Testing using v4.3.10 extension pack

comment:20 by Charles B. Mc Kennie, 10 years ago

For SnG, replaced .11Testing with 4.3.10 with extension pack and tested with the 'new" filters. Results: No VBoxSVC quitting, but no access by the Guest to the device

comment:22 by Charles B. Mc Kennie, 10 years ago

No. Cant attach any thing

comment:23 by galitsyn, 10 years ago

Please make sure if no partition which belongs to USB storage device is mounted to the host (USB device should not be in use by host).

comment:24 by Charles B. Mc Kennie, 10 years ago

  1. Install .11Testing
  2. Delete all USB filters for a VM
  3. Create new USB filters for a VM
    1. USB stick
    2. USB hard drive
  4. Unpliug target USB devices
  5. Start the VM
  6. Start testing
    1. plug in USB hard drive - no attach to VM and not connected to OSX
    2. plug in USB stick - no attach to VM and not connected to OSX
    3. VBoxSVC did not quit
  7. Shutdown the VM
  8. Stop VBox
  9. USB devices are connected to OSX
Last edited 10 years ago by Charles B. Mc Kennie (previous) (diff)

comment:25 by galitsyn, 10 years ago

Could you please attach your VM config, "ioreg -l" output and "VBoxManage list usbhost" obtained on stage (6c). Also, please specify USB devices Vendor and Product IDs.

On stage 6c, are you able to see specified devices in VM menu -> Devices -> USB Devices? Able to check them?

comment:26 by Charles B. Mc Kennie, 10 years ago

Oh, confusion {mail on laptop, test on desktop)

  1. Install .4.3.11-93514
    1. Install Extension pack 4.3.10-93012
  2. Delete all USB filters for a VM
  3. Create new USB filters for the VM
    1. USB stick
    2. USB hard drive
  4. Eject and Unpliug target USB devices from OSX
  5. Start VM (Windows)
  6. Start testing
    1. plug in USB hard drive
      1. attach to VM
      2. Format a partition
      3. Safely Removed device
      4. Returned device to OSX (first time this worked for a hard drive ever)
    2. plug in USB stick
      1. attach to VM
      2. browsed the device
      3. Safely Removed device
      4. Returned device to OSX (always worked)
      5. Ejected device from OSX; attached to the VM again
      6. Safely Removed device
    3. VBoxSVC did not quit
  7. Shutdown the VM
  8. Stop VBox
  9. USB device connected to OSX

If you still want the lists, let me know

Last edited 10 years ago by Charles B. Mc Kennie (previous) (diff)

comment:27 by galitsyn, 10 years ago

Sorry, does this mean the issue has been fixed for you?

in reply to:  27 comment:28 by Charles B. Mc Kennie, 10 years ago

Replying to galitsyn:

Sorry, does this mean the issue has been fixed for you?

Most definitely.

Also, appears to fix USB Drive Process Conformity https://forums.virtualbox.org/viewtopic.php?f=9&t=49774&hilit=consistent+USB

Thanks in a big way

comment:29 by galitsyn, 10 years ago

Summary: OSX USB wont connect; log file in /ApplicationsOSX USB wont connect; log file in /Applications => fixed in SVN

Thank you for testing and for your patience! Fix will be available with the next maintenance release.

comment:30 by Frank Mehnert, 10 years ago

Resolution: fixed
Status: newclosed

Fix is part of VBox 4.3.12.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use