VirtualBox

Ticket #11028 (closed defect: invalid)

Opened 19 months ago

Last modified 19 months ago

vboxdrv.rules breaks other custom rules

Reported by: Mimmoliquid Owned by:
Priority: major Component: USB
Version: VirtualBox 4.2.0 Keywords: udev rules vboxdrv.rules
Cc: Guest type: Linux
Host type: Linux

Description

I'm an arch linux user and i noticed there's a bad behavior caused by the vboxdrv.rules udev rule file (placed in /usr/lib/udev/rules.d/10-vboxdrv.rules). It basically breaks my other rules, blocking the execution of the scripts/applications inside them; i fixed it by changing the "RUN=" entries to "RUN+=", everything now is working flawlessly. Here's my edited file:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600" ENV{ACL_MANAGE}="1"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

Running Arch Linux, kernel 3.5.4-1-ARCH

Attachments

startup.txt Download (27.4 KB) - added by WhyMe 17 months ago.
Ubuntu Guest DMESG output.

Change History

comment:1 Changed 19 months ago by michael

A couple of questions. How are you installing VirtualBox? Our "all distributions" installer which I would expect you to use on Arch should place the rule into "/etc/udev/rules.d", not into "/usr/lib/udev/rules.d". And can you provide the output of the command "udevadm version 2>/dev/null" run at the command shell? Thanks.

comment:2 Changed 19 months ago by Mimmoliquid

The virtualbox version I installed is the one I picked from the "community" Arch repository via the Arch package manager. The version of udev management tool is the 193. Thanks to you.

comment:3 Changed 19 months ago by michael

Could you please remove it and see if you have the same issue when using our "all distributions" installer? This shouldn't have any effect on your virtual machines if you keep to the same version, other than that you will have to stop them all first.

comment:4 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Actually that package has exactly the bug you describe. So please open a bug report at their bugtracker as this is not a bug of the VirtualBox packages made by Oracle.

Changed 17 months ago by WhyMe

Ubuntu Guest DMESG output.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use