VirtualBox

Ticket #11021 (closed defect: fixed)

Opened 19 months ago

Last modified 4 months ago

Guest display is offset on retina display when 3d acceleration is enabled => Fixed in SVN

Reported by: josh2112 Owned by:
Priority: minor Component: 3D support
Version: VirtualBox 4.2.0 Keywords: retina aero wddm
Cc: Guest type: Windows
Host type: Mac OS X

Description

Guest is Windows 7 with the experimental WDDM display driver (not the basic Direct3D driver) installed. Host is OS X 10.8.2 on a MacBook Pro with Retina display. When Aero is activated, the Windows 7 display suddenly gets pushed up by about 25 pixels. It's like instead of drawing the Win 7 video driver output in the content area of the window, VirtualBox starts drawing it at the origin of the window so that it covers the title bar. Screenshots are attached.

This affects mouse interaction too, mouse position is registered on where the window content SHOULD be, not where it is. So you must click below a button to register a click on the button.

Interestingly enough, if you move the VB window to an external (non-retina) display, it corrects itself. If you move the window back onto the Retina display, the problem reoccurs.

This also happens on my Windows 8 guest.

Attachments

osx 10.8 - vbox 4.3 - win 7 aero.jpg Download (341.0 KB) - added by josh2112 19 months ago.
Win 7 on retina display host with Aero enabled
osx 10.8 - vbox 4.3 - win 7 no aero.jpg Download (312.2 KB) - added by josh2112 19 months ago.
Same with Aero disabled
win7 with aero osx 10.8.2 vbox 4.2.2.png Download (195.2 KB) - added by rcarz 18 months ago.

Change History

Changed 19 months ago by josh2112

Win 7 on retina display host with Aero enabled

Changed 19 months ago by josh2112

Same with Aero disabled

comment:1 Changed 18 months ago by rcarz

I'm having the same issue on a MacBook Pro Retina with OS X 10.8.2 and VB 4.2.2. If I disable 3D acceleration then it renders properly.

Changed 18 months ago by rcarz

comment:2 Changed 17 months ago by jbylsma

I can confirm this issue in Ubuntu 12.04 Desktop, both 32 and 64, as well as Fedora 17 x86_64. Another workaround is to use VBoxManage to disable the status bar:

VBoxManage setextradata global GUI/Customizations noStatusBar

This prevents the offset title bar behavior.

comment:3 Changed 16 months ago by lafa

I have same problem on macbookpro 15 retina. http://4.bp.blogspot.com/-vK5ZR8-9ss8/UMzIlAUAsOI/AAAAAAAAE6M/xKPeMA9zCYU/s1600/VboxProblem.tiff

Last edited 16 months ago by lafa (previous) (diff)

comment:4 Changed 11 months ago by epoyart

I have the same problem in a MacBook Pro Retina 15 inch, Early 2013 (MacBookPro10,1).

comment:5 Changed 10 months ago by jfbenckhuijsen

Confirming on MacBook Pro Retina 15 inch. Guest OS is LinuxMint, 3d is enabled. So the issue is not specific to a Windows Guest OS.

comment:6 Changed 9 months ago by ip6li

Confirming to 4.2.16 r86992 (same for host and guest additions) an Windows 7 guest Host: Mac OS 10.8.4 on MacBook Pro Retina 15-inch, Early 2013 Disabling 3d for guest is a preliminary workaround. 3d enabled make guest unusable.

comment:7 Changed 6 months ago by VBox

Problem verified on a new (Nov.2013) 15" MacBook Pro with Retina display and Mavericks OS 10.9

VirtualBox version 4.3.2

Guest OS is Linux Mint 15 64-bit.

Offset goes away if I move the VB window to an external non-Retina display, or if I turn off 3D acceleration when using the Retina display.

Last edited 6 months ago by VBox (previous) (diff)

comment:8 Changed 5 months ago by bl4cklight

This bug has been going on for more than a year (on a macbook pro retina, no matter the version of VB or Mountain Lion / Mavericks )

However, here is a workaround to get the 3D acceleration working. I did not yet test it over a long period of time, and its probably lost when upgrading to a new version of VB.

You need to "disable" the retina display for the app, if you are ready to sacrifice this aspect.

For a regular application this is done by going in the information panel, and checking the "Open in low resolution" option. However for virtualbox, this is not done on the "VirtualBox" entry in your application folder, but in one of the applications hidden within the package.

  • Right click on virtualbox application and "show package contents"
  • In Contents/Resources/VirtualBoxVM.app => edit the settings this application to select "Open in low resolution"

... and then, your display is faster, and the 3D acceleration works at the proper offset! (tested only with a CentOS linux)

comment:9 Changed 4 months ago by demmeln

The workaround by jbylsma is ok, but it would be great to see a real solution to this ongoing issue.

comment:10 Changed 4 months ago by misha

We've reproduced the issue here, and are working on it.

comment:11 Changed 4 months ago by misha

We have fixed this issue in our repository. Please give a try the toe following test build and let me know whether it solves the issue for you:
https://www.virtualbox.org/download/testcase/VirtualBox-4.3.5-91229-OSX.dmg Extension pack: https://www.virtualbox.org/download/testcase/Oracle_VM_VirtualBox_Extension_Pack-4.3.5-91228.vbox-extpack

comment:12 Changed 4 months ago by DesertWolf

Hello!, I have tested out the version of VB provided on my Mac book pro with retina display and it is fixed for me :)

Thanks!

comment:13 Changed 4 months ago by misha

  • Summary changed from Guest display is offset on retina display when 3d acceleration is enabled to Guest display is offset on retina display when 3d acceleration is enabled => Fixed in SVN

Thanks for the feedback!

comment:14 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The fix is part of VBox 4.3.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use