VirtualBox

Ticket #10954 (closed defect: duplicate)

Opened 19 months ago

Last modified 5 months ago

Guest Additions not reporting shader model 3 support

Reported by: DK707 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am trying to run Altium Designer 10 in a Windows XP virtual machine and have installed the "experimental" 3D support in the guest and selected the 3D option on the host.

Altium Designer requires DirectX 9.0c which must include shader model 3 support. I have attached a screencapture of the error message I get when I try to enable 3D support within the Altium tool.

This is becoming a major concern as Altium has indicated that the they will phase out the GDI interface and require the DirectX 9.0c to be available to use future versions of their software.

FYI, the dxdiag command gives me the following output:

The file VBoxDisp.dll is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL).  You may be able to get a WHQL logo'd driver from the hardware manufacturer.
To test DirectDraw functionality, click the "Test DirectDraw" button above.
Direct3D 7 test results: Failure at step 40 (Creating flipping primary surface with one back buffer): HRESULT = 0x88760064 (error code)
Direct3D 8 test results: Failure at step 4 (EnumAdapterModes): HRESULT = 0x8876086c (error code)
Direct3D 9 test results: All tests were successful.

Is it normal that the Direct3D version 7,8 tests fail?

If you would like to reproduce this problem, I think the freely available Altium Designer Viewer will also produce this DirectX error message if the hardware 3D support is selected from inside the tool.

The viewer is available here:  http://downloads.altium.com/altiumdesigner/AltiumDesignerViewerBuild9.3.0.19153.zip

Attachments

directx_error.png Download (23.1 KB) - added by DK707 19 months ago.
Altium Designer 10 Error message when enabling DirectX support
Vbox.log Download (109.8 KB) - added by DK707 19 months ago.
Vbox-4.2.1.log Download (107.7 KB) - added by DK707 19 months ago.
Log when running test build 4.2.1 r80868
VBox-4.2.1-with-4.2.1-guest-additions.log Download (106.1 KB) - added by DK707 19 months ago.
GLDiag.png Download (41.0 KB) - added by DK707 19 months ago.
nvidia_gl_cap.txt Download (40.1 KB) - added by DK707 19 months ago.
Output of nvidia-settings -g
glview.tgz Download (6.8 KB) - added by DK707 19 months ago.
Output of GLView
Altium_Screenshots.tgz Download (344.9 KB) - added by DK707 19 months ago.
Altium Deisgner Screencaptures while in DirectX and GDI mode

Change History

Changed 19 months ago by DK707

Altium Designer 10 Error message when enabling DirectX support

Changed 19 months ago by DK707

comment:1 Changed 19 months ago by misha

  • Component changed from guest additions to 3D support

comment:2 Changed 19 months ago by misha

This is a duplicate of the #10190 actually.
D3D7 support test should actually fail since VBox provides only D3D9 and D3D8 support for XP. The reason for D3D8 support test failure is most likely corrupted installation. Could you check %SystemRoot%\System32\d3d8.dll file properties (right-click in explorer and select "properties" and open "details" tab) whether the file is VBox-originated, and that %SystemRoot%\System32\msd3d8.dll file is Microsoft-originated.

comment:3 Changed 19 months ago by DK707

The installed d3d8.dll file is VBox-originated (Version 4.2.0.80737)

The installed msd3d8.dll file is Microsoft-originated (Version 5.3.2600.5512)

The sha256sum for the files are as follows:

52ac22897a9b0508bc8138424ee5f64769d46ef7df0aa005ada16e4d97e9e7ae d3d8.dll

28e1153276db83206e4d887503479ef37700710008d181fc046d1768dd9bb686 msd3d8.dll

It sure sounds like the bug #10190 is similar to my problem. Is there any update on the status of this problem. Is there any code I can test?

comment:4 Changed 19 months ago by misha

  • Status changed from new to closed
  • Resolution set to duplicate

We are looking for a quick way of fix this.
I'll mark this bug as a duplicate of #10190, so let's continue further discussions there.

comment:5 Changed 19 months ago by misha

We've made some enhancements to enable Shader v3 support in case host GPUs is suitable for it.
Please give a try to the following test build:  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.1-80868-Linux_amd64.run and let me know if it helps for you.
If not - please upload here a VM log file.

Changed 19 months ago by DK707

Log when running test build 4.2.1 r80868

comment:6 Changed 19 months ago by DK707

I tried 4.2.1-80868 and am still getting the same error where Altium reports the shader mode as 2.0. I am uploading the log file as requested. I was using the 4.2.0 guest additions.

Also, when I run dxdiag, the DirectX 9.0 test works, but 8.0 fails with an error as before.

Do you have any debug utility that I could run on the guest that might give you more information about this problem?

comment:7 follow-up: ↓ 8 Changed 19 months ago by misha

The log says you did not update guest additions,

Guest Additions information report: Version 4.2.0 r80737 '4.2.0'

please install Guest Additions from the above VBox package I posted here, reboot the guest and try again.

Changed 19 months ago by DK707

comment:8 in reply to: ↑ 7 Changed 19 months ago by DK707

Replying to misha:

The log says you did not update guest additions,

Guest Additions information report: Version 4.2.0 r80737 '4.2.0'

please install Guest Additions from the above VBox package I posted here, reboot the guest and try again.

I installed Guest Additions 4.2.1 r80850 and still have the same error dialog box in Altium Designer indicating the emulated video card only supports shader model 2.0.

For reference the installed version of d3d8.dll and d3d9.dll show version 4.2.1.0 in their property page. As before the dxdiag returns the same results with Direct3D 9 working and Direct3D 8 returning an error.

Changed 19 months ago by DK707

comment:9 Changed 19 months ago by DK707

Out of curiousity I found and installed a utility called GL Extensions viewer ( http://www.realtech-vr.com/glview/) and it also reports that the shader model is 2.0. I have attached a screencapture.

comment:10 Changed 19 months ago by misha

Shader Model v3 might be unavailable for you due to some OpenGL limitations that do not allow translating D3D to Ogl as VBox does.

Run GLview in guest, and create a dump of opengl extensions info with it and attach the archived dump here:

  1. Open "Extensions" view by clicking "extensions" on the left pane of GLview
  2. Click "XML" button on GLView tool-bar (the very right button), and select "Save As"
  3. Archive and post the generated file here

Changed 19 months ago by DK707

Output of nvidia-settings -g

Changed 19 months ago by DK707

Output of GLView

comment:11 Changed 19 months ago by DK707

I have attached the output of GLView as requested. Also, I have attached the output of the "nvidia-settings -g" command which lists the capabilites of the Fedora 16 host system.

comment:12 Changed 19 months ago by misha

Seems like I gave you a build with additions that do not include the fix. Let's have another try:
 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.1-80930-Linux_amd64.run
Please install this build and update Guest Additions from it.
If it still does not work, please attach guest glview dump again.

comment:13 Changed 19 months ago by DK707

Build 4.2.1-80930 is an improvement. GLView and Altium both see that Shader Model 3 is available. Unfortunately, the Altium package is not working properly in DirectX mode. What seems to be happening is that it is drawing things correctly and then is immediately overwriting the entire workspace with a background color. i.e. The screen just looks gray where the circuit board should be.

The curious thing is that if I do a guest CTRL-Printscreen while in DirectX mode, I can see the board in the captured image while the actual visible screen is just gray in this region.

I have uploaded an archive of some screenshots along with the log file from GLView.

The files are as follows:

GDI_Mode_Guest_Screenshot.png This file contains a screencapture of the Altium Designer application running in GDI mode and is what I would expect to see when I switch to DirectX mode.

DirectX_mode_Host_Screenshot.png This file contains a screencapture of the Altium Designer application running in DirectX mode. I took this screencapture using the host's printscreen utility. You can see that the gray background covers the entire workspace. This is actually what the Guest looks like in DirectX mode.

DirectX_mode_Guest_Screenshot.png This file contains a screencapture of the Altium Designer application running in DirectX mode. This screenshot was taken by ctrl-printscreen in the guest and is not representative of what I actually see. It seems to have captured what is hidden behind the incorrectly drawn gray background.

It seems that the there is some issue in the guest addition driver that may be affecting the Z-buffering or drawing order of objects.

Please let me know if there is anything else I can do that might shed light on what is happening and what can be done to fix the problem.

Changed 19 months ago by DK707

Altium Deisgner Screencaptures while in DirectX and GDI mode

comment:14 Changed 14 months ago by efferre

Confirmed also here using Virtualbox 4.2.6 on a linux host and Windows XP guest

comment:15 Changed 5 months ago by efferre

Which is the status for this bug? I still se shader level 2.0 supported with latest VirtualBox 4.3.2 and Guest Additions 4.3.2 r90405

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use