VirtualBox

Ticket #10928 (closed defect: fixed)

Opened 19 months ago

Last modified 18 months ago

Preferences dialog does not show correct values if no virtual machines are added => Fixed in SVN

Reported by: mdr86 Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.2.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Title says it all really; if no virtual machines are added, incorrect values (I assume they're the default values) are shown in the Preferences dialog box.

I noticed this problem when I was changing settings before adding any VMs. I added the extension pack but if I closed and opened the Preferences dialog box the extensions list was empty. Adding a virtual machine makes the extension pack appear in the list. The default host-only network is also missing if no VM is added.

Adding a VM solves the problem. If all VMs are removed, and the GUI is restarted, the problem returns.

When this problem is exhibited, I am unable to set the default VM folder, and VirtualBox returns the error "Failed to set global VirtualBox properties." with details "Callee RC: CO_E_NOTINITIALIZED (0x800401F0).

I'm running Windows 7 Professional x64.

Change History

comment:1 follow-up: ↓ 5 Changed 19 months ago by agentmike

Had this exact same issue, but my error had some sense in it. I'm using Win XP, and used VirtualBox some time ago, and the default directory was on a drive E:\ which was since removed. When I was now trying to add a new machine, it gave an error that it's unable to create a virtual machine in the default folder on this E:\ drive (which indeed doesn't exist).

And when I tried to change the default directory in the preferences, it gave me the error stated above.

Restarting and re-installing didn't solve this, but eventually changing the value of "defaultMachineFolder=" manually in the VirtualBox.xml settings file did the trick.

comment:2 Changed 19 months ago by frank

Confirmed, apparently a 4.2 regression.

comment:3 Changed 19 months ago by klaus

Workaround might be using the command line: VBoxManage setproperty machinefolder <absolute path> - if this doesn't work then it's a more low level bug.

comment:4 Changed 19 months ago by frank

  • Summary changed from Preferences dialog does not show correct values if no virtual machines are added to Preferences dialog does not show correct values if no virtual machines are added => Fixed in SVN

The fix will be part of the next maintenance release.

comment:5 in reply to: ↑ 1 Changed 18 months ago by KitoSoma

Confirmed that changing the value of "defaultMachineFolder=" manually in the VirtualBox.xml settings file works as a temporary manual fix.

comment:6 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.2.2

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use