VirtualBox

Ticket #10913 (closed defect: fixed)

Opened 19 months ago

Last modified 14 months ago

Crash on 4.1.22 with kernel 3.2.0-29 on Ubuntu 12.04

Reported by: claudiolog Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.22 Keywords: pci, driver, boot,
Cc: Guest type: all
Host type: Linux

Description

This is what I got when trying to use (in boot) virtualbox

5535	Sep 11 09:25:50 pathfinder kernel: [   24.822830] vboxdrv: Found 2 processor cores.
  5536	Sep 11 09:25:50 pathfinder kernel: [   24.823116] vboxdrv: fAsync=0 offMin=0x1c8 offMax=0xc94
  5537	Sep 11 09:25:50 pathfinder kernel: [   24.823157] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
  5538	Sep 11 09:25:50 pathfinder kernel: [   24.823159] vboxdrv: Successfully loaded version 4.1.12_Ubuntu (interface 0x00190000).
  5539	Sep 11 09:25:50 pathfinder kernel: [   24.890505] r8169 0000:04:00.0: eth0: link up
  5540	Sep 11 09:25:50 pathfinder kernel: [   24.890754] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  5541	Sep 11 09:25:50 pathfinder kernel: [   25.142996] BUG: unable to handle kernel paging request at ffff8800dfcf002c
  5542	Sep 11 09:25:50 pathfinder kernel: [   25.143469] IP: [<ffffffffa01420e3>] VBoxPciLinuxInit+0xe3/0x1000 [vboxpci]
  5543	Sep 11 09:25:50 pathfinder kernel: [   25.143967] PGD 1c06063 PUD 0 
  5544	Sep 11 09:25:50 pathfinder kernel: [   25.144466] Oops: 0002 [#1] SMP 
  5545	Sep 11 09:25:50 pathfinder kernel: [   25.144977] CPU 0 
  5546	Sep 11 09:25:50 pathfinder kernel: [   25.144984] Modules linked in: pci_stub vboxpci(O+) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) rfcomm bnep bluetooth nfsd nfs lockd fscache auth_rpcgss nfs_acl binfmt_misc sunrpc snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep joydev snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event i915 snd_seq snd_timer snd_seq_device drm_kms_helper drm snd mei(C) i2c_algo_bit mac_hid soundcore snd_page_alloc eeepc_wmi asus_wmi sparse_keymap psmouse ppdev video wmi parport_pc serio_raw lp parport usbhid hid r8169 usb_storage
  5547	Sep 11 09:25:50 pathfinder kernel: [   25.147582] 
  5548	Sep 11 09:25:50 pathfinder kernel: [   25.148288] Pid: 1314, comm: modprobe Tainted: G         C O 3.2.0-29-generic #46-Ubuntu System manufacturer System Product Name/P8H61-M LE/BR
  5549	Sep 11 09:25:50 pathfinder kernel: [   25.149065] RIP: 0010:[<ffffffffa01420e3>]  [<ffffffffa01420e3>] VBoxPciLinuxInit+0xe3/0x1000 [vboxpci]
  5550	Sep 11 09:25:50 pathfinder kernel: [   25.149871] RSP: 0018:ffff88013606ff08  EFLAGS: 00010293
  5551	Sep 11 09:25:50 pathfinder kernel: [   25.150684] RAX: ffffffffa02f002c RBX: 0000000000000000 RCX: 0000000000000000
  5552	Sep 11 09:25:50 pathfinder kernel: [   25.151517] RDX: 0000000000000000 RSI: ffffffffa036115d RDI: ffffffffa02f2118
  5553	Sep 11 09:25:50 pathfinder kernel: [   25.152370] RBP: ffff88013606ff18 R08: 0000000000000000 R09: 0000000000000000
  5554	Sep 11 09:25:50 pathfinder kernel: [   25.153239] R10: 0000000000000090 R11: 0000000000000001 R12: ffffffffa02f2100
  5555	Sep 11 09:25:50 pathfinder kernel: [   25.154120] R13: ffffffffa0142000 R14: 00000000017a95c0 R15: 0000000000405e80
  5556	Sep 11 09:25:50 pathfinder kernel: [   25.155019] FS:  00007f26868d7700(0000) GS:ffff88013fa00000(0000) knlGS:0000000000000000
  5557	Sep 11 09:25:50 pathfinder kernel: [   25.155942] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
  5558	Sep 11 09:25:50 pathfinder kernel: [   25.156872] CR2: ffff8800dfcf002c CR3: 0000000136033000 CR4: 00000000000406f0
  5559	Sep 11 09:25:50 pathfinder kernel: [   25.157836] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
  5560	Sep 11 09:25:50 pathfinder kernel: [   25.158820] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
  5561	Sep 11 09:25:50 pathfinder kernel: [   25.159817] Process modprobe (pid: 1314, threadinfo ffff88013606e000, task ffff880136622e00)
  5562	Sep 11 09:25:50 pathfinder kernel: [   25.160838] Stack:
  5563	Sep 11 09:25:50 pathfinder kernel: [   25.161870]  ffffffffa0362000 0000000000000000 ffff88013606ff48 ffffffff81002040
  5564	Sep 11 09:25:50 pathfinder kernel: [   25.162943]  ffffffffa0362000 ffffffffffffffff 0000000000008fb8 00000000017a95c0
  5565	Sep 11 09:25:50 pathfinder kernel: [   25.164031]  ffff88013606ff78 ffffffff810a82fe 00000000017abd80 0000000000000000
  5566	Sep 11 09:25:50 pathfinder kernel: [   25.165135] Call Trace:
  5567	Sep 11 09:25:50 pathfinder kernel: [   25.166244]  [<ffffffff81002040>] do_one_initcall+0x40/0x180
  5568	Sep 11 09:25:50 pathfinder kernel: [   25.167374]  [<ffffffff810a82fe>] sys_init_module+0xbe/0x230
  5569	Sep 11 09:25:50 pathfinder kernel: [   25.168520]  [<ffffffff81661ec2>] system_call_fastpath+0x16/0x1b
  5570	Sep 11 09:25:50 pathfinder kernel: [   25.169674] Code: 85 c0 75 7f 48 c7 c7 5d 11 36 a0 e8 68 19 f6 e0 48 85 c0 49 89 c4 48 89 05 2b 02 22 00 74 4d 83 38 02 74 74 48 8b 80 48 02 00 00 <65> ff 00 8b 05 fc 1d b9 e1 85 c0 74 2b 48 8b 1d 09 1e b9 e1 48 
  5571	Sep 11 09:25:50 pathfinder kernel: [   25.171039] RIP  [<ffffffffa01420e3>] VBoxPciLinuxInit+0xe3/0x1000 [vboxpci]
  5572	Sep 11 09:25:50 pathfinder kernel: [   25.172344]  RSP <ffff88013606ff08>
  5573	Sep 11 09:25:50 pathfinder kernel: [   25.173646] CR2: ffff8800dfcf002c
  5574	Sep 11 09:25:50 pathfinder kernel: [   25.204695] ---[ end trace cd5630ff5f19e59c ]---
  5575	Sep 11 09:26:00 pathfinder kernel: [   35.190843] eth0: no IPv6 routers present
  5576	Sep 11 09:26:01 pathfinder kernel: [   36.104392] init: plymouth-stop pre-start process (1962) terminated with status 1

Attachments

VBox.log Download (43.9 KB) - added by claudiolog 19 months ago.
Log of a "successfull" guest boot.

Change History

comment:1 Changed 19 months ago by claudiolog

Had to revert to 4.1.12 and kernel 3.2.0-27

comment:2 Changed 19 months ago by frank

Please try to use VBox 4.1.22 with kernel 3.2.0-27.

comment:3 Changed 19 months ago by frank

And does this happen with different guests? Does this happen immediately when you try to start the guest? Can you provide a VBox.log file of the failing session with 4.1.22? Also, where did you get the 4.1.22 package from, from this website or from the Ubuntu repository? VirtualBox 4.1.22 works very well here on Ubuntu 12.04 / 64-bit on Linux 3.2.0-30.

comment:4 Changed 19 months ago by claudiolog

Hi Frank,

this happens when I boot Linux, it does not depends on which guest I'm using.

I'm using

 http://download.virtualbox.org/virtualbox/debian/ precise/contrib

as source.

I try to use 4.2. RC4 but sometimes I got the same error in boot. Sometimes the boot continues, sometimes it stops.

I'll try to got a VBox.log and attach it later.

Changed 19 months ago by claudiolog

Log of a "successfull" guest boot.

comment:5 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Cannot reproduce on Ubuntu 12.04. Please reopen if still relevant with VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use