VirtualBox

Ticket #10907 (closed defect: invalid)

Opened 20 months ago

Last modified 18 months ago

Linux Guest Crashes on Full-screen

Reported by: michaelcole Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.22 Keywords: multiple screens crash
Cc: Guest type: Linux
Host type: Linux

Description

Hi, for years, I've been an advocate of VirtualBox in the php community ( http://drupal.org/project/quickstart is used by 100's of users), but recently started getting this problem (about 3 weeks ago).

I'm hosting Linux on Linux, with two screens. When I boot, the primary monitor doesn't draw correctly, and the guest uses the 2ndary monitor as the primary. When I full-screen, the VM aborts. Sometimes, both monitors respond to mouse clicks. Sometimes, when the windows are not full-screen, they draw correctly.

I've tried the up to date OSE and Oracle versions of Vbox and guest additions. I've also tried different versions of the Nvidia and Nouveau video drivers on my host and get the same results. I've also treid with/without 3d acceleration.

Here's a log from a crash:  http://pastebin.com/rR8b6dpZ

If that isn't enough, what's the best way to debug this? It's easy to reproduce.

Any suggestions?

Thanks!

Attachments

rR8b6dpZ.txt Download (56.3 KB) - added by michaelcole 20 months ago.
Log from crash
48.jpg Download (169.4 KB) - added by michaelcole 20 months ago.
Drawing only on one screen. Current config is for multiple monitors.
49.jpg Download (363.4 KB) - added by michaelcole 20 months ago.
Same as 48.jpg, but about to shut down the VM

Change History

Changed 20 months ago by michaelcole

Log from crash

comment:1 Changed 20 months ago by michaelcole

Bump! After some more testing, it appears VBox is only drawing one screen. Multiple screens is unusable, which is a major feature I need from a virtualizer.

comment:2 Changed 20 months ago by frank

Your log file indicates VBox 4.1.20 while you set the version to 4.1.22. Try if disabling 3D prevents the crash. And no, VBox is not only drawing one screen. Multiple screens are very well usable.

comment:3 Changed 20 months ago by michaelcole

Hi Frank, thanks for pointing out that inconsistency. The log is from 4.1.20, and I also reproduced it in 4.1.22. I have tried with and without 3d. It was working before with 3d.

Actually, it *is* only drawing on one screen, then after resizing it crashes, which is why I filed the bug.

Last edited 20 months ago by michaelcole (previous) (diff)

Changed 20 months ago by michaelcole

Drawing only on one screen. Current config is for multiple monitors.

Changed 20 months ago by michaelcole

Same as 48.jpg, but about to shut down the VM

comment:4 Changed 19 months ago by michael

What system are you running in the VM? It looks like some Ubuntu - is it a standard one or something special? Do both screens redraw if you pause the guest? And is is the VirtualBox application which crashes? How do you have the screens set up in the guest's system settings? From the log it looks like screen 0 is disabled. It also looks from the first screen shot as if the screen is generally not refreshing correctly. And can you reproduce this with a freshly installed Ubuntu (or some other commonly available distribution)?

comment:5 Changed 19 months ago by michaelcole

I'm running Mint 13 with Cinnamon. It's based on Ubuntu.  http://linuxmint.com/ It's on my radar to switch back to Ubuntu, but that's a bit of a hassle. I'll add some more notes then.

Thanks for the comment!

Mike

comment:6 Changed 18 months ago by michaelcole

Hi, I upgraded my desktop and laptop to Ubuntu 12.04, installed the Cinnamon desktop and Virtualbox.

I can now use dual-screen without any problems. This may be related to just the Mint Distro.

Thanks!

comment:7 Changed 18 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Sounds like I can close this then. Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use