VirtualBox

Ticket #1089 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Hang/crash while copying 3+ GB file from windows vista 32bit guest to a linux 64 bit host

Reported by: rtcm Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords:
Cc: Guest type: other
Host type: other

Description

I have installed VirtualBox-1.5.4_27034_fedora8-1.x86_64 on Fedora 8 running kernel kernel-2.6.23.12-101.fc8.x86_64.

As a guest I have installed Windows Vista 32-bit.

Inside Windows I had an ISO file north of 3GB. Wanted to copy it to my 80GB ipod but as I didn't have enabled USB support to the guest and already had the ipod's FAT fs mounted on the host I did a temporary share of a folder on the ipod's fs. Mounted it on Vista from an Administrator command shell with "net use x: \vboxsrv\folder" and started the copy on the same Admin shell with "xcopy c:\file.iso x:\". After a while the PC was almost completly unresponsive. I left it for an hour because like that, the PC reading/writing(?) the HDD and the ipod's disk activity always spinning.

As things didn't improve past this hour I disconnected the ipod's USB cable and the PC came "back to life". I'm still running the same gnome session I had running then to post this. The Vista guest seems to have crashed. I'll post various log bits I found related to this.

~/.xsession-errors has these lines I never saw in it before and they look interesting because the CPU certainly was being run at 100% during that hour because the fans were at their maximum:

Soft CPU time limit exhausted, terminating. Hard CPU time limit exhausted, terminating forcibly.

On the ipod's fs, on the parent of the directory I had shared in VirtualBox I found a file called 2008-01-14-23-35-46.009-VirtualBox-26966.log:

Log created: 2008-01-14T23:35:46.093347000Z Executable: /usr/lib/virtualbox/VirtualBox Arg[0]: /usr/lib/virtualbox/VirtualBox Arg[1]: -comment Arg[2]: Vista Arg[3]: -startvm Arg[4]: ce97642e-1e8c-4e1c-5f96-d621f94edbea

!!Assertion Failed!! Expression: i < 4096 Location : /home/vbox/vbox-1.5/src/VBox/Runtime/r3/linux/sems-linux.cpp(219) int RTSemEventSignal(RTSEMEVENTINTERNAL*) iCur=0x1 pIntEventSem=00002aaab40011c0

I'm also attaching the full VBox.log file.

Attachments

VBox.log Download (29.6 KB) - added by rtcm 6 years ago.

Change History

Changed 6 years ago by rtcm

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #616.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use