VirtualBox

Ticket #10888 (closed defect: wontfix)

Opened 20 months ago

Last modified 20 months ago

RDP guest desktop re-size is not reported back

Reported by: bmiklautz Owned by:
Priority: major Component: RDP
Version: VirtualBox 4.1.20 Keywords: xfreerdp mstsc re-size
Cc: Guest type: other
Host type: all

Description

When connecting with xfreerdp or mstsc a screen resolution change in the guest is not reported back to the rdp client.

If I connect with rdesktop i get a capability 2, capabilitySetType: CAPSTYPE_BITMAP 0x2 with desktopWidth and desktopHeight set to the new guest resolution back from VirtualBox. Which allows rdesktop to resize the client window as well.

VirtualBox doesn't sent this capability set to xfreerdp or mstsc. The guest screen is resized but window size on the client stays the same this way. When the guest resolution gets smaller a black border is shown. When the guest resolution gets bigger only a part (center) of the guest screen is shown which renders the rdp connections unusable most of the time (since the menubar/top bar/.. can't be reached anymore).

Are there any special capabilities/settings that need to be sent when connecting to VirtualBox with rdp to get guest desktop re-size information? This bug seems to be related to #8079

Tested with:

xfreerdp 1.0.1 and a recent version from git (gbf02b5b)
mstsc (6.1.7601) on windows 7

4.1.18-r78361 on debian (wheezy and squeeze)
4.1.20-r80170 on OSX
Extension pack 4.1.20-80170

Guest Systems:
ubuntu 12.04
windows 7

Change History

comment:1 Changed 20 months ago by sunlover

  • Status changed from new to closed
  • Resolution set to wontfix

This is an expected behavior. VBox VRDP server does not report the guest resolution changes to the MS RDP client.

VBox VRDP server works differently with rdesktop and MS RDP client.

In MS RDP client case the guest is resized to match the client resolution. The guest must have the guest additions installed to do this. This is the same behavior as when MS RDP client connects to the Terminal server.

In rdesktop case, the client is resized to match the guest resolution.

comment:2 Changed 20 months ago by bmiklautz

The behavior you describe is exactly what I have observed.

How is the client detected? - If I know I could probably add support for that in xfreerdp as well.

It would be really nice to have re-sizing support in xfreerdp without guest additions as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use