VirtualBox

Ticket #10845 (closed defect: fixed)

Opened 20 months ago

Last modified 10 months ago

VBoxSVC crash caused by incorrect use of IAppliance => fixed in SVN

Reported by: UFO Owned by:
Priority: minor Component: OVF
Version: VirtualBox 4.1.18 Keywords: VBoxSVC crash IAppliance
Cc: Guest type: all
Host type: Windows

Description

When I call IVirtualBox::createAppliance(), IAppliance::read() and then IAppliance::importMachines() - without calling IAppliance::interpret() - VBoxSVC crashes.

I've already found out that I have to call IAppliance::interpret(), but nevertheless this looks like a bug.

Simplified version of the code I used (C#): IAppliance app = VirtualBox.CreateAppliance(); IProgress progress = app.Read("c:\file.ova"); progress.WaitForCompletion(-1); app.Interpret(); app.ImportMachines(new ImportOptions[] { ImportOptions.ImportOptions_KeepNATMACs });

Change History

comment:1 Changed 11 months ago by aeichner

  • Summary changed from VBoxSVC crash caused by incorrect use of IAppliance to VBoxSVC crash caused by incorrect use of IAppliance => fixed in SVN

Thanks for the report, I was able to reproduce issue. It will be fixed in the next maintenance release.

comment:2 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use