VirtualBox

Ticket #10828 (closed defect: worksforme)

Opened 20 months ago

Last modified 19 months ago

VBoxService --disable-timesync broken

Reported by: jacksar Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: other
Host type: other

Description

When I set time a lot into future (an hour or more) (by using as root: "date -s "AUG 25 2012 16:00:00") the clock will be reset to the host time after 5 seconds.

As advised here https://www.virtualbox.org/ticket/2928 I run "/usr/sbin/VBoxService --help" and "sudo /usr/sbin/VBoxService --disable-timesync".

It didn't disable time sync for me on with Ubuntu 12.04 (Virtual Box 4.1.12_Ubuntu: 77245). It didn't disable time sync for someone else on Windows back in 2010 ( https://forums.virtualbox.org/viewtopic.php?t=8535#p129883).

However, "sudo /etc/init.d/vboxadd-service stop" disables time sync and it works as expected (time will not get set back to host time).

Summary if bug report: "/usr/sbin/VBoxService --disable-timesync" is broken.

Change History

comment:1 Changed 19 months ago by Tsso

Can I have some feedback for this report?

comment:2 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

From your description it seems to be that you just start another instance of the VBoxService system process. I've tried to reproduce your problem. The --disable-timesync switch does definitely work. But it is also possible to start several instances of the VBoxService process in parallel. In that case, the previously running VBoxService process will still synchronize the time while the new process you started with sudo will not. To disable the time synchronization permanent you either need to edit the /etc/init.d/vboxadd-service script.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use