VirtualBox

Ticket #10797 (new defect)

Opened 21 months ago

Last modified 21 months ago

Stale WinReg classes cause host-only to screw up.

Reported by: markfilipak Owned by:
Priority: major Component: installer
Version: VirtualBox 4.1.18 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Re:  https://forums.virtualbox.org/viewtopic.php?f=2&t=50696&sid=824290275eb7bbb17378d54c962eb21e

I have attached "ROOT%NET%0002 - before repairing VBox.zip" which has bogus WinReg entries referencing an Unknown Adapter (Dev. Mgr. with !) with the only clue being "Device Instance Id" of "ROOT\NET\0002" (all other properties were blank). I have attached "ROOT%NET%0002 - added by repairing VBox.zip" which has good WinReg entries referencing the same adapter AFTER I had identified it as VBoxNetAdp.sys. The good WinReg entries and the bogus WinReg entries are now BOTH in the WinReg. How did I do this? I tried to update the Unknown Adapter driver. I found that the only thing that Windows would accept was Oracle Corp., Host-only. When I updated the Unknown Adapter driver to the Host-only driver, the Unknown Adapter DISAPPEARED (leaving only my original Host-only Adapter). Curiously, my original Host-only connection now has this as it's IP: 169.254.27.11/16. The original (before the Unknown Adapter disappeared) was 192.168.56.1/24. How did the bugus WinReg entries get made? I had reinstalled ("Repair") VBox three times. There were 3 bogus entries. Coincidence? It seems to me that VBox is not cleaning up the WinReg. Your mileage may vary. This problem prevented me from getting host-only working. I would appreciate a prompt reply regarding whether you'd like me to make any tests or send any additional.

Attachments

ROOT%NET%0002 - before repairing VBox.zip Download (4.8 KB) - added by markfilipak 21 months ago.
ROOT%NET%0002 - added by repairing VBox.zip Download (1.8 KB) - added by markfilipak 21 months ago.
VBox.log Download (83.3 KB) - added by markfilipak 21 months ago.
host-only stale entries.reg Download (19.4 KB) - added by markfilipak 21 months ago.

Change History

Changed 21 months ago by markfilipak

Changed 21 months ago by markfilipak

Changed 21 months ago by markfilipak

comment:1 Changed 21 months ago by markfilipak

Can I go ahead and fix my WinReg? Or would you like me to run any tests or send any further WinReg entries first?

Last edited 21 months ago by markfilipak (previous) (diff)

comment:2 Changed 21 months ago by misha

Sorry for delay.. first of all, one should never need to access those registry entries directly, or even worse modify them directly, since this may lead to unpredictable system behavior.
Could you please describe your problem(s) in terms of high-level symptoms/problems..
I.e. could you give a detailed description of the problem you initially had, (was it the "Unknown Adapter" which appeared in the device tree? If so, could you tell which actions (VBox installation??) made it appear? )
And also a step-by-step description of your further actions and problems you encountered (also in terms of high-level symptoms).

comment:3 Changed 21 months ago by markfilipak

Misha, I don't know how to reply. I hit "Reply" in your comment and... well... I'm not sure what I was looking at but it didn't appear to have anywhere for me to type in anything. I'm going to prepare a report and add it as a new comment.

I need to get on with things. Can I go ahead and fix my WinReg?

Last edited 21 months ago by markfilipak (previous) (diff)

comment:4 Changed 21 months ago by markfilipak

This will be long...

Host: WinXP Pro SP3
Guest: WinXP Pro SP3 VBox: Version 4.1.18r78361

Part 1: (Re:  https://forums.virtualbox.org/viewtopic.php?f=2&t=50564) I initially created my Guest with NAT just to get it working. Then I switched to Host-only so that the Host & Guest would be in an interior subnet. I wired up Host-only, mostly by hand, and got the Host & Guest 'talking' and sharing. I configured the Host for ICS. Everything appeared to work. Both Host & Guest could ping 192.168.1.1 (the exterior router), but ping yahoo.com in the Guest failed (though the DNS worked!). I went to the VBox forum and found that you can't get the Guest on the Internet via Host-only + ICS. I now know that's not true, but at the time I believed it. While trying to get Host-only configured, I did an ipconfig and discovered the tunneling. I didn't know what it was and that it was associated with VBox, so I deleted the driver in Device Manager, adapter properties. Then I realized that VBox was probably the source of the tunneling and that it was probably needed, so I reinstalled VBox via "Repair".

Part 2: (Re:  https://forums.virtualbox.org/viewtopic.php?f=2&t=50696) I removed Host-only so that there was no Guest network. Everything was happy. I enabled NAT. Everything was happy. I decided to give Host-only another try, this time step-by-step, taking all the defaults, and no hand wiring. Nothing worked. It was at this point that Perry got through my head that Host-only is NOT a router, but is an ordinary switch. Now, I've done a few networks for business but always with an interior router and ICS at the gateway system. I didn't know that a switch doesn't have a gateway until Perry informed me of that. I thought that the device at a subnet's boundary was always called the "gateway", even if it is only a switch. Well! Now I think I see what the tunnel is all about. I assume that it's doing link-layer tunnelling based on MAC addresses (much the way that Wi-Fi security can be achieved without WEP or WPA) and that Host-only only appears to be a router when looked at with only IP addressing in mind. During this time I "Repair"ed VBox two more times (making the total number of "Repair"s, three). When I was finally convinced that the Guest should have no gateway, I tried removing it in the Guest's TCPIP properties. It couldn't be removed. I set the Guest to get IP automatically with no gateway in the Advanced properties and rebooted the Guest. It's connection status and ipconfig still showed a gateway. I tried hard wiring the IP. No improvement. I ripped out Host-only, rebooted, put Host-only back in, rebooted. (Each time I did this, I reinstalled the Guest Additions for good measure.) Perry thought something got corrupted in the Host, so I looked in the Host's Device Manager and, along side the Host-only adapter, I found an Unknown Adapter. I tried to use Windows device update but it couldn't find a driver for the unknown adapter (and, believe me, I tried to help it by pointing it all over the place in Windows's various device driver stores, caches, and backups, in VBox's install folder & sub-folders, etc.). Finally, in desperation, I pointed update to "Oracle Corp, Host-only" and - voila! - the unknown adapter disappeared (leaving behind only what I thought was the original Host-only adapter). However, the Host-only adapter left behind shows a totally bogus IP: 169.254.27.11/16 (not even legal for an interior network!).

Part 3: While fiddling with the unknown device in Device Manager, I discovered that the reason it was unknown was that the only thing Windows knew about it was that its Device Instance Id was ROOT\NET\0002. I searched the Windows Registry for "ROOT\NET\0002" and found one real adapter and three bogus adapters. This is all documented in the Reg files contained in the ZIPs that I attached to the original post here. Since during all this I had "Repair"ed VBox three times and there were now three bogus devices in the Windows Registry, I naturally assume that the "Repair"s are what corrupted it.

PS: You caution me not to remove the bogus Windows Registry entries by hand, but what's the alternative?

PPS: I could export the entire Host registry. Do you want it?

Version 4, edited 21 months ago by markfilipak (previous) (next) (diff)

comment:5 Changed 21 months ago by markfilipak

Host-only doesn't clean up after itself at all! Create a new host-only connection, then delete it. It's still in the WinReg. I've done it several times and now my WinReg is full of stale entries.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network]

I'm cleaning my WinReg now.

Changed 21 months ago by markfilipak

comment:6 Changed 21 months ago by markfilipak

I've added host-only stale entries.reg

comment:7 Changed 21 months ago by markfilipak

All guests are currently using NAT. Next, I'll try to re-install Host-only.

comment:8 Changed 21 months ago by markfilipak

Well. I don't get any responses here. I'm moving on. Good luck with VBox. I may try VMWare once I can determine whether it does or does not support XP.

I'd like to leave you with some impressions. The VBox help file and documentation is some of the worst I've ever read. The more one reads it, the more unanswered questions arise. I'm an electronics engineer (Ohio State Univ., 1977) and a documentarian (various international specifications and system architectures). The project's approach to documentation is apparently to bury it in the same version control system used to control code development. That is a very unfortunate decision. That guarantees that a myopic "code viewpoint" will forever be baked into the docs. Only failure can ensue.

When I read the help file, I can't tell whether a topic addresses the guest OS, the host OS, or the VBox application. A guest is sometimes referred to as "the guest", sometimes as "the virtual machine", and sometimes by other terms. Often, even where it's fairly clear what aspect of VBox is being addressed, the reference is stale (as in File -> Settings -> Network, which doesn't exist).

I think I could completely rewrite the help file in a weekend with the resulting verbiage being about 3x more understandable (if such an improvement can be characterized by such a percentage).

Ciao - Mark Filipak.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use