VirtualBox

Ticket #10765 (closed defect: invalid)

Opened 21 months ago

Last modified 18 months ago

Linux Guest Additions don't get properly installed after guest graphics stack update

Reported by: lin-unix Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.18 Keywords: xorg 1.12, guest additions
Cc: Guest type: Linux
Host type: other

Description

There's nothing better than a story :)

My distribution, Chakra, recently updated some packages related to the graphics stack (see pacman.log) and after reboot, the system would not start the X Server - it would just drop to console (see errors.log).

I figured that there was an issue with the guest additions not working well with the update and I was correct. Uninstalling the guest additions allowed me to boot up right to the GUI login screen :)

Note the attached VBoxGuestAdditions-uninstall.log. I looked for left over files but only found /dev/vboxguest and /dev/vboxuser so I deleted those two.

Once I logged into my desktop environment (which is KDE), I clicked Devices->Install Guest Additions to reinstall the guest additions. I ran VBoxLinuxAdditions.run as root. The script claimed to compile and install everything successfully.

I then rebooted. My system booted to the login screen (no issue with the X Server or starting up the vbox services) but my screen resolution is maxed out at 1024x768 and my mouse jumps around.

Miscellaneous: My distribution likes to keep packages "vanilla". My host is OS X 10.7. Sometimes when uninstalling the guest additions, the last line in VBoxGuestAdditions-uninstall.log also says "fail!".

Attachments

pacman.log Download (1.2 KB) - added by lin-unix 21 months ago.
vboxadd-install-x11.log Download (73 bytes) - added by lin-unix 21 months ago.
vboxadd-install.log Download (162.6 KB) - added by lin-unix 21 months ago.
VBoxGuestAdditions-uninstall.log Download (246 bytes) - added by lin-unix 21 months ago.
VBoxGuestAdditions.log Download (103 bytes) - added by lin-unix 21 months ago.
boot Download (118.8 KB) - added by lin-unix 21 months ago.
Boot log - relevent dates are from July 14th
errors.log.1 Download (19.7 KB) - added by lin-unix 21 months ago.
Error log - relevent dates are from July 14th
dmesg.log Download (26.2 KB) - added by lin-unix 21 months ago.
everything.7z Download (164.3 KB) - added by lin-unix 21 months ago.
Log of everything - relevant dates from July 14th
kernel.log.tar.gz Download (169.5 KB) - added by lin-unix 21 months ago.
Kernel log - Relevant date from July 14th
VBox.log.2 Download (100.5 KB) - added by lin-unix 21 months ago.
VBox.log.3 Download (95.3 KB) - added by lin-unix 21 months ago.
Xorg.0.log Download (56.9 KB) - added by lin-unix 21 months ago.
xorg.conf Download (1.8 KB) - added by lin-unix 21 months ago.
vboxvideo.png Download (6.1 KB) - added by daniele.cocca 21 months ago.
A screenshot showcasing what's reported in comment n.4.
xorg.2.conf Download (1.9 KB) - added by lin-unix 21 months ago.
Autogenerated xorg.conf
xorg.tar.gz Download (1.3 KB) - added by lin-unix 20 months ago.
Original xorg.conf
XOrg(1).tar.gz Download (1.3 KB) - added by lin-unix 20 months ago.
After VBox Tools install - xorg.conf
Confs.zip Download (3.6 KB) - added by The Stig 20 months ago.
Xorg.conf Files

Change History

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

  • attachment boot Download added

Boot log - relevent dates are from July 14th

Changed 21 months ago by lin-unix

Error log - relevent dates are from July 14th

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

Log of everything - relevant dates from July 14th

Changed 21 months ago by lin-unix

Kernel log - Relevant date from July 14th

Changed 21 months ago by lin-unix

Changed 21 months ago by lin-unix

comment:1 Changed 21 months ago by michael

Could you add /var/log/Xorg.0.log from the guest? Also, can you resize the guest by resizing the VirtualBox window? And is there more you can say about the mouse (the guest pointer?) jumping around? Thanks.

Changed 21 months ago by lin-unix

comment:2 Changed 21 months ago by lin-unix

I cannot resize the guest by resizing the VirtualBoz window. In fact, View->Auto-resize Guest Display is greyed out as well as Switch to Seamless Mode.

The guest pointer usually jumps to the far left of my screen. It doesn't shake or anything like that - it just disappears and reappears to the far left (sometimes top left of the screen).

Also, in my first paragraph in the bug report's description I mentioned that my system drops to console at boot up. That's just because the guest additions was compiled against an older version or xorg (version mismatch used to be listed in Xorg.0.log) and my distribution's update of xorg broke caused that. Therefore, my problem is that after I uninstall and then reinstall the guest additions the VirtualBox graphics driver does not load up. Vesa is used instead.

comment:3 Changed 21 months ago by michael

Does the file /etc/X11/xorg.conf exist on your guest? If so, could you please attach it?

Changed 21 months ago by lin-unix

comment:4 Changed 21 months ago by daniele.cocca

I'm having the same problem on my Chakra Linux guest installation, and with a bit more of research I found out that the vboxvideo driver seems to be trying to load the vboxdrv kernel module, which isn't there. See the attached screenshot.

Changed 21 months ago by daniele.cocca

A screenshot showcasing what's reported in comment n.4.

comment:5 follow-up: ↓ 12 Changed 21 months ago by michael

Daniele, your case seems to be somewhat different, as I think that lin-unix has vboxdrv running. Did you install the Additions from the image which comes with VirtualBox? And lin-unix, sorry that I didn't react, but I don't get notified on file uploads, just on comments. Your xorg.conf file doesn't look like I would expect it to. Do you know offhand of any reasons why it would be different?

comment:6 Changed 21 months ago by daniele.cocca

Honestly I doubt it, as in the vboxadd-install.log attached by lin-unix (which is quite similar to mine, by the way) I see no "vboxdrv", but only the names of the three modules I'm also getting.

Yes, I installed the guest additions from the ISO that gets mounted with Host+D. To make sure it wasn't actually my fault, I tried uninstalling the guest additions and reinstalling them again, but the result is the same.

comment:7 Changed 21 months ago by michael

I am obviously too tired. vboxdrv should not be running (on the guest - it runs on the host), vboxguest should be (and seems to be in both cases). I have no immediate idea though why your X.Org is trying to load a module of that name - does xorg.conf have any clue? Note that lin-unix's Xorg.0.log does not contain that line.

comment:8 follow-up: ↓ 9 Changed 21 months ago by daniele.cocca

Nope, it doesn't because his X.Org seems to be automatically loading the "vesa" driver (possibly, skipping the "vboxvideo" driver because of the above reason). In my case, I temporarily modified my xorg.conf to use the "vboxvideo" driver trying to debug this issue, and the above error popped up. That's all I know, unfortunately.

comment:9 in reply to: ↑ 8 Changed 21 months ago by michael

Replying to daniele.cocca:

Nope, it doesn't because his X.Org seems to be automatically loading the "vesa" driver (possibly, skipping the "vboxvideo" driver because of the above reason). In my case, I temporarily modified my xorg.conf to use the "vboxvideo" driver trying to debug this issue, and the above error popped up. That's all I know, unfortunately.

Could you please attach your current xorg.conf and Xorg.0.log? Thank you.

comment:10 Changed 21 months ago by daniele.cocca

The current (working, but not seamlessly integrated) configuration is exactly the same as the xorg.conf posted by lin-unix some time ago. The tweaked one only has "vboxvideo" instead of "vesa" in the "Device" section. I'll attach an X log with that tweaked configuration.

comment:11 Changed 21 months ago by daniele.cocca

To my surprise, while trying to reproduce the failing Xorg.0.log as you requested, I was able to start my X session correctly, and now my KDE session is seemingly integrated into my host system.

This has to be the first bug that actually fixes itself. The last upgrade of my X.Org packages is dated Jul 29, thus before the reinstallation of the drivers I performed in comment n.6.

I don't know what fixed it actually, but I'm glad it's solved. I think that lin-unix could be lucky as well, as he uses the same distribution.

comment:12 in reply to: ↑ 5 Changed 21 months ago by lin-unix

Replying to michael:

Daniele, your case seems to be somewhat different, as I think that lin-unix has vboxdrv running. Did you install the Additions from the image which comes with VirtualBox? And lin-unix, sorry that I didn't react, but I don't get notified on file uploads, just on comments. Your xorg.conf file doesn't look like I would expect it to. Do you know offhand of any reasons why it would be different?

I have no idea why my xorg.conf file is like that. I didn't do any editing myself. Now I did get X to autogenerate a new xorg.conf file, but that didn't help.

Changed 21 months ago by lin-unix

Autogenerated xorg.conf

comment:13 Changed 21 months ago by michael

Auto-generating xorg.conf will not help, as the infrastructure is not aware of the Guest Additions. (Actually not quite true - upstream X.Org does know about them, though I don't think that configuration file generation does; it is probably deprecated, since the default is no xorg.conf at all these days.) Running the Additions installer on top of a working xorg.conf file ought to work though.

comment:14 Changed 21 months ago by lin-unix

I installed Virtualbox 4.2 Beta 1 and the problem was fixed only when I went into xorg.conf and added vboxvideo manually.

comment:15 Changed 21 months ago by michael

Could you please try the following?

1) Uninstall the Additions, clean up xorg.conf (if you know how to get back a clean Chakra Linux xorg.conf, then do that) and attach it here if it is different from what you have attached previously. Also remove any other files lying around /etc/X11 like xorg.conf.bak or xorg.conf.vbox which look like they can be removed. 2) Reinstall the 4.2 Beta 1 Additions and attach the resulting xorg.conf, again if it is different from previous attachments?

Just to get an idea of what things look like from a clean slate. Even better if you have time would be installing a fresh guest rather than just removing the Additions.

comment:16 Changed 20 months ago by lin-unix

Sorry for the delay. I installed a fresh install of Chakra and got you the files.

Changed 20 months ago by lin-unix

Original xorg.conf

Changed 20 months ago by lin-unix

After VBox Tools install - xorg.conf

comment:17 Changed 20 months ago by lin-unix

Both xorg.conf's are the same.

Changed 20 months ago by The Stig

Xorg.conf Files

comment:18 Changed 20 months ago by The Stig

I attached 4 conf files:

  1. Clean Chakra install
  2. After 4.1.18 additions
  3. After system update which breaks things
  4. Installation of 4.2 Beta additions

It remained broken after 4.2 additions were installed..so i just dropped the 4.1 conf in and it started working again.

Cheers

comment:19 follow-up: ↓ 20 Changed 19 months ago by michael

To be clear, if you install the 4.2 Additions and remove xorg.conf altogether, do things work as they should? This should actually work fine, and perhaps the right thing for the Additions installer to do would be to remove (i.e. rename to a back-up copy) xorg.conf on installation. Perhaps though you could also get in touch with the people who maintain X.Org in Chakra to ask if there is a reason why xorg.conf is created in the first place when you install in a VirtualBox VM? There should be no need for it.

comment:20 in reply to: ↑ 19 Changed 19 months ago by lin-unix

Replying to michael:

To be clear, if you install the 4.2 Additions and remove xorg.conf altogether, do things work as they should? This should actually work fine, and perhaps the right thing for the Additions installer to do would be to remove (i.e. rename to a back-up copy) xorg.conf on installation. Perhaps though you could also get in touch with the people who maintain X.Org in Chakra to ask if there is a reason why xorg.conf is created in the first place when you install in a VirtualBox VM? There should be no need for it.

Ya everything works well in 4.2. I think this bug report can be closed. I will talk to my distribution. Thanks for your help!

comment:21 Changed 18 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for the feedback. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use