VirtualBox

Ticket #10700 (closed defect: fixed)

Opened 22 months ago

Last modified 3 months ago

windows 8 not boot

Reported by: KinG.InFeT Owned by:
Priority: critical Component: installer
Version: VirtualBox 4.1.18 Keywords: windows 8
Cc: Guest type: Windows
Host type: Linux

Description

windows 8 not boot and not start the installation

Attachments

VBox.log Download (78.4 KB) - added by KinG.InFeT 22 months ago.
complete log
Win8-2012-06-24-21-51-39.log Download (78.2 KB) - added by madsen 22 months ago.
Win8 (x86) Guest on Win7 SP1 (64x) Host
win8-2012-06-25-15-40-56.log Download (64.6 KB) - added by madsen 22 months ago.
Win8 (x86) Guest on Win7 SP1 (64x) Host - booting installation only
VboxLog.zip Download (51.7 KB) - added by a_catalin 20 months ago.
VBoxLog 4.2.0 Beta 1.zip Download (59.1 KB) - added by a_catalin 20 months ago.
VBox 4.2.0 RC2 log.zip Download (14.4 KB) - added by a_catalin 20 months ago.
VBox 4.2.0_RC3-80444 log.zip Download (16.0 KB) - added by a_catalin 20 months ago.
win8-2012-09-15-14-01-28.log Download (74.1 KB) - added by madsen 19 months ago.
Win 8 (x86), VirtualBox 4.2.0, no Guest Extensions installed.
win8-2012-09-15-14-01-28_deactivated-features.log Download (74.1 KB) - added by madsen 19 months ago.
Win 8 (x86), VirtualBox 4.2.0, no Guest Extensions installed, deactivated nearly everything.
win8-2012-10-28-10-38-38_no-pref-changes.log Download (73.9 KB) - added by madsen 18 months ago.
Win8 (x86) Guest on Win7 SP1 (64x) Host. No settings changed.
win8-2012-10-28-10-40-47_deactivated-NAT.log Download (69.6 KB) - added by madsen 18 months ago.
Win8 (x86) Guest on Win7 SP1 (64x) Host. NAT deactivated.
win8-2012-10-28-10-59-33_deactivated-NAT-USB.log Download (69.0 KB) - added by madsen 18 months ago.
Win8 (x86) Guest on Win7 SP1 (64x) Host. NAT, absolute pointing device and USB Controller deactivated.
Session-Information-win8_x86_successful_start.PNG Download (30.7 KB) - added by madsen 13 months ago.
Screenshot of session info after a successful start of VM
Session-Information-win8_x86_no_success.PNG Download (31.4 KB) - added by madsen 13 months ago.
Screenshot of session info after no success of starting a VM
win8.1_x86_BSOD_session-information.PNG Download (39.8 KB) - added by madsen 6 months ago.
win8.1_x86_BSOD_session-information
Win8.1_x86_BSOD.log Download (84.2 KB) - added by madsen 6 months ago.
win8.1_x86_BSOD_log
Win8.1_x64_BSOD_VBox_4.3.2.log Download (84.4 KB) - added by madsen 5 months ago.
Win2012_x64_BSOD_VBox_4.3.2.log Download (81.0 KB) - added by madsen 5 months ago.
Win2012_x64_no-errors_VBox_4.2.18.log Download (80.6 KB) - added by madsen 5 months ago.

Change History

Changed 22 months ago by KinG.InFeT

complete log

Changed 22 months ago by madsen

Win8 (x86) Guest on Win7 SP1 (64x) Host

comment:1 Changed 22 months ago by madsen

Win8 does not boot. I just attached the iso file to the IDE controller. Nothing else changed. I tried Win8 32bit and 64bit versions. In both cases I get a black screen with "Windows" in big white letters. Nothing happens after that.

For more similar information see also "Windows 8 Reboot Hangs" -  https://forums.virtualbox.org/viewtopic.php?f=2&t=44577&start=360#p228333

Changed 22 months ago by madsen

Win8 (x86) Guest on Win7 SP1 (64x) Host - booting installation only

comment:2 Changed 22 months ago by madsen

Try and error in VirtualBox

  • Case: Win8 Release Preview hangs on boot
  • Software: VirtualBox 4.1.18 with Extension Pack 4.1.18
  • VM: selected OS type Windows 8 for the x86-ISO and/or Windows 8 (64bit) for the 64x-ISO

First try

  1. Storage: Deleted SATA-Controller, added Hard Disk drive to IDE Controller --> boot failed
  2. Display: Activated “2D Video Acceleration”, deactivated “3D Acceleration” --> boot failed
  3. System > Boot Order: Deactivated “Floppy” --> boot failed
  4. Audio: deactivated --> boot successful! --> after a reset the VM does not boot again
  5. System > Extended Features: deactivated “absolute pointing device” and USB Controller --> boot failed
  6. Network Adapter deactivated --> boot failed
  7. System > Chipset: Changed to ICH9 --> boot failed

Second try (deleted old VM, created new one)

  1. Storage: Deleted SATA-Controller, added Hard Disk drive to IDE Controller --> boot failed
  2. Display: Activated “2D Video Acceleration”, deactivated “3D Acceleration” --> boot failed
  3. System > Boot Order: Deactivated “Floppy” --> boot failed
  4. Audio: deactivated --> boot failed
  5. System > Extended Features: deactivated “absolute pointing device” and USB Controller --> boot successful! --> Win8 installation started --> after a normal reboot during the Win8 installation the VM hangs again

Third try (deleted old VM, created new one)

  1. Display: Deactivated “3D Acceleration” --> boot failed
  2. System > Boot Order: Deactivated “Floppy” --> boot failed
  3. Audio: deactivated --> boot failed
  4. System > Extended Features: deactivated “absolute pointing device” --> boot failed
  5. System > Extended Features: deactivated “USB Controller” --> boot failed
  6. Storage: Deleted SATA-Controller, added Hard Disk drive to IDE Controller --> boot failed
  7. Network Adapter deactivated --> boot failed
Last edited 19 months ago by madsen (previous) (diff)

comment:3 Changed 22 months ago by KinG.InFeT

both methods do not work

comment:4 follow-up: ↓ 7 Changed 22 months ago by frank

Please don't use the ICH9 chipset, it's still experimental. Please try with both 2D and 3D disabled in the VM settings.

comment:5 follow-up: ↓ 6 Changed 22 months ago by frank

Oh, and did you use the OS type "Windows 8" when creating the VM?

comment:6 in reply to: ↑ 5 Changed 22 months ago by madsen

Replying to frank:

Oh, and did you use the OS type "Windows 8" when creating the VM?

Hey Frank, I did use the correct OS type from the very beginning

comment:7 in reply to: ↑ 4 Changed 22 months ago by madsen

Replying to frank:

Please don't use the ICH9 chipset, it's still experimental. Please try with both 2D and 3D disabled in the VM settings.

Hey Frank, I used ICH9 only because no other option to change was left.

Third try, "both 2D and 3D disabled", no success.

comment:8 follow-up: ↓ 22 Changed 21 months ago by RedWolfe

I got it to work by enableing the IO APIC capability and not using SATA drives.

Changed 20 months ago by a_catalin

comment:9 Changed 20 months ago by a_catalin

About the same problem here. Windows XP x86 as host, Windows 8 x86 as guest, VirtualBox 4.1.18 with Extension Pack 4.1.18. In 99% of the times the installation does not start or, if it starts, does not continue after the restart. All I can see is that blue "window". IO APIC capability was enabled from the start, changing from Sata to Ide doesn't help. But I have noticed that in those 1% it seems to work because I have modified something in the VM settings. I take a snapshot, I start the VM, the installation starts. I reverse to snapshot, I start the VM again, the installation does not start anymore. I try again with the same change in the VM settings, does not work anymore. I try again modifying something else in VM settings, sometimes is working, sometimes is not. Apparently it's at random. Once I succeeded in installing 100% but I made the mistake of installing the guest additions. But that's another (bug) story...

comment:10 Changed 20 months ago by a_catalin

Using VirtualBox 4.2.0 Beta 1 I managed to install Windows 8. Thank you.

However now I have the same problem with the installed Windows: most of the times it does not start. All I can see is that blue window in a black background (the logo I think).

Changed 20 months ago by a_catalin

comment:11 Changed 20 months ago by a_catalin

I tried with 4.2.0 RC2: most of the times it starts ok. I will attach the log from one time it didn't start.

Changed 20 months ago by a_catalin

comment:12 Changed 20 months ago by a_catalin

I tried with 4.2.0_RC3-80444. It started ok but after I installed Guest Additions it didn't started anymore. I will attach the log.

Changed 20 months ago by a_catalin

comment:13 Changed 20 months ago by frank

What does that mean, "didn't start anymore", do you see a black screen or a blue screen of death?

comment:14 Changed 20 months ago by a_catalin

As usual, just that blue logo in the black screen.

comment:15 Changed 20 months ago by a_catalin

Hi. I tested with 4.2.0_RC4 r80667. Seems that the problem is fixed. I installed Windows 8 from 0 without problems and I took a snapshot after shutting down the first time. If I close Windows 8 from inside, all is fine. With guest additions seems also fine. Good job, thank you.

Just a small problem: if I reverse to snapshot while it's running, it doesn't start anymore next time (same symptoms: blue logo in a black screen). To fix it you have to close the VM without reverting to snapshot; next time it starts ok. Maybe it does that because Windows 8 is an "online" OS and it loses "connection" (sorry for my newbie language :D). Is there any way to modify the snapshot system so it would start fine every time...?

comment:16 Changed 19 months ago by madsen

  • Case: Win8 Release Preview hangs on boot
  • Software: VirtualBox 4.2.0-80737 with Extension Pack 4.2.0-80737
  • Host: Win7 SP1 64x
  • Guest-VM: selected OS type Windows 8 for the x86-ISO and/or Windows 8 (64bit) for the 64x-ISO

Even with the new VirtualBox 4.2.0 I can not start or install Win 8 (x86 or 64x). It is like the user "a_catalin" described in his post Ticket 10700, comment no 9: "In 99% of the times the installation does not start or, if it starts, does not continue after the restart."

Here is my hardware config, maybe my CPU or something else is not compatible:

  1. ASUS M2N32-SLI WiFi Deluxe nForce590 SLI, Rev 1.03G, BIOS 5002
  2. AMD Athlon64 X2 4800+ Brisbane 65nm EE 2x2.5GHz, Stepping: G1, Socket: AM2
    1. PAE/NX: yes
    2. AMD-V: yes
    3. SSE2: yes
    1. Nested Paging: not supported by my CPU, but no requirement for Win 8
  3. OCZ DDR2-RAM 800 PC2-6400 2x2048MB CL4
  4. XFX Radeon HD 4830 512 MB DDR3, GPU: RV770, 55nm, 512MB GDDR3-RAM, 256bit
Last edited 19 months ago by madsen (previous) (diff)

Changed 19 months ago by madsen

Win 8 (x86), VirtualBox 4.2.0, no Guest Extensions installed.

Changed 19 months ago by madsen

Win 8 (x86), VirtualBox 4.2.0, no Guest Extensions installed, deactivated nearly everything.

comment:17 Changed 18 months ago by madsen

Try and error in VirtualBox 4.2.4

  • Case: Win8 Release Preview (32bit) hangs on boot
  • Software: VirtualBox 4.2.4 (no Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8" for the x86-ISO

Since the release of the "Win8 Release Preview" the installation of Win8 did never start.

Therefore I was suprised to see it start today with VB 4.2.4. Anyhow it did not continue after the restart.

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device. --> boot failed (see log win8-2012-10-28-10-38-38_no-pref-changes.log)
  2. System > Extended Features: deactivated “absolute pointing device” and USB Controller --> boot failed (see log win8-2012-10-28-10-40-47_deactivated-NAT.log)
  3. in addition to b. Network Adapter deactivated --> installation started --> did not continue after restart (see log win8-2012-10-28-10-59-33_deactivated-NAT-USB.log)
Last edited 18 months ago by madsen (previous) (diff)

Changed 18 months ago by madsen

Win8 (x86) Guest on Win7 SP1 (64x) Host. No settings changed.

Changed 18 months ago by madsen

Win8 (x86) Guest on Win7 SP1 (64x) Host. NAT deactivated.

Changed 18 months ago by madsen

Win8 (x86) Guest on Win7 SP1 (64x) Host. NAT, absolute pointing device and USB Controller deactivated.

comment:18 Changed 16 months ago by gojul

Same error here : Windows 8 hangs on boot randomly. Host : Linux Ubuntu 12.10 with kernel 32bits PAE Guest : Windows 8 with 2 GB RAM and 3D effects enabled (as one cannot disable 3D effects within guest additions on Windows 8 guest additions install prog)

comment:19 Changed 13 months ago by madsen

Try and error in VirtualBox 4.2.10

  • Case: Win8 (32bit) hangs on boot
  • Software: VirtualBox 4.2.10 (no Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8" for the x86-ISO

I was suprised to see it start today with VB 4.2.10. Anyhow it did not continue after the restart.

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device. --> installation started (see picture Session-Information-win8_x86_successful_start.PNG) --> did not continue after restart (see picture Session-Information-win8_x86_no_success.PNG)

Changed 13 months ago by madsen

Screenshot of session info after a successful start of VM

Changed 13 months ago by madsen

Screenshot of session info after no success of starting a VM

comment:20 Changed 12 months ago by madsen

Try and success in VirtualBox 4.2.12

  • Case: Win8 (32bit) starts
  • Software: VirtualBox 4.2.12 (without and with Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8" for the x86-ISO

The VM started, the installation succeeded and Win8 is functioning in VB 4.2.12. All functions seem to be ok: 2D, 3D, USB 2.0 work fine. Performance is great.

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device.
Last edited 12 months ago by madsen (previous) (diff)

comment:21 Changed 12 months ago by madsen

Try and error in VirtualBox 4.2.12

  • Case: Win8 (64bit) hangs on boot
  • Software: VirtualBox 4.2.12 (no Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8 64bit" for the x86-ISO

Only the Win8 logo shows up. No installation dialog.

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device.

comment:22 in reply to: ↑ 8 Changed 12 months ago by ejs

Replying to RedWolfe:

I got it to work by enableing the IO APIC capability and not using SATA drives.

This changes nothing for me. I had 5-6 successful boots then it was stuck on the splash screen.

4.2.12

comment:23 Changed 10 months ago by madsen

Finally: Try and success in VirtualBox 4.2.14 to 4.2.18!!!

  • Case: Win8 (32bit and 64bit) starts
  • Software: VirtualBox 4.2.14 (without and with Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8" / "Windows 8 64bit" for the x86 / x64-ISO

The VM started, the installation succeeded and Win8 is functioning in VB 4.2.14. All functions seem to be ok: 2D, 3D, USB 2.0 work fine. Performance is great.

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device.
Last edited 6 months ago by madsen (previous) (diff)

comment:24 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

In that case I will close this ticket.

comment:25 Changed 6 months ago by madsen

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:26 Changed 6 months ago by madsen

Try and error in VirtualBox 4.3.2

  • Case: Win8.1 (32bit and 64bit) hangs on boot
  • Software: VirtualBox 4.3.2 (no Extension Pack); updated from VirtualBox 4.2.18.
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8.1 (32bit)" for the x86-ISO and/or Windows 8 (64bit) for the 64x-ISO

The Win8 logo shows up. --> infinite loop of BSOD and restart: "Your PC ran into a problem and needs to restart. We're just collecting some error information, and then we'll restart for you."

What I did

  1. no changes made in the "Settings". Only added the ISO file to the CD/DVD device.
Last edited 6 months ago by madsen (previous) (diff)

Changed 6 months ago by madsen

win8.1_x86_BSOD_session-information

Changed 6 months ago by madsen

win8.1_x86_BSOD_log

comment:27 Changed 6 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

You have to change the VM settings to "Windows 8.1 (64-bit)". This will fix your VM. Older VBox releases were a bit less pedantic here.

comment:28 Changed 5 months ago by madsen

  • Status changed from closed to reopened
  • Resolution worksforme deleted

@frank: Your solution probably works for you. But ist does not for me with VirtualBox 4.3.2 .

Neither does "Windows 8.1" with an x86-ISO start nor the "Windows 8.1 (64-bit)" with an 64x-ISO. I tried Windows 2012 (64bit). Same error: "Your PC ran into a problem and needs to restart. We're just collecting some error information, and then we'll restart for you."

I downgraded to 4.2.18. Works fine.

comment:29 Changed 5 months ago by frank

madsen, please attach a VBox.log from a VM session where you started this guest with VBox 4.3.2 and selected the 64-bit Windows 8.1 OS type for that guest.

Changed 5 months ago by madsen

Changed 5 months ago by madsen

Changed 5 months ago by madsen

comment:30 Changed 5 months ago by madsen

hey frank, I attached three more files.

comment:31 Changed 5 months ago by frank

Thanks. The IEM: line is relevant. Most likely not yet fixed with the next maintenance release but we are working on a fix.

comment:32 Changed 3 months ago by madsen

Finally: Try and success in VirtualBox 4.3.6!!!

  • Case: Win8 (32bit and 64bit) starts
  • Software: VirtualBox 4.3.6 (without and with Extension Pack)
  • Host: Win7 SP1 64x
  • VM: selected OS type "Windows 8" / "Windows 8 64bit" for the x86 / x64-ISO

@frank: VirtualBox 4.3.6 works fine.

I have skipped VirtualBox 4.3.4. Simply had no time to install and test it.

comment:33 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the information. I will close this ticket. Please open separate tickets for separate issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use