VirtualBox

Ticket #10660 (closed defect: wontfix)

Opened 22 months ago

Last modified 19 months ago

File update in shared folder does not trigger inotify on Ubuntu

Reported by: unbi Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.16 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello all!

I'm using virtualbox 4.1.16 and latest guest addition.

My Host is Windows 7 and Guest is Ubuntu 11.10

I have a shared folder which its files suppose to be "watched" for changes from the Ubuntu machine by a node.js application - grunt: https://github.com/cowboy/grunt

the "watch" functionality in node.js is based on inotify: http://nodejs.org/api/fs.html#fs_fs_writefilesync_filename_data_encoding

for some reason, when i update a file in the shared folder from within the win host the Ubuntu guest does not triggers a file change.

i know its not a bug within node.js app since when i use: touch filename.js command in the ubuntu cmd the watch function works.

plus i saw someone else suffer from this kind of bug in different ruby application check it out on this url: https://github.com/guard/guard/issues/269

your help is highly appreciated!

Thanks :)

Change History

comment:1 Changed 22 months ago by jaypea

i've experience the same behaviour.

Host: Ubuntu 12.04, kernel 3.2.0-25-generic
Guest: Debian Wheezy, kernel 3.2.0-2-686-pae
virtualbox: 4.1.16
guest additions: 4.1.16

tested with a small php script which uses the inotify lib directly.
inotify_watch is triggered on local filesystem changes but not on remote changes in vboxsf mounted directories.

Last edited 22 months ago by jaypea (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 21 months ago by klaus

Since when is there a guarantee that inotify works on network filesystems?

comment:3 in reply to: ↑ 2 Changed 21 months ago by avit

Confirming this as well. Would be very nice to have.

Replying to klaus:

Since when is there a guarantee that inotify works on network filesystems?

You're right, there is no such guarantee, but it would be helpful if directories mounted through VirtualBox's built-in "shared folder" functionality could do this. Is it possible to make GuestAdditions forward inotify events?

comment:4 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

That would be quite different. The reason is that the host and the guest might have different file systems and vboxsf would have to implement a generic protocol to forward that information from the host to the guest. And this would have to work between many different host/guest combinations. Therefore marking this ticket as "won't fix", sorry.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use