VirtualBox

Ticket #10630 (closed defect: duplicate)

Opened 23 months ago

Last modified 21 months ago

GM(VINF_EM_DBG_HYPER_ASSERTION) Assertion at PGMAllPool.cpp:2476

Reported by: jdpickens Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.16 Keywords: VGA
Cc: Guest type: Linux
Host type: Windows

Description

I'm getting this error with ever increasing frequency. There is no pattern as to when it occurs. The end of the VBox.log is always the same. If anyone has a workaround, I'd greatly appreciate it.

Attachments

VBox.log Download (390.1 KB) - added by jdpickens 23 months ago.
Log file immediately after the crash

Change History

Changed 23 months ago by jdpickens

Log file immediately after the crash

comment:1 Changed 23 months ago by Hachiman

  • Summary changed from Ubuntu guest crashes with "Not in text mode!" from VGA controller to GM(VINF_EM_DBG_HYPER_ASSERTION) PGMAllPool.cpp:2476

comment:2 Changed 23 months ago by Hachiman

  • Summary changed from GM(VINF_EM_DBG_HYPER_ASSERTION) PGMAllPool.cpp:2476 to GM(VINF_EM_DBG_HYPER_ASSERTION) Assertion at PGMAllPool.cpp:2476

comment:3 Changed 23 months ago by jdpickens

I just updated to the latest Ubuntu components and the error persists. So, I suspect the problem is indeed in VirtualBox -- not in Ubuntu.

comment:4 Changed 23 months ago by jdpickens

I've been using VirtualBox for over a year for 8+ hours a day. This problem used to occur once every 3 or 4 weeks. I dismissed it as some sort of glitch in my environment. But as I have updated to later versions, the crash has become more frequent. Since updating to 4.1.16, the crash happens 2 or 3 times a day.

Could you give me a hint as to what triggers the problem?

comment:5 Changed 23 months ago by klaus

The error -1701 means that VirtualBox ran out of space on its hypervisor heap (which has a max size of 1.25MB in your case - see cbHyperHeap in the log file). This is the default setting for "usual" VMs, which means most people on this planet use it and don't have problems.

Can you try if lowering the memory size for this VM helps? Right now it has almost 3GB, can you live with 2GB for a while? It'll save a bit of hyper heap, possibly enough to make the problem go away. Once this is confirmed we can discuss the options, because so far it's not known if this really is just a case of "a tad too little heap".

comment:6 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

No response, closing. If you have comments, please add them to #10745. Enabling VT-x in your BIOS should solve the issue as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use