VirtualBox

Ticket #10584 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

3d acceleration does not work with 4.1.4 additions

Reported by: yrro Owned by:
Priority: critical Component: 3D support
Version: VirtualBox 4.1.14 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When running VirtualBox 4.1.4 with Debian (Linux 3.2) and the 4.1.4 guest additions, no program is able to use OpenGL. e.g.,

$ glxinfo
Error: couldn't find RGB GLX visual or fbconfig
name of display: :0.0

Downgrading to the 4.1.12 guest additions (and Xorg 1.11) solves the problem.

Host is Windows 7 64-bit. Graphics card is a Radeon HD 4890.

Forwarded from  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673437 since others cannot reproduce this bug in Debian.

Attachments

Debian-SID-2012-05-23-12-16-34.log Download (63.0 KB) - added by Perryg 2 years ago.
Xorg.0.log Download (37.5 KB) - added by akdor1154 2 years ago.
Xorg log
syslog Download (54.4 KB) - added by akdor1154 2 years ago.
syslog
VBox.log Download (68.9 KB) - added by akdor1154 2 years ago.
Debhoster Virtualbox log

Change History

comment:2 Changed 2 years ago by yrro

Whoops, when I said "4.1.4" I meant "4.1.14" in the bug title and description. Sorry about that.

comment:3 follow-up: ↓ 10 Changed 2 years ago by misha

could you please run some ogl app with CR_DEBUG=1 and CR_DEBUG_FILE=/path/to/log/file.log environment variables being set in guest and attach the generated log file here.

comment:4 follow-up: ↓ 5 Changed 2 years ago by akdor1154

I am seeing this too, with a Debian Testing guest on a Windows 7 x64 / NVidia GTX 260 host. Running glxgears with the aforementioned envvars being set has no effect - I still get the same:

Error: couldn't get an RGB, Double-buffered visual

Also I have the same four dri related (EE)s in my Xorg.0.log as yrro.

btw I cannot sign onto the new SSO service with Opera - server error, contact administrator. -.-

comment:5 in reply to: ↑ 4 Changed 2 years ago by misha

Replying to akdor1154: Please attach log file for vbox ogl component as specified in comment:3

comment:6 Changed 2 years ago by akdor1154

Sorry, was writing at 3am, so my language wasn't the clearest. Setting those environment variables and running glxgears (this uses OpenGL, does it not?) does not create a log - I just get the quoted error printed to the console before glxgears quits.

comment:7 Changed 2 years ago by misha

Please attach a VM log file please.

comment:8 Changed 2 years ago by Perryg

Adding name to monitor ticket.

Changed 2 years ago by Perryg

comment:9 Changed 2 years ago by Perryg

My experience with this is I do have it working. But it takes some fiddling to make it happen. After an upgrade the fallback mode is the only way it works.

remove gnome-shell & gnome-panel then install gnome-shell gnome-panel restore the gnome3 functionality until the next upgrade.

Log file attached and link to discussion at:  https://forums.virtualbox.org/viewtopic.php?f=3&t=49620#p225920

This was with official VBox 4.1.14 deb on Ubuntu 12.04_64 host and 4.1.14 GAs on the SID guest, but works the same on latest from SVN.

Last edited 2 years ago by Perryg (previous) (diff)

Changed 2 years ago by akdor1154

Xorg log

Changed 2 years ago by akdor1154

syslog

Changed 2 years ago by akdor1154

Debhoster Virtualbox log

comment:10 in reply to: ↑ 3 Changed 2 years ago by yrro

Replying to misha:

could you please run some ogl app with CR_DEBUG=1 and CR_DEBUG_FILE=/path/to/log/file.log environment variables being set in guest and attach the generated log file here.

I too get no debug output when these environment variables are set with the 4.1.14 guest additions installed. With 4.1.12 I see the expected debug output. Weird...

comment:11 Changed 2 years ago by yrro

This is a packaging issue caused by the multiarch transition. Upgrading libgl1-mesa-dri to version 8.0.2, and then restarting X fixes it.

comment:12 Changed 2 years ago by akdor1154

woohoo! confirmed. thanks :)

comment:13 Changed 2 years ago by ingo2

confirmed! libgl1-mesa-dri 8.0.2-2 from Sid fixt it for me as well.

comment:14 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use