VirtualBox

Ticket #10459 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

VirtualBox Crashes on WinXP host when host runs out of RAM

Reported by: grossetti Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I'm using a WinXP host and a Linux Guest. When the host runs out of RAM Virtualbox crashes. This is the first time I use a Windows host and I have never had this issue with Linux hosts. I am using Virtualbox 4.1.12.r77245 with Guest additions and the extensions (4.1.12.r77245). This is really making my life hard because it crashes a lot.

Thanks, Gabriel

Attachments

VBox.log Download (87.4 KB) - added by grossetti 2 years ago.
Log file
vb_error.PNG Download (26.1 KB) - added by grossetti 2 years ago.
Error dialogu
vb_error2.PNG Download (19.7 KB) - added by grossetti 2 years ago.
2nd dialog

Change History

Changed 2 years ago by grossetti

Log file

comment:1 Changed 2 years ago by Hachiman

What dou you mean by "crash" here? log ends with normal shutdown. Perhaps you need reduce amount of RAM reserved for guest.

comment:2 Changed 2 years ago by grossetti

It displays a VB dialog telling me that something bad happened and that I can press OK to close VB or Cancel to debug, but that debugging requires special knowledge and tools so it recommends to press OK. Doesn't sound like a normal shutdown... In any event, even if the Windows host runs out of RAM it has the pagefile so it shouldn't do that (and I have 64 GB of free HD space right now). Also, as I pointed out, my personal laptop has the opposite, a Linux host and it never crashes like that. The RAM ratio is about the same.

Changed 2 years ago by grossetti

Error dialogu

Changed 2 years ago by grossetti

2nd dialog

comment:3 Changed 2 years ago by grossetti

I added two screenshots of the dialogs I get, vb_error.png comes first, if I press "OK" it closes VB and I get vb_error2.png (standard Windows app crash dialog).

comment:4 Changed 2 years ago by frank

  • Priority changed from blocker to major

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10121.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use