VirtualBox

Ticket #10434 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Assertion Failed crash under heavy disk IO

Reported by: level7 Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.12 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi, when my Guest VM is under heavy disk IO (doing svn update of a large working directory) it randomly crashes (1-2 times a day) with the following error in the log file:

16:25:49.040 AsyncCompletion: Task 0x007fc5fb991480 completed after 15 seconds
16:25:49.040 AsyncCompletion: Task 0x007fc5fb9916c0 completed after 15 seconds
16:25:49.040 AsyncCompletion: Task 0x007fc5fb991680 completed after 15 seconds
16:25:50.913 AHCI#0: Canceled read at offset 11987676672 (114688 bytes left) returned rc=VINF_SUCCESS
16:25:50.913 
16:25:50.913 !!Assertion Failed!!
16:25:50.913 Expression: pSgBuf->cbSegLeft <= 5 * _1M && (uintptr_t)pSgBuf->pvSegCur >= (uintptr_t)pSgBuf->paSegs[pSgBuf->idxSeg].pvSeg && (uintptr_t)pSgBuf->pvSegCur + pSgBuf->cbSegLeft <= (uintptr_t)pSgBuf->paSegs[pSgBuf->idxSeg].pvSeg + pSgBuf->paSegs[pSgBuf->idxSeg].cbSeg
16:25:50.913 Location  : /home/vbox/vbox-4.1.12/src/VBox/Runtime/common/misc/sg.cpp(54) void* sgBufGet(RTSGBUF*, size_t*)
16:25:50.913 pSgBuf->idxSeg=0 pSgBuf->cSegs=1 pSgBuf->pvSegCur=00007fc5f4ab1000 pSgBuf->cbSegLeft=65536 pSgBuf->paSegs[0].pvSeg=000000000176c330 pSgBuf->paSegs[0].cbSeg=114688
  • Host: Ubuntu 10.10 64bit
  • Guest: Ubuntu 8.04 64bit

Attachments

AssertionFailed.log Download (157.6 KB) - added by level7 2 years ago.

Change History

comment:1 Changed 2 years ago by Hachiman

Could you please attach full log file?

Changed 2 years ago by level7

comment:2 Changed 2 years ago by level7

Full log file attached.

comment:3 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10292.

comment:4 Changed 2 years ago by level7

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Could someone please explain to me in what way this bug is a duplicate of #10292 ?

Last comment to the above bug says:

I am not sure this is actually a bug at this point or user error.

and references forum post which mentions VirtualBox vs Extension Pack version miss match:

 https://forums.virtualbox.org/viewtopic.php?f=8&t=48226

My VirtualBox version is exactly the same as Extension Pack, so can't see how this would be relevant?

comment:5 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

Your VM runs into the very same assertion as the user in #10292. The extension pack does not matter and yes, this is a VirtualBox bug but so far we have no idea what's wrong. The crash happens only for a few users and only if there a lot of pending I/O requests as can be seen in your logfile. Please continue the discussion in #10292, not here.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use