VirtualBox

Ticket #10371 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Virtual Box can not see the whole RAM on Fedora PAE

Reported by: Moham Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.10 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have installed Virtual box v4.1.10 r76796 on Fedora 3.2.7-1.fc16.i686.PAE. The host machine has 8g of RAM but the virtual box can only see 3584M.

Attachments

VBoxSVC.log Download (8.2 KB) - added by Moham 2 years ago.
Here is the VB log file. the problem is with the VirtualBox, when I clicked on settings and got to General tab the memory there is less than the OS sees
VBSettings.jpg Download (83.7 KB) - added by Moham 2 years ago.

Change History

comment:1 Changed 2 years ago by frank

Please attach a VBox.log file of such a VM session.

Changed 2 years ago by Moham

Here is the VB log file. the problem is with the VirtualBox, when I clicked on settings and got to General tab the memory there is less than the OS sees

Changed 2 years ago by Moham

comment:2 Changed 2 years ago by Moham

Frank,

The problem is with VBOX itself. the VBOX can't see the whole RAM, it sees only 3584M while the OS sees 8G

comment:3 Changed 2 years ago by frank

Oh, you mean the limitation in the settings dialog. That is actually 'by design'. Normal users should not need to raise the VM limit in the guest beyond that value, even not with PAE. If you really want to pass more memory to the guest then use the 'VBoxManage modifyvm' command line. But if you really need to do that then you should switch to a 64-bit host.

comment:4 Changed 2 years ago by Moham

Thanks a lot Frank

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

I hope you agree to close this ticket as 'not a bug'.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use