VirtualBox

Ticket #10312 (closed defect: worksforme)

Opened 2 years ago

Last modified 2 years ago

Wird Network Coruption

Reported by: OxOOCOFFEE Owned by:
Priority: critical Component: network
Version: VirtualBox 4.1.8 Keywords: svn checkin corrupt MAC
Cc: Guest type: Windows
Host type: Mac OS X

Description

While I was trying to checking new file using svn (1.7.3 running on all machines) from guest (win7 x32) running on host( Mac 10.7.3) to remote server running CentOS6 I was getting strange errors while trying to checking new added file. This file is about 48M .7z file. When checking in it looks like the transfer rate was very low about 1 to 15k/sec from guest and after 15 to 30 sec I got this error from svn "Can't write to connection: The pipe has been ended". Since I am using svn+ssh I logged in to CentOS server and checked secure log file. I found this entry :

Mar 7 15:48:31 centsvr sshd[9823]: Corrupted MAC on input. Mar 7 15:48:31 centsvr sshd[9823]: Disconnecting: Packet corrupt Mar 7 15:48:31 centsvr sshd[9819]: pam_unix(sshd:session): session closed for user

I try to check in multiple times and got this error. Try rebut guest and no help.

Now I reverted that add in guest and did it from host and it was just fine. No errors.

I am attaching log for guest. There are two NIC configured NAT and local only

Attachments

VBox.log Download (83.4 KB) - added by OxOOCOFFEE 2 years ago.

Change History

Changed 2 years ago by OxOOCOFFEE

comment:1 Changed 2 years ago by Hachiman

We've discussed the issue on IRC and via mail. Here the summary of conversation and tactic we'll follow in order to fix this issue. At first iteration I'll need to look at net traffic dump, if the reason is obvious, then we'll finish on the first iteration. Otherwise I will probably need mapping, host sockets to guest with NAT communication, that will require build of VBoxDD with enabled logging and collecting traffic dumps like in first iteration plus traffic dump on host site.

comment:2 Changed 2 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to worksforme

After some discussions with reporter and attempts to reproduce, we've decided to close ticket until issue appears again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use