VirtualBox

Ticket #10290 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Windows 8 crashes (BSOD) when accessing shared folders

Reported by: Andre.Ziegler Owned by:
Priority: blocker Component: guest additions
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I've install the Windows 8 CP (32Bit) in a VM and installed the guest additions. I've added two shared folders and when I try to access them inside the VM, Windows 8 crashes. This is the output of the dump:

MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 00061946, The subtype of the bugcheck.
Arg2: 855da850
Arg3: 000222a3
Arg4: 00000000

BUGCHECK_STR:  0x1a_61946

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  2

LAST_CONTROL_TRANSFER:  from 8122c3ec to 812dcec8

STACK_TEXT:  

nt!KeBugCheckEx
nt! ?? ::FNODOBFM::`string'
nt!MmProbeAndLockPages
WARNING: Stack unwind information not available. Following frames may be wrong.
VBoxGuest!RTMemContFree
VBoxGuest!RTMemContFree
VBoxGuest!RTR0MemObjLockKernelTag
VBoxGuest
VBoxGuest
VBoxGuest
VBoxGuest
VBoxGuest!g_pszRTAssertFunction
nt!IofCallDriver
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF!g_pszRTAssertFunction
nt!KiThreadStartup

FOLLOWUP_IP: 
VBoxGuest!RTMemContFree+63c
887d08bc 8b45e4          mov     eax,dword ptr [ebp-1Ch]

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  VBoxGuest!RTMemContFree+63c

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: VBoxGuest

IMAGE_NAME:  VBoxGuest.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4f30f27f

FAILURE_BUCKET_ID:  0x1a_61946_VBoxGuest!RTMemContFree+63c

BUCKET_ID:  0x1a_61946_VBoxGuest!RTMemContFree+63c

Attachments

VBox.log Download (100.7 KB) - added by Andre.Ziegler 2 years ago.
Windows 8 Build 8250 (Consumer Preview).vbox Download (12.1 KB) - added by Andre.Ziegler 2 years ago.
Logs.7z Download (24.0 KB) - added by Andre.Ziegler 2 years ago.

Change History

Changed 2 years ago by Andre.Ziegler

Changed 2 years ago by Andre.Ziegler

comment:1 Changed 2 years ago by Andre.Ziegler

I can copy files from command prompt, but when I access the shared folders in the Explore, Windows 8 crashes.

comment:2 Changed 2 years ago by misha

Thanks for the report. We've reproduced and fixed the problem and will give you a test build with a fix shortly.

comment:3 Changed 2 years ago by misha

Here is a link to the test build of Guest Additions with the fix:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.1.9-76652.iso

comment:4 Changed 2 years ago by Andre.Ziegler

The VM crashes during upgrade. The WDDM driver causes an issue. it fails to unload:

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: 9e7f1d6a, memory referenced.
Arg2: 00000000, value 0 = read operation, 1 = write operation.
Arg3: 8143919b, If non-zero, the instruction address which referenced the bad memory
	address.
Arg4: 00000002, (reserved)

Debugging Details:
------------------


READ_ADDRESS:  9e7f1d6a 

FAULTING_IP: 
nt!ExFreePoolWithTag+3f0
8143919b 8a03            mov     al,byte ptr [ebx]

MM_INTERNAL_CODE:  2

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

nt!KeBugCheckEx
nt! ?? ::FNODOBFM::`string'
nt!MmAccessFault
nt!KiTrap0E
nt!ExFreePoolWithTag
nt!ExFreePoolEx
nt!ExDeleteLookasideListEx
WARNING: Stack unwind information not available. Following frames may be wrong.
VBoxVideoWddm
dxgkrnl!DpiDriverUnload
nt!IopUnloadDriver
nt!PnpUnloadAttachedDriver
nt!PnpRemoveLockedDeviceNode
nt!PnpDeleteLockedDeviceNode
nt!PnpDeleteLockedDeviceNodes
nt! ?? ::NNGAKEGL::`string'
nt!PnpProcessTargetDeviceEvent
nt!PnpDeviceEventWorker
nt!ExpWorkerThread
nt!PspSystemThreadStartup
nt!KiThreadStartup

after this Windows resets itself because it could no longer boot. Now I don't know if the drivers where updated correctly. When I now try to access the shared folders, the VM stops responding and the VirtualBox.exe on the host) causes a 100% cpu usage. In this case the guest also crashes:

MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 00061946, The subtype of the bugcheck.
Arg2: 844bc570
Arg3: 000281e1
Arg4: 00000000

nt!KeBugCheckEx
nt! ?? ::FNODOBFM::`string'
nt!MmProbeAndLockPages
WARNING: Stack unwind information not available. Following frames may be wrong.
VBoxGuest!RTMemContFree
VBoxGuest!RTMemContFree
VBoxGuest!RTR0MemObjLockKernelTag
VBoxGuest
VBoxGuest
VBoxGuest
VBoxGuest
VBoxGuest!g_pszRTAssertFunction
nt!IofCallDriver
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF
VBoxSF!g_pszRTAssertFunction
nt!KiThreadStartup

comment:5 Changed 2 years ago by Andre.Ziegler

ok, the driver are updated in the VM

comment:6 Changed 2 years ago by misha

Please attach a minidump here.

comment:7 Changed 2 years ago by misha

VM log would be also very useful

Changed 2 years ago by Andre.Ziegler

comment:8 Changed 2 years ago by misha

No need for the minidump. We've reproduced the WDDM driver unload-related crash you observed abd fixed it. I will provide you with the new test build shortly.

comment:9 Changed 2 years ago by Andre.Ziegler

ok :)

comment:10 Changed 2 years ago by misha

Here is the new test build ov VBox Guest Additions with the fix:  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.1.9-76683.iso

NOTE!! since the current version you have installed still has the bug that might cause BSOD on additions uninstall, I would suggest to do the following:

  1. Run VBoxWindowsAdditions.exe /extract /D=c:\test -> this would extract the GA files to c:\test
  2. copy C:\test\x86\VBoxVideoWddm\VBoxVideoWddm.sys %SystemRoot%\System32\Drivers
  3. rmdir /s /q C:\test
  4. reboot
  5. Run GA installer in an "everage" mode

comment:11 Changed 2 years ago by Andre.Ziegler

ok, updating the additions seems to fixed it.

I can now access the shared folders with the Explorer. I'll test it a bit more the next few days :)

comment:12 Changed 2 years ago by Andre.Ziegler

I think you can close it. For me it works now without issues.

comment:13 Changed 2 years ago by frank

Thanks for the feedback!

comment:14 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use