VirtualBox

Ticket #10284 (closed defect: fixed)

Opened 2 years ago

Last modified 7 weeks ago

MS Office 2010 crashes Win7/64 VM

Reported by: ZioNemo Owned by:
Priority: critical Component: 3D support
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have several instances of a very nasty crash of the whole VM when performing certain operations on MS Office 2010.

The one I'm reporting here is clicking on a button in an Excel spreadsheet.

The host is a Win7 home Premium x64 The guest is a Win7 Ultimate x64

The bug is completely reproducible. Unfortunately I cannot attach the offending .xlsx file because it contains sensitive information.

I do attach the log of one of the crashes. The last lines seem to indicate the OpenGL component is somehow involved.

FYI: I have a very similar crash when using PowerPoint on a very similar guest machine running under a linux ubuntu server 11.10 x64 host. In this case I have *NO* printouts at the end of log. This condition only arises if the guest is run headeless using "VBoxHeadless -s ..." and accessed using RDP (same behavior if the RDP client is the default win one or linux rdesktop).

For some applications this is a real show-stopper.

I am available to give any further detail needed.

Attachments

VBox.log Download (59.9 KB) - added by ZioNemo 2 years ago.

Change History

Changed 2 years ago by ZioNemo

comment:1 Changed 2 years ago by misha

Please create minidumps for the crashes you observe. See https://www.virtualbox.org/ticket/9267#comment:36 on how to make minidumps be generated on app crashes for Vista SP1 and later.

comment:2 Changed 2 years ago by misha

Also please try if disabling the 3D support in VM settings (on "Display" page) solves the issue.

comment:3 Changed 2 years ago by ZioNemo

I do attach the resulting minidump.

Minidump is too big; please fetch it from  http://www.mediafire.com/?n8d4wcqos3k3f6o

Disabling 3D acceleration solves the problem for me.

I am available to help solving the underlying problem.

THANKS

comment:4 Changed 2 years ago by misha

  • Component changed from other to 3D support

comment:5 Changed 2 years ago by frank

  • Priority changed from blocker to critical

comment:6 Changed 19 months ago by frank

Still relevant with VBox 4.1.22 / 4.2.0?

comment:7 Changed 12 months ago by raghiante

I have been experiencing issues with Win 7 64 bit & MS Office 2010 32 bit & VirtualBox 4.2.12 r84980 just like reported by ZioNemo. I believe this issue is still relevant on 4.2.x

comment:8 Changed 12 months ago by Floh79

Hi, I have same issue and I'm using 4.2.12.

If you want to know how to reproduce. The best way to reproduce on my machine is:

  • Open Excel
  • just mark everything (button on left upper corner which ist above "1" and left of "A")
  • deselect everything
  • repeat till BSOD

I cannot work with excel in Virtualbox. *sigh*

comment:9 Changed 10 months ago by dcortesi

+1 for 4.2.12. Disabling 3D acceleration fixes it.

It can be reproduced as simply as opening Excel 2013, creating a new blank worksheet, and clicking on the File menu.

comment:10 Changed 6 months ago by misha

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions?

comment:11 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.3.2 (including 4.3.2 Guest Additions).

comment:12 Changed 7 weeks ago by Paul_2.0

Can confirm. Was using vbox with win7 x64 host / guest and was connecting to my work pc (also win7 x64) via rdp and using office 2010 on my work PC for about 6 months without issue. When working with excel 2010 (not all sheets, just one we received recently) guest OS would crash with different bsod error codes. The guest OS would stall and clicking the mouse would not result in any ui changes (ex could not select different cells, rows, etc. could not minimize the RDP connection to get back to my guest OS). If i pressed Ctrl+C to enable/disable scaling mode, it would show a BSOD error (I'm assuming the BSOD was behind the RDP window the whole time and the display just didn't update.) Disabling 3d acceleration seems to have resolved the issue. Thanks very much!

Apologies if this post reopens the ticket; that is not my intention. I just wanted to share my experience and maybe help someone else trouble-shoot if someone is having similar issues. The crash looks like it is just stalled / frozen session and behind it / what's really happening is the BSOD error.

EDIT: Spoke too soon. Still experiencing BSOD even with 3d Acceleration disabled in the video options.

http://imgur.com/TtSZLCN

The driver in question looks like it is related to DirectX. I ran DXDiag64 and saw that my video driver is labeled: Virtual Box Graphics Adapter for Windows Vista. Could this be the issue? I know Vista and 7 share some commonalities in terms of architecture, but shouldn't there be a windows7 video driver for vbox guests and the virtual video adapters?

Last edited 7 weeks ago by Paul_2.0 (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use