VirtualBox

Ticket #10213 (closed defect: duplicate)

Opened 2 years ago

Last modified 20 months ago

Windows Guest Hangs for Random Time Frame

Reported by: bmfesta2009 Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.8 Keywords: Guest,Freeze,Hang,No Response
Cc: Guest type: Windows
Host type: Linux

Description

This issue I have been experiencing for a very long time, since Virtual Box 3.x and I have been attempting this on multiple computers and laptops all with similar results. Primarily I am running an Ubuntu 64 bit Host OS with a Windows 7 64 bit Guest OS. The issue is that the guest OS will become unresponsive in the active window for a random period of time, generally 1-10 minutes.

I have identified that the freeze is not guest OS wide as I can open and interact with other applications, but the focus application remains frozen. I also notice that this is generally created in applications that use any form of alpha blending. Here is an example that happens 100% of the time for me:

Cold boot Ubuntu -> VM Boot Windows -> SSL VPN into Office network -> Remote Desktop into office Computer -> Open Outlook -> Anytime an e-mail is received and the notification appears on the bottom corner of the screen the remote desktop client becomes unresponsive.

This is also repeatable locally using Outlook, but I generally remote into my office pc for e-mail. This freeze has become most tedious while using TurboTax to do my taxes as most of their screens use alpha blending around the text entry boxes.

If using more video memory, or enabling video accaleration, or using the 3D drivers I notice that the experience becomes worse. Any guidance would be greatly appreciated as this is becoming a problem for my productivity. I am currently going to be performing a clean install of both host and guest os to see if this resolves any issues, but I am not expecting anything to change.

Details for VM: [General] Name: Windows 7 (64-bit) OS Type: Windows 7 (64 bit) [System] Base Memory: 5185 MB Processor(s): 4 Execution Cap: 100% Boot Order: Floppy, CD/DVD-ROM, Hard Disk VT-x/AMD-V: Enabled Nested Paging: Enabled [Display] Video Memory: 48 MB Screens: 2 3D Acceleration: Disabled 2D Video Acceleration: Disabled Remote Desktop Server: Disabled Storage? [IDE Controller] IDE Secondary Master (CD/DVD): Empty [SATA Controller] SATA Port 0: Windows 7 (64-bit).vdi (Normal, 100.00 GB) [Audio] Host Driver: PulseAudio Controller: Intel HD Audio [Network] Adapter 1: Intel PRO/1000 MT Desktop (Bridged adapter, eth1) [Serial Ports] Disabled [USB] Device Filters: 0 (0 active) [Shared Folders] Shared Folders: 1

Attachments

Windows 7-2012-02-22-21-30-44.log Download (75.4 KB) - added by bmfesta2009 2 years ago.
RecentSystemHang
Windows 7-2012-02-23-09-37-27.log Download (98.6 KB) - added by bmfesta2009 2 years ago.
Short running instance with freeze scenario.

Change History

comment:1 Changed 2 years ago by bmfesta2009

I have completely formatted my computer and reset all BIOS settings. Since then I have installed a fresh Ubuntu 11.10 Desktop x64 Host OS and Windows 7 Ultimate x64 Guest OS. I still have the issue with the new 3D drivers where it does not work with dual display. So with the legacy 3D driver on I have identified that when the guest OS stops responding that the Host OS shows the VirtualBox process has dropped to 0% CPU usage. I still have not identified the cause for Virtual Box to drop to 0%. Generally when the Guest OS is sitting idle it still uses at least 8% CPU.

Changed 2 years ago by bmfesta2009

RecentSystemHang

comment:2 Changed 2 years ago by bmfesta2009

I'm attaching the log from the most current run where the system has just frozen. Something interesting in the log is this:

01:31:34.486 Changing the VM state from 'RUNNING' to 'SUSPENDING'. 01:31:34.676 Changing the VM state from 'SUSPENDING' to 'SUSPENDED'. 01:31:34.762 Changing the VM state from 'SUSPENDED' to 'RESUMING'. 01:31:34.762 Changing the VM state from 'RESUMING' to 'RUNNING'.

I'm guessing the time is CPU time, because in real time this was actually 3 minutes between suspend and resume. Mind you I did not ever select suspend or resume, I was just using the computer browsing the file system and internet.


Nevermind I'm guessing this is related to the attachment of an ISO where I was installing the application I browsed to.

Last edited 2 years ago by bmfesta2009 (previous) (diff)

Changed 2 years ago by bmfesta2009

Short running instance with freeze scenario.

comment:3 Changed 2 years ago by bmfesta2009

So I just attached a dump file where I booted up an instance opened up internet explorer browsed 3 sites the guest os froze and then I issued a shutdown. So you have a log from startup to shutdown with about 5 minutes of operation. The freeze itself lasted about 2 minutes.

I also ripped out the guest addition software, files, and registry and have proven that it still replicates the issue. So the problem exists before guest additions, leaving it to be in a guest os configuration problem or a host os problem.

So far the only changes in my host OS are the install of Virtual Box and in the guest OS is the install of Microsoft Office. I am starting to test difference configurations of the guest OS.

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Please check the chipset emulation from ICH9 to PIIX3 (VM settings). The ICH9 chipset emulation has known problems.

comment:5 Changed 2 years ago by bmfesta2009

Thank you for the feedback. Does this also apply to the disk controller? Should that be PIIX3, PIIX4, or ICH6? I didn't notice any previous communication around ICH9 issues, sorry if I missed that.

comment:6 Changed 20 months ago by frank

No, that does apply only to the chipset. But with VBox 4.1.20 we fixed some ICH9-related bugs.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use