VirtualBox

Ticket #10211 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

Ubuntu12.04 alpha 2 has not moving mouse

Reported by: melchiaros Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have installed Ubuntu12.04 alpha 2 64bit succesfull on virtualbox 4.1.8.

After login the mouse is not able to move arround.

Additional a left mouse click causes a black screen as long I pushed the left mouse button.After that the desktop looks again normal.

On nativ metal this version of Ubuntu works, so it is a problem from VirtualBox.

Attachments

Ubuntu 12.04 64bit-2012-02-04-16-11-48.log Download (79.8 KB) - added by melchiaros 2 years ago.

Change History

Changed 2 years ago by melchiaros

comment:1 Changed 2 years ago by michael

I take it this is without the Guest Additions installed (since the USB tablet emulation fails here too with Precise A2, but the Additions mouse driver works). Taking a look at /var/log/Xorg.0.log, I see the following lines:

[   131.339] (--) evdev: VirtualBox USB Tablet: Found relative axes
[   131.339] (II) evdev: VirtualBox USB Tablet: Forcing relative x/y axes to exist.
[...]
[   131.339] (II) evdev: VirtualBox USB Tablet: initialized for relative axes.
[   131.339] (WW) evdev: VirtualBox USB Tablet: ignoring absolute axes.

Obviously there has been a change in behaviour in X.Org's evdev driver. I have contacted the upstream maintainer to see if he has any thoughts about this, but you might want to take this up with Ubuntu (one of their developers, Chase Douglas, is quite heavily involved in the X.Org input subsystem just now).

comment:2 Changed 2 years ago by michael

Update: I have already got an answer, to wit, that this should have been fixed in the following upstream commit:  http://cgit.freedesktop.org/xorg/driver/xf86-input-evdev/commit/?id=224a28de25fda654040a9fd4e5c4d748c9e29809

Last edited 2 years ago by michael (previous) (diff)

comment:3 Changed 2 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Closing as invalid, since the upstream fix solves the problem here. Please re-open if you feel that this is not right.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use