VirtualBox

Ticket #10163 (closed defect: fixed)

Opened 2 years ago

Last modified 3 months ago

GDM (gnome-shell mode) hangs most of the time

Reported by: mooninite Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by misha) (diff)

Host: Fedora 16 x86_64

Guest: Fedora 16 i686

VirtualBox 4.1.8 GA installed. SELinux is in permissive mode in the guest.

9 times out of 10, GDM will never appear. I connected with SSH and ran GDB on gnome-shell --gdm-mode and got this backtrace:

(gdb) bt
#0  0x006dc416 in __kernel_vsyscall ()
#1  0x006034d2 in __lll_lock_wait () from /lib/libpthread.so.0
#2  0x005fee71 in _L_lock_775 () from /lib/libpthread.so.0
#3  0x005fed2b in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x0067363c in crLockMutex () from /usr/lib/VBoxOGLcrutil.so
#5  0x00d787ec in stubMakeCurrent () from /usr/lib/dri/vboxvideo_dri.so
#6  0x00d8dc54 in vboxstub_glXMakeCurrent () from /usr/lib/dri/vboxvideo_dri.so
#7  0x00d8ef3c in vboxstub_glXMakeContextCurrent ()
   from /usr/lib/dri/vboxvideo_dri.so
#8  0x00d90176 in vboxstub_glXMakeCurrentReadSGI ()
   from /usr/lib/dri/vboxvideo_dri.so
#9  0x00d909bd in vbox_glXMakeCurrentReadSGI ()
   from /usr/lib/dri/vboxvideo_dri.so
#10 0x4dcd8043 in ?? () from /usr/lib/libcogl.so.5
#11 0x4dc9abd4 in cogl_display_setup_EXP () from /usr/lib/libcogl.so.5
#12 0x00a37967 in ?? () from /usr/lib/libclutter-glx-1.0.so.0
#13 0x00a59e03 in ?? () from /usr/lib/libclutter-glx-1.0.so.0
#14 0x00a794c9 in ?? () from /usr/lib/libclutter-glx-1.0.so.0
#15 0x00a86c43 in ?? () from /usr/lib/libclutter-glx-1.0.so.0
#16 0x00a88289 in clutter_init () from /usr/lib/libclutter-glx-1.0.so.0
#17 0x4d0a81b6 in meta_init () from /usr/lib/libmutter.so.0
#18 0x08049da9 in main ()

Change History

comment:1 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions, and re-open the ticket if needed?

comment:2 Changed 3 months ago by mooninite

This was fixed with ticket 12319. I had forgotten I had opened this ticket.

comment:3 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use