VirtualBox

Ticket #10149 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

VBoxHeadless: RegGetValueA could not be located in ADVAPI32.d

Reported by: vadimrapp Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.8 Keywords:
Cc: Guest type: other
Host type: other

Description

After upgrading to 4.1.8, when I launch virtual machine by using vboxheadless.exe ,there's error message "The procedure entry point RegGetValueA could not be located in ADVAPI32.dll"

Note that according to  http://social.msdn.microsoft.com/Forums/en/vcgeneral/thread/910a0e22-42bf-437d-8f5b-0162cc691f89 , in Windows XP function RegGetValueA is only available in 64-bit version, and instead RegQueryValueEx should be used.

Attachments

VBox.log Download (37.2 KB) - added by vadimrapp 2 years ago.
log file

Change History

Changed 2 years ago by vadimrapp

log file

comment:1 Changed 2 years ago by misha

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #10071. Please take a look at my last comment to #10071 for the link to the test build with a fix for this issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use