VirtualBox

Ticket #10120 (new defect)

Opened 2 years ago

Host-only adapter spontaneously loses DHCP-leased IP

Reported by: jgehrcke Owned by:
Priority: major Component: network
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hello!

My Setup:

I'm running VB 4.1.6 on an Ubuntu 10.04 LTS host with a Debian Squeeze as guest. My network configuration is

1) Host-only adapter for convenient host<->guest accessibility through 192.168.56.x IPs. The guest network corresponding to this adapter is configured dynamically via DHCP.

2) NAT adapter for "internet access" in the guest.

The host is a workstation which I've never rebooted so far during the time I'm working with VB (I have been using VB for a few weeks now).

The problem:

I've experienced the host-only adapter "losing its IP" already two times now. Each of the times, it happened like this:

1) I started the VM up to the Debian login screen and did not graphically log in.

2) I made sure that the guest's network interface corresponding to the host-only adapter successfully got its network configuration via DHCP (including the IP 192.168.56.101) by hovering the mouse pointer over the network symbol of the VB window corresponding to the VM. It said for example (among others):

Adapter 1 (Host-only adapter): IP 192.168.56.101, cable connected

3) I then made sure that I can connect from the host to the guest via

    ssh user@192.168.56.101

This worked pretty well.

4) Basically, I then did not use the guest for a few days. I did not use VB at all in the meantime. This means that I did not start other VMs. I simply did not touch VB, I just left the VM described here running and running....

5) After a few days, I tried to ssh user@192.168.56.101 again, but the host was not reachable.

6) Hovering over the network symbol of the VB window corresponding to the VM said:

    Adapter 1 (Host-only adapter): cable connected

I.e. the host-only adapter of the guest "lost" its IP address. As I said, I've observed this two times now. I do not know how to reliably reproduce it but it seems like a severe problem to me, because this issue renders the VM inaccessible from the outside.

Do you know this problem? What should I do to further debug it? I did not try version 4.1.8, because the changelog does not indicate a change regarding the host-only adapter. Could it be a problem of configuration within the guest (some power saving stuff)?

Thanks,

Jan-Philip Gehrcke

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use