VirtualBox

Ticket #10010 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

RHEL6.2 64bit guest addition breakage -> fixed as of 12 Jan 2012

Reported by: Romario74 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Using Red Hat Enterprise Linux 6.2 64bit, the guest additions do no build cleanly. I have attached logfiles. Here is console output of installation:

[root@vm-rhel6 VBOXADDITIONS_4.1.6_74713]# ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 4.1.6 Guest Additions for Linux.........
VirtualBox Guest Additions installer
Removing installed version 4.1.6 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules           [  OK  ]
Removing existing VirtualBox non-DKMS kernel modules       [  OK  ]
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module                   [  OK  ]
Building the shared folder support module                  [  OK  ]
Building the OpenGL support module                         [FEHLGESCHLAGEN]
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions              [  OK  ]
Installing the Window System drivers
Installing X.Org Server 1.10 modules                       [  OK  ]
Setting up the Window System to use the Guest Additions    [  OK  ]
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services componen[  OK  ]

Attachments

vboxadd-install-x11.log Download (73 bytes) - added by Romario74 2 years ago.
VBoxGuestAdditions.log Download (142 bytes) - added by Romario74 2 years ago.
vboxadd-install.log Download (154.8 KB) - added by Romario74 2 years ago.
new install log

Change History

Changed 2 years ago by Romario74

Changed 2 years ago by Romario74

comment:1 Changed 2 years ago by Romario74

only relevant file is I guess vboxadd-install.log

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

This is not a bug. The Additions are installed correctly. The DRM module cannot be built. This is expected on some Linux distributions.

comment:3 Changed 2 years ago by michael

  • Status changed from closed to reopened
  • Resolution invalid deleted
  • Summary changed from RHEL6.2 64bit guest addition breakage to RHEL6.2 64bit guest addition breakage -> fixed as of 6 Jan 2012

Closer inspection showed that this is due to changes in the RHEL/OEL kernel relative to the same version number upstream. The Additions test build linked below (usual disclaimers apply) should contain the fix.

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r75565.iso

comment:4 Changed 2 years ago by michael

  • Description modified (diff)

comment:5 Changed 2 years ago by Romario74

Hmm no, it does not seem to build clean.

Console:

[root@vm-rhel6 VBOXADDITIONS_4.1.9_75566]# sh VBoxLinuxAdditions.run 
Verifying archive integrity... All good.
Uncompressing VirtualBox 4.1.9 Guest Additions for Linux.........
VirtualBox Guest Additions installer
Removing installed version 4.1.8 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules           [  OK  ]
Removing existing VirtualBox non-DKMS kernel modules       [  OK  ]
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module                   [  OK  ]
Building the shared folder support module                  [  OK  ]
Building the OpenGL support module                         [FEHLGESCHLAGEN]
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions              [  OK  ]
Installing the Window System drivers
Installing X.Org Server 1.10 modules                       [  OK  ]
Setting up the Window System to use the Guest Additions    [  OK  ]
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services componen[  OK  ]
[root@vm-rhel6 VBOXADDITIONS_4.1.9_75566]# 

And I will attach vboxadd-install.log.

Changed 2 years ago by Romario74

new install log

comment:7 Changed 2 years ago by Romario74

Yes, this builds clean. Thank you!

comment:8 Changed 2 years ago by michael

  • Summary changed from RHEL6.2 64bit guest addition breakage -> fixed as of 6 Jan 2012 to RHEL6.2 64bit guest addition breakage -> fixed as of 12 Jan 2012

Thanks for testing. I will update my over-eager fix date!

comment:9 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Fix is part of VBox 4.1.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use