[vbox-dev] 3d pass-through and gnome-shell ?

Hans de Goede hdegoede at redhat.com
Fri Jun 23 09:52:19 GMT 2017


On 23-06-17 10:44, Michael Thayer wrote:
> Hello Hans,
> 22.06.2017 11:49, Hans de Goede wrote:
> [...]
>> I've been testing vbox 3d pass-through, and if I use metacity as a window
>> manger then running glxgears -info shows:
>> GL_RENDERER   = Chromium
>> GL_VERSION    = 2.1 Chromium 1.9
>> GL_VENDOR     = Humper
>> So things seem to be working, but gnome3 / gnome-shell does not work ?
> [...]
> Sorry, another slow response, and sorry too that it will not be a very
> satisfactory response.  What you are pointing out is a known problem
> with our 3D.  It only works for X11 clients, not for Wayland.

I was sort off expecting that already and tried with X11 (which gnome3
still supports just fine), but that does not work either.

> This is
> fixable in theory, but has been so far down the priority list for so
> long that we have officially declared it as user contribution only[1].
> In fact, as soon as I get round to it I will disable 3D support for
> Fedora guests altogether, as it is not reliable.

With this I assume you mean removing the 3d accel checkbox in device
settings, because it already is off by default, right ?

> Our 3D detection
> mechanism at start-up is too slow as compared to the Fedora log-in
> screen appearing, and often prevents log-in altogether.

Hmm can you elaborate a bit on this? This sounds like something which
is worthwhile fixing.

Note I've also tried booting into runlevel 3 and then doing "startx"
this also does not work, maybe I first need to start a none gnome-3
session, run glxgears there and then try startx  with a gnome3-session,
or does the slow detection get redone every time ?



More information about the vbox-dev mailing list