[vbox-dev] VBoxPuelMain.DLL - GetLastError=126

Ribhi Kamal rbhkamal at gmail.com
Thu Mar 17 13:07:47 GMT 2011

Hi all!

I compiled VirtualBox 4.0.51 from trunk then tried to install the extension
pack only to be greeted by the following error:
C:\bin>VBoxManage.exe extpack install
Progress state: E_FAIL
VBoxManage.exe: error: Failed to install
Failed to load the main module

So I recompiled the code in debug and stepped through the code, and sure
enough, LoadLibrary MS-function was failing to load VBoxPuelMain.DLL even
though the path is correct.

Thinking that this might be an rependancy issue, I tried to pause the
execution of vboxsvc.exe right before it tries to call LoadLibrary and
copied all the DLLs that it needs to same location as the DLL (in the
win.x86 folder).... but still I got the same error.

Any Ideas on why that would happen? Perhaps I'm compiling the
code incorrectly?

So far, I was unable to get USB support to work, however, everything else
seems to work fine. So any help would be greatly appreciated.

Thanks in advance!
-- RK
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20110317/ada26eac/attachment.html>

More information about the vbox-dev mailing list