[vbox-dev] Newer revisions not compiling on Debian Lenny

walt w41ter at gmail.com
Fri Dec 19 21:05:42 GMT 2008

On Fri, 19 Dec 2008, walt wrote:

> On Fri, 19 Dec 2008, André Neves wrote:
> > Hi all. I'm not quite sure if I should report this here, but I'll give it a
> > shot.
> >
> > I've had troube compiling VBox for the last couple of times I tried, always
> > with the same error:
> >
> > /usr/bin/ld: final link failed: Nonrepresentable section on output...
> The real error appears above that:
> /usr/include/c++/4.1.3/bits/stl_construct.h:107: undefined reference to
> `std::basic_string<char, std::char_traits<char>,
> std::allocator<char> >::~basic_string()'
> ...

I missed the obvious, that this is a linker error not a compiler error.

That undefined symbol is defined in libstdc++ like this:

# nm -C libstdc++.a | grep 'basic_string<char,' | grep ~b
00000000 W std::basic_string<char, std::char_traits<char>, std::allocator<char>

I'm no expert on linking, that's for sure, but here is a great essay on
linking libstc++ statically (which is what vbox does).  When I understand
everything in it, I'll get back to you ;o)


More information about the vbox-dev mailing list