[vbox-dev] Newer revisions not compiling on Debian Lenny

Frank Mehnert Frank.Mehnert at Sun.COM
Fri Dec 19 15:55:11 GMT 2008

On Friday 19 December 2008, André Neves wrote:
> Hi all. I'm not quite sure if I should report this here, but I'll give it a
> shot.
> I've had troube compiling VBox for the last couple of times I tried, always
> with the same error:
> /usr/bin/ld: final link failed: Nonrepresentable section on output
> Has anyone seen it before? I don't have a clue on how to fix that.
> I attached the ouptut of configure and kmk so you could see the error in
> full. As you can see on the command line for configure, I'm using GCC 4.1.

We don't use gcc-4.1, I strongly suggest you to use gcc/g++-4.2.
This should compile your tree.

Kind regards,

Dr.-Ing. Frank Mehnert    Sun Microsystems    http://www.sun.com/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://www.virtualbox.org/pipermail/vbox-dev/attachments/20081219/8e5814ca/attachment.sig>

More information about the vbox-dev mailing list