[vbox-dev] VirtualBox doesn't compile on openSUSE Linux 10.3

walt w41ter at gmail.com
Fri Aug 29 22:57:27 GMT 2008

Alexey Eremenko wrote:
> Hi All !
> I have tried to compile latest VBox nightly build (11791), but it
> always give me the same error:
> I have tried several versions back too, doesn't helps, fails on same error.
> ...
> kernel

I don't know if this is relevant, but that kernel is a bit old now.  Does
SUSE provide anything more recent?

 > ...
> from /usr/include/linux/if_tun.h:22,
> ...
> /usr/include/linux/if.h:118: error: redefinition of 'struct ifmap'
> /usr/include/net/if.h:113: error: previous definition of 'struct ifmap'
 > ...

The line error line numbers for those header files don't make any sense when
I compare them to my own files, so your kernel header files are probably also
fairly old.

When I compile vbox from svn sources I always see the compiler checking for
header files in /usr/src/linux/include -- i.e. in the kernel source code, not
the system header files in /usr/include/.  The vbox code prefers to use the
headers provided by the kernel sources over whatever random headers the SUSE
devs chose to install on your machine.

I can't promise that this will work, but I suggest that you install a newer
kernel and the also the matching kernel source code because vbox will be
happier that way :o)  Even better if you compile your own kernel instead of
installing one of the pre-compiled ones.  For example (watch for line-wrap):

More information about the vbox-dev mailing list