Opened 16 years ago
Closed 16 years ago
#4570 closed defect (fixed)
vboxapisetup.py - No module named distutils.core => fixed in SVN
Reported by: | gwr | Owned by: | |
---|---|---|---|
Component: | installer | Version: | VirtualBox 3.0.2 |
Keywords: | pkgadd distutils | Cc: | |
Guest type: | other | Host type: | Solaris |
Description
Attempting to install VirtualBox-3.0.2-SunOS-r49928.pkg on Solaris Nevada (snv_119) and saw this error:
pkgadd -d VirtualBox-3.0.2-SunOS-r49928.pkg [...] ## Executing postinstall script. Loading VirtualBox kernel modules... VirtualBox Host kernel module loaded. VirtualBox NetAdapter kernel module loaded. VirtualBox NetFilter kernel module loaded. VirtualBox USB kernel module loaded. Configuring services and drivers... Installing Python bindings... Traceback (most recent call last): File "./vboxapisetup.py", line 17, in ? from distutils.core import setup ImportError: No module named distutils.core Updating boot archive... Done. Installation of <SUNWvbox> was successful.
My system was installed with the SUNWCuser "cluster", ("End User System Support") not the "full distribution".
The installed Python packages are:
gwr# pkginfo |grep SUNWPython GNOME2 SUNWPython The Python interpreter, libraries and utilities GNOME2 SUNWPython-extra Supplemental Python libraries and utilities GNOME2 SUNWPython25 The Python interpreter, libraries and utilities GNOME2 SUNWPython26 The Python interpreter, libraries and utilities GNOME2 SUNWPython26-extra Supplemental Python libraries and utilities
It looks like distutils.core file is part of this package:
SUNWPython-devel
This solved the problem for me:
pkgadd -d ... SUNWPython-devel pkgrm SUNWvbox pkgadd -d VirtualBox-3.0.2-SunOS-r49928.pkg
Change History (5)
comment:1 by , 16 years ago
comment:2 by , 16 years ago
Or alternatively, make that part of the postinstall script check for existence of the distutils.core object and skip setting up the Python bindings if that's missing.
comment:3 by , 16 years ago
Thanks a lot for the report. This has been fixed in internal SVN and should be part of the next release.
comment:4 by , 16 years ago
Summary: | vboxapisetup.py - No module named distutils.core → vboxapisetup.py - No module named distutils.core => fixed in SVN |
---|
comment:5 by , 16 years ago
Resolution: | → fixed |
---|---|
Status: | new → closed |
The "depend" file in the SUNWvbox package really should include