VirtualBox

Version 25 (modified by achimha, 14 years ago) (diff)

--

Status: Guest OSes

The following table gives an overview of how well VirtualBox supports various operating systems in its virtual machines. Rows marked with an asterisk (*) contain information reported by users and not verified by InnoTek. (Page last updated 2007-06-17)

Guest OS Status Remarks
Windows family
Windows Vista Works, with Additions Need to install networking driver in guest manually; see User FAQ
Windows 2000 Works, with Additions
Windows XP Works, with Additions
Windows Server 2003 Work, with Additions
Windows NT
Works, with Additions Some issues with old service packs. Recommended to install service pack 6a. * Windows 98 Works, no Additions available Linux family Generally, all 2.4 and 2.6 kernels work; however, we recommend 2.6.13 or above for better performance. Kernels 2.6.18 to 2.6.18.2 contain a race condition (which was unfortunately backported to the Ubuntu 6.06 Server and 6.10 kernels) that can cause boot crashes in virtual machines. Ubuntu 5.10/6.06 Desktop/7.04 herd 5 Work, with Additions Ubuntu 6.06 Server/6.10 Works partially, with Additions The Ubuntu 6.06 Server and 6.10 kernels suffer from the race condition mentioned above. Debian 3.1/4.0 Works, with Additions SUSE 9/10.0 Work, with Additions SUSE 10.2 Works partially, with Additions The SUSE 10.2 kernel suffers from the race condition mentioned above. Mandrake 10.1 Works, with Additions Fedora Core 1/4/5/6 Work, with Additions Fedora 7 Works X.org driver of Additions not working in VirtualBox 1.4.0 Red Hat Enterprise Linux 3, 4 and 5 Work, with Additions * Red Hat Linux 9 Works, with Additions *Red Hat Linux 7 Doesn't work * Linspire 4.5 Works, with Additions * Slackware 10.1 Works, with Additions * Conectiva 10 Works, with Additions * Xandros 3 Doesn't work Xandros 4 Works, with Additions ArchLinux Works, with Additions Installation has to be booted with the ide-legacy option. Unices FreeBSD Works partially FreeBSD 6.2 is known to cause problems. * PC-BSD 1.3 Doesn't work OpenBSD Works, no Additions available Solaris 10 Works Not all releases work reliably. Others DOS Works, no Additions available Only limited testing as part of system installation processes has been performed. OS/2 Works partially Requires VT-x hardware virtualization support. Only MCP2 is reported to work reliably so far. * Novell Netware 6.5 Doesn't work * BeOS 5 Doesn't work * Syllable Works * Visopsys Doesn't work * ReactOS Doesn't work * SkyOS Works, no Additions available

www.oracle.com
ContactPrivacy policyTerms of Use