VirtualBox

Ticket #9935 (closed defect: duplicate)

Opened 2 years ago

Last modified 23 months ago

vboxsf crashes on fedora host

Reported by: mrsombre Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.6 Keywords: shared
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I install vbox guest additions on Fedora for using Linux guest as server and my Windows 7 host for working. So, directory on my Windows (C:\webservers\home) mapped to Linux /web and my Apache server serve from this directory. I working on Windows and changing and renaming files, that causes errors on guest. But just editing files works fine.

Some times I has something like 'ls: cannot access _Environment.php: No such file or directory', after i renamed Environment.php to _Environment.php

[root@web application]# ls -l
ls: cannot access _Environment.PHP: No such file or directory
total 28
-rwxrwx--- 1 root vboxsf 5325 Nov 21 03:01 Bootstrap.PHP
drwxrwx--- 1 root vboxsf 4096 Nov 21 02:52 configs
?????????? ? ?    ?         ?            ? _Environment.PHP
-rwxrwx--- 1 root vboxsf  943 Nov 21 02:32 Environment.temp.PHP
drwxrwx--- 1 root vboxsf 4096 Nov 20 13:52 forms
-rwxrwx--- 1 root vboxsf 1458 Nov 21 13:04 Init.PHP
...

Also I made a little test on PHP. I create file with check file_exists(). Then I make test file and method return true. Then I remove file and has true again :\ I check local folder and test was passed (true, false).

I can't found what a problem. I tried to reinstall vboxadd, recreate shared folder. Mount it from /etc/fstab, by mount -t vboxsf, by automount (/media/sf_foldername). And always has same issue. If I change file contents all works as expected. But if remove/add/rename files I has errors with ls: cannot access or with PHP can't determine removed file or not. Looks like file system is broken. But remounting share fixes this problem for next time i renaming files.

Please, where I can found error? I think problem in vboxsf file system, but where.

For info: guest - Fedora16 x64 (upgraded by yum) host - Windows 7 x64 vm - VirtualBox 4.1.6 vbox additions updated on guest and on version 4.1.6

Attachments

VBox.log Download (44.2 KB) - added by mrsombre 2 years ago.
Fedora VBox.log

Change History

Changed 2 years ago by mrsombre

Fedora VBox.log

comment:1 in reply to: ↑ description Changed 2 years ago by mrsombre

Sorry, title should be 'vboxsf crashes on fedora guest'

comment:2 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Looks like a duplicate of #9887.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use