VirtualBox

Ticket #9884 (closed defect: duplicate)

Opened 2 years ago

Last modified 23 months ago

attempting to run a 64 bits guest reboot the linux host (AMD)

Reported by: zebul6 Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I am running Archlinux 32 bits, up to date as of 2011-11-10. with a 3.1 kernel on an inspiron 531 with an AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ AuthenticAMD

For the record, I am able to run Ubuntu 11.10 64 bits on this box natively

The issue/bug: When I attempt to run any (either windows 7 64 bits or ubuntu 11.10 64 bits, and I think I could enlarge the list to whatever you like) with virtualbox 4.1.6, it blacken the screen and reboot the box/pc!

I was expecting this to be fixed other time but I see no improvement. This is not a new bug. It happens since at least vbox 4, kernel 2.6.39

I think it has to do with the linux kernel but I can't be sure.

Scenario: Attempting to install Windows 7 64 bits by booting the iso/dvd

With PAE/NX enabled with IO-APIC activated, it freezes after displaying "Starting Windows"

With PAE/NX enabled without IO-APIC activated, it rebooted right after "Starting Windows" is displayed after the "Windows is loading files" screen

If I enable PAE/NX with IO-APIC, it reboots as soon as "Starting Windows" is displayed

One get a similar experience attemting to install ubuntu 11.10 64 bits from vbox (not sure about the config of the VM)

Also booting ubuntu 11.10 64 bits from a real partition with vbox in archlinux 32 bits, gives a reboot as soon as the boot process begins (after grub screen)

Also booting Windows 7 Home Premium 64 bits from a real partition with vbox in archlinux 32 bits) gives also a reboot

I have gave up trying to use anything 64 bits with vbox because of that reboot.

I got no problem running Ubuntu 11.10 64 bits (from a real partition) from Windows 7 Home Premium 32 bits with virtualbox.

Attachments

VBox.log Download (43.0 KB) - added by zebul6 2 years ago.
log
VBox.2.log Download (45.4 KB) - added by zebul6 2 years ago.
Attempt to run Ubuntu 11.10 64 bits (Guest - rawdisk) on archlinux 32 bits (Host)
VBox.3.log Download (42.6 KB) - added by bjh 2 years ago.
My log file

Change History

Changed 2 years ago by zebul6

log

Changed 2 years ago by zebul6

Attempt to run Ubuntu 11.10 64 bits (Guest - rawdisk) on archlinux 32 bits (Host)

comment:1 Changed 2 years ago by zebul6

I should have mentionned that I use the archlinux virtualbox packages: virtualbox, virtualbox-modules, virtualbox-additions, and virtualbox-ext-oracle (the last one from AUR).

May be I should have opened a bug on archlinux tracker first.

comment:2 Changed 2 years ago by frank

  • Summary changed from attempting to run a 64 bits guest reboot the linux host to attempting to run a 64 bits guest reboot the linux host (AMD)

No, you are correct here.

comment:3 Changed 2 years ago by bjh

I'm now seeing this bug after upgrading my host to Ubuntu 12.04 32 bit. 11.10 was fine. The host is an AMD Phenom II 955, 4GB RAM, kernel 3.2.0-24-generic-pae (I tried non-pae but it made no difference).

The host reboots whenever I try to start a 64 bit guest. 32 bit guests are fine. VirtualBox is latest 4.1.14 from download.virtualbox.org. I've also tried the 4.1.12 from Ubuntu but it was the same.

Changed 2 years ago by bjh

My log file

comment:4 Changed 23 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Most likely a duplicate of #10528. Please see there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use