VirtualBox

Ticket #9875 (closed defect: obsolete)

Opened 8 years ago

Last modified 15 months ago

can not install openbsd as guest

Reported by: rna023 Owned by:
Component: other Version: VirtualBox 4.1.6
Keywords: openbsd Cc:
Guest type: BSD Host type: Linux

Description

It prompt "Segmentation fault" freqently.

Attachments

VBox.log Download (68.4 KB) - added by rna023 8 years ago.
0.jpg Download (20.4 KB) - added by rna023 8 years ago.
1.jpg Download (60.8 KB) - added by rna023 8 years ago.
2.jpg Download (40.8 KB) - added by rna023 8 years ago.
3.jpg Download (40.8 KB) - added by rna023 8 years ago.

Change History

Changed 8 years ago by rna023

Changed 8 years ago by rna023

Changed 8 years ago by rna023

Changed 8 years ago by rna023

Changed 8 years ago by rna023

comment:1 Changed 8 years ago by rna023

in the picture 2.jpg , it stoped ,did not move ,I have to close the vm manually.

comment:2 Changed 8 years ago by Perryg

IIRC openBSD requires VT-x or AMD-V hardware virtualization support.

comment:3 Changed 7 years ago by jacksar

This is not a BSD issue, it is an OpenBSD + VirtualBox issue.

FreeBSD installs and runs in VirtualBox without problems.

<opinion>It seems to me that the VirtualBox developers over time have simply chosen to ignore the issue rather than fixing it, which I've been told is completely feasible.</opinion>

comment:4 Changed 7 years ago by frank

Well, we don't ignore this issue but we have a lot of other problems with higher priorities. You can get an impression if you search through the list of bugs on this site. And BSD is not officially supported by VirtualBox. So we might debug this problem sooner or later but there is no guarantee, sorry.

comment:5 Changed 7 years ago by frank

And jacksar, you did also not deliver any additional information. The original reporter added a VBox.log file which clearly shows that VT-x is not available on his host. Perry already answered that VT-x is required to get *BSD running on VirtualBox. So before complaining about missing support you should do your homework first and provide more information (e.g. a VBox.log file of a VM session where you attempted to run that guest).

comment:6 Changed 7 years ago by jacksar

frank:

There is zero reason for me to provide additional information. I am not presenting any new complaints.

Also, you can spout all you want that such-and-such clearly shows that VT-x is not available on so-and-so's host, and that so-and-so2 stated the need for it but that doesn't change that numerous people have used temporary solutions to this very permanent problem (some command line arguments to VBoxSDL I believe) that no longer work in recent versions of VirtualBox. It also does not change the fact that other virtualization technologies, and some emulation ones, can run OpenBSD just fine.

Your original attempt at civility was nice. And was lost on your second message.

comment:7 Changed 7 years ago by frank

jacksar, your last message added zero information to this ticket and your response showed that you did not really attempt to get any help.

Anyway, I did not test BSD as VirtualBox guest myself but I know from others that BSD runs well on VirtualBox with VT-x enabled. If it does not work with VT-x enabled then the problem is more interesting for us to fix. If we you demand on a fix for the non-VT-x (raw mode) then I must admit the chances are very low for a fix.

And, just for your information, virtualization is different from emulation, so Qemu (if you have that in mind) is a bad example. But this is off-topic.

comment:8 Changed 7 years ago by jacksar

frank:

Once again, as I am indeed adding no new complaints, there is no new information for me to add. You seem to be missing that and another few basic concepts: something didn't work in VirtualBox, many users managed to make it work using hacky workaround, and those workarounds were never integrated and have been all but disabled.

Many people have machines that work just fine, and have no interest in buying new hardware just to appease their software. It's a waste of resources and money (especially considering recycling legislations and fees nowadays.)

While I made be blunt and unable to offer any help that can help the development base offer a polished workaround to the lack of "BSD" support (which is a farce considering some default BSD kernels work OOTB), I assure you that I would like help. I wouldn't post if I didn't care.

comment:9 Changed 7 years ago by frank

jacksar, even if some BSD guests work out of the box for you it does not mean that makes sense to support BSD guests in general. You can be assured that we make VirtualBox as compatible to native hardware as possible and many people report success with guests I've never heart about. But we cannot provide support for everything, at some point there is a border (also keeping our limited resources in mind). And another such limitation is that we non-VT-x/AMD-V mode will only work with certain guests. Don't blame VirtualBox but rather blame the hardware vendors not providing sufficient technology to allow a secure and well-performing virtualization without VT-x/AMD-V.

I suggest you to read the paper Analysis of the Intel Pentium's Ability to Support a Secure Virtual Machine Monitor by Robin and Irvine, this paper explains the problem.

But you make me curious: Which hacky workarounds are you talking about? And why should we integrate a hacky workaround into the VirtualBox code?

comment:10 Changed 4 years ago by gb0x79

I was able to install OpenBSD as a guest with

  • 32-bit linux 3.x host running on a 64-bit cpu
  • hw virtualization disabled in BIOS
  • virtualbox 4.3.28

The key was to enable I/O APIC in System->Motherboard configuration. Perhaps as a side effect, now the cpu usage of the VB process (VBoxSDL) in the host is consistently high, even when the guest is idle.

comment:11 Changed 15 months ago by crater

Just a note from the future, wanted to report no issues installing OpenBSD 6.3 amd64 under Version 5.2.12 r122591 (Qt5.6.3). Host environment is macOS High Sierra 10.13.4 on Intel Core i7. dmesg(8) from guest:

OpenBSD 6.3 (GENERIC.MP) #3: Fri May 18 00:06:26 CEST 2018
    root@syspatch-63-amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 2130640896 (2031MB)
avail mem = 2059055104 (1963MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0xe1000 (10 entries)
bios0: vendor innotek GmbH version "VirtualBox" date 12/01/2006
bios0: innotek GmbH VirtualBox
acpi0 at bios0: rev 2
acpi0: sleep states S0 S5
acpi0: tables DSDT FACP APIC SSDT
acpi0: wakeup devices
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i7-4960HQ CPU @ 2.60GHz, 2594.38 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,SSSE3,CX16,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,RDRAND,NXE,RDTSCP,LONG,LAHF,ABM,ITSC,FSGSBASE,AVX2,INVPCID,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
acpitimer0: recalibrated TSC frequency 2594002019 Hz
cpu0: smt 0, core 0, package 0
mtrr: CPU supports MTRRs but not enabled by BIOS
cpu0: apic clock running at 1000MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i7-4960HQ CPU @ 2.60GHz, 2594.24 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,SSSE3,CX16,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,RDRAND,NXE,RDTSCP,LONG,LAHF,ABM,ITSC,FSGSBASE,AVX2,INVPCID,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
, remapped to apid 2
acpiprt0 at acpi0: bus 0 (PCI0)
acpicpu0 at acpi0: C1(@1 halt!)
acpicpu1 at acpi0: C1(@1 halt!)
acpibat0 at acpi0: BAT0 model "1" serial 0 type VBOX oem "innotek"
acpiac0 at acpi0: AC unit online
acpivideo0 at acpi0: GFX0
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel 82441FX" rev 0x02
pcib0 at pci0 dev 1 function 0 "Intel 82371SB ISA" rev 0x00
pciide0 at pci0 dev 1 function 1 "Intel 82371AB IDE" rev 0x01: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <VBOX HARDDISK>
wd0: 128-sector PIO, LBA, 20480MB, 41943040 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <VBOX, CD-ROM, 1.0> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
vga1 at pci0 dev 2 function 0 "InnoTek VirtualBox Graphics Adapter" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
em0 at pci0 dev 3 function 0 "Intel 82540EM" rev 0x02: apic 2 int 19, address 08:00:27:36:71:e8
"InnoTek VirtualBox Guest Service" rev 0x00 at pci0 dev 4 function 0 not configured
auich0 at pci0 dev 5 function 0 "Intel 82801AA AC97" rev 0x01: apic 2 int 21, ICH
ac97: codec id 0x83847600 (SigmaTel STAC9700)
audio0 at auich0
ohci0 at pci0 dev 6 function 0 "Apple Intrepid USB" rev 0x00: apic 2 int 22, version 1.0
piixpm0 at pci0 dev 7 function 0 "Intel 82371AB Power" rev 0x08: apic 2 int 23
iic0 at piixpm0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 configuration 1 interface 0 "Apple OHCI root hub" rev 1.00/1.00 addr 1
uhidev0 at uhub0 port 1 configuration 1 interface 0 "VirtualBox USB Tablet" rev 1.10/1.00 addr 2
uhidev0: iclass 3/0
ums0 at uhidev0: 5 buttons, Z and W dir
wsmouse1 at ums0 mux 0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on wd0a (5f736ce6f8d8d304.a) swap on wd0b dump on wd0b
wsmouse1: can't attach mux (error=5)
wsmouse1 detached
ums0 detached
uhidev0 detached
uhidev0 at uhub0 port 1 configuration 1 interface 0 "VirtualBox USB Tablet" rev 1.10/1.00 addr 2
uhidev0: iclass 3/0
ums0 at uhidev0: 5 buttons, Z and W dir
wsmouse1 at ums0 mux 0
wsmouse1 detached
ums0 detached
uhidev0 detached
uhidev0 at uhub0 port 1 configuration 1 interface 0 "VirtualBox USB Tablet" rev 1.10/1.00 addr 2
uhidev0: iclass 3/0
ums0 at uhidev0: 5 buttons, Z and W dir
wsmouse1 at ums0 mux 0

CPU features on host system reported as follows:

machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 FMA CX16 TPR PDCM SSE4.1 SSE4.2 x2APIC MOVBE POPCNT AES PCID XSAVE OSXSAVE SEGLIM64 TSCTMR AVX1.0 RDRAND F16C

The main usability improvement that I could see being made here is to introduce support for OpenBSD in the guest additions since that would add a lot in terms of virtual desktop usability, i.e. copy paste, shared folders, etc. Can address in separate ticket.

comment:12 Changed 15 months ago by janitor

  • Status changed from new to closed
  • Resolution set to obsolete

Thanks for the update, but your i7 has VT-x support.

For the case without VT-x --recompile-supervisor might help.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use