Ticket #9786 (new defect)

Opened 7 years ago

Last modified 7 months ago

USB devices freeze VM instances and VB main window under certain conditions

Reported by: jiggle-o Owned by:
Priority: minor Component: USB
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

In one certain instance I have found that any tested usb Headsets will freeze the VM and the VirtualBox windows. Since the latest upgrade when connecting a USB headset (I have tried 3), upon opening any program that would use the headset the VM will freeze. It will also make the main VirtualBox windw freeze to where you cannot shut down that VM or open new ones. I have tried with a soft phone, voice recognition and sound recorder. All produce the same effect.

  1. open a Windows VM on a Windows host
  2. attach a USB headset
  3. start Windows sound recorder

next clicking on anything shaould freeze the VM indefinitely This was tested with Win 7 Ult. X64 host and Win 7 Pro X64 guest


VBox.log Download (60.0 KB) - added by UFO 6 years ago.

Change History

comment:1 Changed 6 years ago by UFO

Looks like this may be related to #9780. I experience the same problem with VirtualBox 4.1.6 r74713, running on a Windows 7 x64 host and running a Windows 7 x64 guest.

When the USB device is attached, the guest OS shows the USB audio device in the device manager, but it does not show up in the audio settings. After removing and reinstalling the driver it shows up in the audio settings. When I try to "Test" the audio device, the USB activity indicator lights up and the guest freezes. The VBox main window freezes as well. Trying to detach the USB device or powerdown/savestate the VM freezes the VM window also. I can kill the main window and VBoxSVC, but I can not kill the VM process. Unplugging the USB device from the host does not make a difference. The only way to recover from this situation seems to be to reboot the host.

This particular device identifies itself as C-Media Electronics Inc. USB Multimedia Audio Device.

Changed 6 years ago by UFO


comment:2 Changed 6 years ago by UFO

Attaching the same device to a Windows 7 x64 guest on an Ubuntu Linux x64 host, running VirtualBox 4.1.6 r74713, is less desastrous. The device sort of works - it plays the test audio, but the USB audio driver locks up after a few times. The host is not affected and the VM window remains fully operational.

Using the same USB device with a Windows 7 x32 host and guest also results in a disastrous freeze, with an occasional blue screen.

USB audio devices also seem to be troublesome with USB-over-Ethernet, and may also result in the machine using the device freezing. This may be a timing issue, and may be related to the issue in VirtualBox.

comment:3 Changed 6 years ago by asdlsd

When i plug into guest os my USB AUDIO (Creative SB Play) guest os freeze (crash). And in host system process VB dont kill, only reboot host. I try guest os Win 7 64 - freeze (crash)... I try guest os Win XP - freeze (crash)... I try reinstall host system - freeze (crash)... In Debian (guest os) - not freeze, but i dont install drv for USB AUDIO. I think crash guest os when os uses device (drv install), because first plug (in Win 7) not freeze antil os install drv.

comment:4 Changed 6 years ago by asdlsd

7 months ago! but still no solution (

comment:5 Changed 6 years ago by frank

  • Description modified (diff)

Yes. Where is your patch?

comment:6 Changed 6 years ago by asdlsd

new build released, but problem still was

comment:7 Changed 6 years ago by asdlsd

Dear Developers, It’s a pity that you treat this problem in this way – more than a year has passed! Without solving this problem we can’t get two and more fully-featured working places from one PC. Let me to remind you that VMWare doesn’t have such a problem, but changing for it is postponed because of inconvenience of the "preconnection" of USB devices in it. But this is for the time being. I hope that you will solve the problem or reply anything regarding it.

comment:8 Changed 5 years ago by kartweel

I can confirm the exact same behaviour. Windows 64-bit host.

comment:9 Changed 5 years ago by rcossel

I am experiencing the same issue. The guest OS locks up, and if you attempt to change any settings or reset the guest OS, the VirtualBox application locks up with high CPU usage and the process can not be ended via task manager. Host PC must be reset

Version 4.2.4 r81684 Host - Windows 7 Enterprise SP1 32bit Guest - Windows XP SP3 Headset Plantronics C-Media USB headset

comment:10 Changed 5 years ago by rcossel

Addendum to above post. I have downgraded VirtualBox to version 4.0.16 r75491 and the USB headset works without locking up the PC.

Version 4.0.16 r75491
Host - Windows 7 Enterprise SP1 32bit
Guest - Windows XP SP3
Headset 4Plantronics C-Media USB

comment:11 Changed 5 years ago by Wayward

I have the problem when i have connected USB devices to windows 7 64bit Professional that i cannot shutdown the machine. I have to power off.

Also when copying large files > 8 GB the system tends to freez.

comment:12 Changed 5 years ago by dony

I downloaded 4.2.12 r84980 for a Windows host and I ran into this same issue. Interestingly uninstalling and using 4.0.18 r82821 and it seems to work, so it sounds like maybe this is either a bug introduced afterwards or a regression (think I saw some similar comments from series 3.x)

comment:13 Changed 5 years ago by progmars

Confirmed on Windows 7 64 bit host with Windows 7 32 bit guest. Exactly the same behavior when trying to attach any of the two devices:

  • Logitech QuickCam
  • Novation Scarlet 2i2

Guest seems to install drivers, then hangs, then I try to detach the USB and entire virtual machine hangs. I forcibly close it, but it is still in processes eating about 25% CPU and I cannot kill it nor from Task Manager, nor from Sysinternals Procexp. The only way is to restart the host.

Last edited 5 years ago by progmars (previous) (diff)

comment:14 Changed 4 years ago by vboxuser1

Having the same issue here while trying to connect usb webcam. Using Debian as a host, VM is Windows 7 x64. VirtualBox version is 4.3.18 r96516.

comment:15 Changed 3 years ago by martijnvdzande

Still the same problem in 4.3.22 and 4.3.24.

Virtualbox won't start with USB audio card attached, detach it, it starts, attach it again and virtualbox is taking up 20% CPU.

Last edited 3 years ago by martijnvdzande (previous) (diff)

comment:16 Changed 12 months ago by donpedro

This is still broken in VB 5.1.22 r115126, Windows 8.1 64Bit.

If a USB audio (e.g. headset/speaker) is inserted into a USB 1.0/2.0/3.0 host controller -> instant freeze.

Any update on this would be great. One thing is that it does not work, but a complete freeze seems a bit odd.

It would also indicate that it ends up in a loop somewhere in the USB code.

comment:17 Changed 9 months ago by ByTheBook

This is still broken in VB 5.1.26 r117224 (Qt5.6.2).

Operating System: Windows 10 Pro 64-bit Version 1703 (OS Build 15063.483)
Motherboard: ASUS Z170-Deluxe
USB Audio Device: astro A50

comment:18 Changed 8 months ago by WFV

I concur, still broken in 5.1.26 Host OS = Arch Linux (64bit) latest stable kernel as of this post. Guest = Windows 7 Professional 64bit

Guest locks up and crashes when try to disconnect USB i-phone. dmesg:

usb 4-3: reset high-speed USB device number 3 using ehci-pci ipheth 4-3:4.2: Apple iPhone USB Ethernet device attached USBDevIo--1[4396]: segfault at e8 ip 00007fa17d7983aa sp 00007f9f37ffee80 error 4 in[7fa17d6eb000+197000]

comment:19 Changed 7 months ago by frenchmustard

I can confirm this is still broken on 5.1.28 r117968.

Steps to recreate.

Host is running 64 bit Linux Mint 18.2 with cinnamon desktop on an 8 core AMD FX 8350 (16 vcores) with 16GB ram. Guest is 64 bit Linux Mint 18.2 cinnamon desktop.

The guest has 6 cpu cores assigned and 6GB Ram on a PIIX3 chipset with I/O APIC enabled. Hardware virtualization options are enabled (default interface). 128MB video memory with 3d acceleration. Pulseaudio driver with ICH AC97 controller selected.

The USB controller is enabled with a USB 2.0 EHCI controller selected. I have detected a Plantronics GameCom 780/788 headset which is plugged in to the host on a USB 2.0 port and have added that to the filter list. It is initially left unselected (not mounted).

1) Start the VM. The machine runs correctly.

2) Log in. I get the desktop and can use the machine without errors and with no time restrictions.

3) Open the guest systems sound settings application. I can see default devices.

4) From the guest machines device menu select the usb option and mount the plantronics device.

At this point I see the plantronics device appear in the guests sound settings window after which the guest machine becomes unresponsive and never recovers. Attempting to shut down or power off the virtual machine fails. The only ways I can get rid of the VM are to reboot the host machine or use "kill -9" as root on all vbox processes.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use