VirtualBox

Ticket #9785 (closed defect: worksforme)

Opened 3 years ago

Last modified 2 years ago

Set extradata for specific Machine not working

Reported by: lsga Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

To start a machine in kiosk mode, without using SDL, we're suppose to do :

VBoxManage setextradata [NAME] GUI/Customizations noMenuBar,noStatusBar

but it doesn't work. Only global customization Work :

VBoxManage setextradata global GUI/Customizations noMenuBar,noStatusBar

But this way, we can't set a Machine with menu, and an other without menu. This is on Ubuntu Linux Host, I still didn't make a try on Windows Host.

Context : I first tried global customization to switch off menus, then global customization to switch them on: it worked. Then I tried to swich menus off for specefic machine, and it didn't worked.

Change History

comment:1 follow-up: ↓ 2 Changed 2 years ago by frank

The documentation does not say that this setting is per-VM. So you can request this behavior but this would be a feature request, not a bug.

comment:2 in reply to: ↑ 1 Changed 2 years ago by lsga

Replying to frank:

The documentation does not say that this setting is per-VM. So you can request this behavior but this would be a feature request, not a bug.

So, what for stand the "[NAME]" in "setextradata [NAME]" if it can only be setted to "GLOBAL" ?

comment:3 Changed 2 years ago by frank

The setextradata [NAME] form is the generic one. It depends on the specific setting if a setting is global-only, per VM-only or either global or per VM. The GUI/Customizations setting is clearly described in the user manual section 9.18 and there is no such per-VM setting mentioned.

comment:4 Changed 2 years ago by lsga

Ok, thanks for your answer...

I'm so sad now :-(

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use