VirtualBox

Ticket #9770 (closed defect: fixed)

Opened 3 years ago

Last modified 6 months ago

Color problems with 3d acceleration Opengl - catia v5

Reported by: ramonet22 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.1.4 Keywords: catia 5 opengl color
Cc: Guest type: Windows
Host type: other

Description (last modified by misha) (diff)

Hi there,

we are having problems with 3d and catia v5. Catia part changes to white color when some operations are performed (such a section) or when we swap to another window inside Catia. I attach a video.

If I disable 3d acceleration, all works fine.

Change History

comment:1 Changed 3 years ago by ramonet22

comment:2 Changed 3 years ago by ramonet22

We have tested with several distributions of linux, and several versions of virtualbox with the same result.

We also tested to change nvidia linux graphics driver, several versions of windows (windows 7 64bits, windows xp 32 bits) and the problem appears too.

Thanks

Ramón

comment:3 Changed 3 years ago by ramonet22

Hi,

I've reproduced the error with a different hardware, concretely this graphic card:

Intel Corporation Mobile GM965/GL960

Regards

comment:4 Changed 2 years ago by saakman

I have the same problem.

I'm working on a designing business and We was very interested on use virtualbox for our daily work over our linux host running Windows VMs for Catia v5 R18, but this problem don't permit us to do our normally daily work. By this reason we prefer use other virtualization solutions such Wine trough VirtualGL.

Other problem with that I've been dreaming that he was solved, is the shadows on the application menus.

You can try to reproduce this other problem (shadows problem) using VirtualBox / 3D driver enabled on VM settings / and Catia v5.

This two problems are horrible for over eight hours designing.

Today, Catia v5 is unusable under VirtualBox 4.1.

comment:5 Changed 2 years ago by saakman

The problem occurs with all the nvidia portfolio that I have tested trying to find a solution:

  • Nvidia Quadro 4000
  • Nvidia Quadro 5000
  • Nvidia FX 4800
  • Nvidia GTX 260

Obviously the problem resides on the premature develop of the 3d feature of VirtualBox.

comment:6 Changed 2 years ago by saakman

Other thing to be present is that I have tested all 3d possible combinations.

3D enabled on VM settings a no D3D neither WDDM installed (only VGA generic driver provided by guest additions)

3D enabled on VM settings and WDDM driver installed (the problem persist, and appear an new problem, iexplore windows turn completely on black)

3D enabled on VM settings and D3D driver installed.

3D Disabled on VM settings: This configuration solve the shadows problem on Catia menus, but the problem of the colours (the model turn on white after going File / New / Open New Catalog) persist. Obviously this is not a good configuration, because with the 3D disabled on the settings of the VM, all the rendering workload is assumed by the CPU, and the 3D performance is very bad.

comment:7 Changed 2 years ago by Markcards

Hi there,

At the first i will resume the technical specifications of the environment Im using for run VirtualBox:

Workstation Fujitsu Celsius R670-2:

  • 2 Cpus Intel Xeon e5645 6 Cores 2.4 Ghz.
  • 64 GB RAM
  • Nvidia Quadro 5000
  • 2 x 250GB SATA Disks
  • Enabled VTx options
  • Disabled Hyperthreading

Native OS: Oracle Enterprise Linux 6.1

VirtualBox version: 4.1.4 (installed from de yum repository of Vbox for RHEL)

Virtual Machine Configuration:

  • Four vCPUs 100% dedicated to the VM
  • 8 GB vRAM
  • SATA Controller
  • PAE activated
  • VTX activated
  • Sound Disabled
  • USB 2.0 disabled

Guest opertating System

  • Windows 7 64 bits Professional
  • Guest additions installed (including D3D and WDDM support)

3D Applications

  • Catia v5
  • UGNX

The main problem is the bad graphical performance reached, natively Catia and UGNX works at the maximum Frame Rate without appear artifacts, neither appears changes of colours on the models that I use.

When I try to simulate the same environment trough virtualbox, the performance decrease a lot, but this is asumible because the virtualization is an aditional layer and it use certain resources. The problem is that the models sometimes turn on white, the application menus leave a shadow on the screen, and definitely is impossible to work normally without problems.

I think the problem is the generic 3d graphic card that provide Virtualbox, this generic card can't use all the performance and values given from my Nvidia Quadro 5000 card.

The problem is very important to me, this environment isnt a test environment, is a producction environment.

comment:8 Changed 2 years ago by saakman

The problem persist on 4.1.6 release....

comment:9 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

This issue is likely to be fixed with VBox 4.3. Please try it with VBox 4.3 and 4.3 Additions, and re-open if needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use