VirtualBox

Ticket #9740 (closed defect: fixed)

Opened 3 years ago

Last modified 21 months ago

"Cable connected" option is not persisted with "Paravirtualized Network"

Reported by: danf84 Owned by:
Priority: minor Component: network
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Before starting the VM, set "Adapter 1" to NAT, set adapter type to "Paravirtualized Network", and untick "Cable connected".

Start the VM, when logged on, while the VM is running, tick "Cable connected" in Network settings. Restart the VM - the cable is reported as unplugged in the OS, despite the new settings showing that "Cable connected" option is ticked.

The only solution is to shutdown the VM, then start it (there's no need to change the settings, just a shutdown and start again).

The same problem will occur if you start with "Cable connected" ticked", and when the VM starts, untick "Cable connected", and when you restart the VM, the OS reported that the cable is still plugged in.

Guest: XP, host Windows 7 x64.

Attachments

TEST-2012-07-20-12-17-18.log Download (74.9 KB) - added by danf84 21 months ago.

Change History

comment:1 Changed 2 years ago by frank

Please attach a VBox.log file for such a VM session. I don't have a Windows XP guest with paravirtualized network drivers available but I couldn't reproduce this problem with a Linux guest.

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing.

Changed 21 months ago by danf84

comment:3 Changed 21 months ago by danf84

Same problem with 4.1.18; attached the log file from a clean vm, I ran it for the first time with cable unplugged, when booted into the OS, set cable to plugged in, then restarted the guest, the cable became unplugged again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use