VirtualBox

Ticket #9737 (closed defect: worksforme)

Opened 3 years ago

Last modified 20 months ago

Starting a virtual machine returns VERR_LDR_MISMATCH_NATIVE error.

Reported by: mfloryan Owned by:
Priority: minor Component: VM control
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

A fresh installation of VirtualBox 4.1.4 on Windows 7 32-bit An attempt to run any virtual machine results in the following error:

Failed to open a session for the virtual machine openSuSE-12.1.

Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE).

Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

It works when VirtualBox is started as Administrator.

The user logged in already has a local administrator rights on the machine.

Attachments

VBox.log Download (1.1 KB) - added by mfloryan 3 years ago.
Log file describing the problem
vbox.log Download (1.1 KB) - added by vs40fresh 2 years ago.

Change History

Changed 3 years ago by mfloryan

Log file describing the problem

Changed 2 years ago by vs40fresh

comment:1 Changed 2 years ago by vs40fresh

This is also happening for me.

I'm trying to upgrade my install from 3.1.4.0 r57640 to 4.1.8 r75467. My host OS is Win7.

I'm running with UAC disabled, using an Administrator account, and have no VirtualStore directory. Running as admin using the right click context menu makes no difference. Running with UAC enabled as either a Standard User or Administrator makes no difference. I've made sure all previous installed files and folders are removed, prior to installing 4.1.8, but yet the problem still occurs.

It sounds like why most users are saying running as administrator works for them is because when they do that, they then have permissions to modify the Program Files directory, and VirtualBox is no longer using some stale data/config information that may have been left behind from the previous installation. This isn't really a solution, it's more like a temporary workaround.

comment:2 Changed 2 years ago by Dhjohn

Have just loaded the latest update, and this problem has suddenly appeared. The reason for failure seems clunky, better design needed.

comment:3 Changed 2 years ago by frank

  • Description modified (diff)

Can only be some installation issue. Is the problem reproducible if after you uninstalled and re-installed VirtualBox?

comment:4 Changed 20 months ago by Ajju

Dear Freank,

I too have the same problem. I am the administrator for the PC but I am not able to access the VM. when I am tryong to access the VM it is giving the error as below

Failed to open a session for the virtual machine AX RETAIL 2012.

Failed to open image 'G:\AX RETAIL 2012\Microsoft Dynamics AX 2012 FP - AX2012-A\Virtual Hard Disks\AX2012-A.vhd' for writing due to wrong permissions (VERR_VD_IMAGE_READ_ONLY).

Failed to attach driver below us! Image is read-only. (VERR_VD_IMAGE_READ_ONLY).

PIIX3 cannot attach drive to the Primary Master (VERR_VD_IMAGE_READ_ONLY).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

and I uninstalled and reinstalled the VM so many times but the same problem persists.

I went to the path C:\USERS\<username>\AppData\Local\VirtualStore\Program Files And then I didn't find any Oracle VM related files or folders. I didn't understand this oint posted by one user(and then rmdir /s Oracle)

and I'm unable to attach the log file. So I'm pasting the some part of log file here

00:00:03.684 AHCI ATA: Ctl: finished processing RESET 00:00:03.685 AHCI ATA: Ctl: finished processing RESET 00:00:03.685 AHCI ATA: Ctl: finished processing RESET 00:00:03.686 DrvBlock: Flushes will be ignored 00:00:03.686 DrvBlock: Async flushes will be passed to the disk 00:00:03.686 VDInit finished 00:00:03.745 VMSetError: D:\tinderbox\win-4.1\src\VBox\Devices\Storage\DrvVD.cpp(2593) drvvdConstruct; rc=VERR_VD_IMAGE_READ_ONLY 00:00:03.746 VMSetError: Failed to open image 'G:\AX RETAIL 2012\Microsoft Dynamics AX 2012 FP - AX2012-A\Virtual Hard Disks\AX2012-A.vhd' for writing due to wrong permissions 00:00:03.756 VMSetError: D:\tinderbox\win-4.1\src\VBox\Devices\Storage\DrvBlock.cpp(963) drvblockConstruct; rc=VERR_VD_IMAGE_READ_ONLY 00:00:03.756 VMSetError: Failed to attach driver below us! Image is read-only. 00:00:03.756 VMSetError: D:\tinderbox\win-4.1\src\VBox\Devices\Storage\DevATA.cpp(7285) ataR3Construct; rc=VERR_VD_IMAGE_READ_ONLY 00:00:03.756 VMSetError: PIIX3 cannot attach drive to the Primary Master 00:00:03.756 PDM: Failed to construct 'piix3ide'/0! VERR_VD_IMAGE_READ_ONLY (-3205) - Image is read-only. 00:00:03.771 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={Failed to open image 'G:\AX RETAIL 2012\Microsoft Dynamics AX 2012 FP - AX2012-A\Virtual Hard Disks\AX2012-A.vhd' for writing due to wrong permissions (VERR_VD_IMAGE_READ_ONLY). 00:00:03.771 Failed to attach driver below us! Image is read-only. (VERR_VD_IMAGE_READ_ONLY). 00:00:03.771 PIIX3 cannot attach drive to the Primary Master (VERR_VD_IMAGE_READ_ONLY)}, preserve=false 00:00:03.863 Power up failed (vrc=VERR_VD_IMAGE_READ_ONLY, rc=E_FAIL (0X80004005)) 00:00:04.322 VRDP: TCP server closed.

So please help me to solve the problem and also let me if any info required from me to solve the problem.

Version 1, edited 20 months ago by Ajju (previous) (next) (diff)

comment:5 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Ajju, the log clearly shows that the file 'G:\AX RETAIL 2012\Microsoft Dynamics AX 2012 FP - AX2012-A\Virtual Hard Disks\AX2012-A.vhd' is read-only for the user which starts VBox. This is definitely not a VirtualBox bug, it must be some permission problem on your host. Even if you are Administrator that does not mean that you have unlimited access to every file. You have to fix the permissions first. As nobody else answered to my requests 4 months ago, I will close this ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use