VirtualBox

Ticket #9732 (closed defect: worksforme)

Opened 3 years ago

Last modified 13 months ago

Mounting shared folder automatically does not work

Reported by: F Scheltens Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.4 Keywords: shared folder
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I am using windows 7 (64 bits) as a host system, and Linux Ubuntu (64 bits) as guest, latest version of Virtual box. I created a shared folder "Linuxfolder" in virtual box, and checked "mount automatically". I created a folder /home/username/Shared. I added the line to /etc/fstab: "Linuxfolder /home/username/Shared vboxsf defaults 0 0"

The problems i experienced with this were: -Unable to read the folder /media/sf_Linuxfolder (even after adding myself to the group vboxsf), insufficient rights.

-The folder /home/username/Shared was not mounted after booting. Mounting the folder manually DID work correctly.

Workaround: Unchecked the option to mount the shared folder automatically in virtualbox.

Effects:

  • I was able to read the folder /media/sf_Linuxfolder
  • The shared folder /home/username/Shared was properly mounted after boot.

Change History

comment:1 Changed 3 years ago by michael

Did you install or upgrade to the Guest Additions from version 4.1.4? They contain a fix which allows you to mount the same folder in several places at once. And did you log out and back in again after adding your user (on the guest) to the group vboxsf?

comment:2 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use